Jump to content
Forums

Report UE4 Bugs Here


Recommended Posts

  • NCSOFT

Dear Crickets,

 

With our latest upgrade for Blade & Soul to Unreal Engine 4 we wanted to make sure to provide the best experience we can to you. However, there are oftentimes sneaky bugs that are hiding from our sight.

If you encounter any bugs whether functional, visual, or text—please report them here in this thread. Our team will continue to review the game, but your reports will be much appreciated!

 

We ask you to please submit your bug report in the following structure:

  • Bug Summary: (Short description of the bug)
  • Reproduction steps: (List a steps of actions you took that lead to the bug if applicable)
  • Attachment: (Please add a screenshot or video if they can help identify the bug)
  • Additional information: (Any additional information you think can help us identify the issue, like your class, level, server or location)

 

Example Bug Report:

Bug Summary: The Waking Nightmare quest gives the wrong location for closing dark rifts

Reproduction steps:

1. I had the pre-requisites to start the Walking Nightmare quest, so I started the quest.

2. The quest objective states that I have to seal dark rifts in Dawnspring Forest.

3. I went to Dawnspring Forest but there are no dark rifts to seal.

Attachment: (here would be a screenshot of dark rifts visible in the dungeon and/or quest text)

Additional information: When I entered the Forest of Echoes Dungeon, I noticed that the dark rifts are there, so the quest description mentions the wrong location. I play the game in English.

 

Please only post your UE4 bug reports here.

 

Thank you for your reports!

Link to post
Share on other sites
  • Replies 381
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello,   I have an issue with key bindings Bug Summary: Number keys not recognised Reproduction steps: Plugin a standard French AZERTY keyboard, none of the number keys are registe

Bug Summary: Gamepad Option is no longer available in Options/Game/Camera settings Reproduction steps: Opened the Settings and go to Game/Camera tab and the Gamepad option is no longer at the bot

Hello, yep i was about to post it , none of the Azerty keys works on the First row on keybinds, bottom are fine  tho  A/E/SS (Q/E/SS) works even if you try to remap on rebind option it shown wrong key

I found a possible vulnerability.
How may I disclose it responsibly (preferably in private)?

 

If this is a real vulnerability, it should be fixed ASAP, before the game is even online.

Edited by Cupidstar
Link to post
Share on other sites

Theres a issue with downloading the UE4 client with NC launcher 2.

it stops downloading at some point with some Error message, that you are not able to download a certain file, even after scanning the issues and so on nothing helped so you are basicly in a downloading loop.

To fix this issue, go to example where you wanna install the game: C:\Program Files (x86)\NCSOFT\BnS_UE4

Then delete he $PATCH$ folder completly and restart the NC launcher 2, this will fix the downloading loop & he start to download the rest.

Good luck.

Please like if it helped :)

  • Like 1
Link to post
Share on other sites

Hello,

 

I have an issue with key bindings

Bug Summary: Number keys not recognised

Reproduction steps: Plugin a standard French AZERTY keyboard, none of the number keys are registering

Additional information: The issue seems to disappear whenever I switch to a QWERTY layout

  • Like 8
Link to post
Share on other sites
9 minutes ago, Psaro said:

Hello,

 

I have an issue with key bindings

Bug Summary: Number keys not recognised

Reproduction steps: Plugin a standard French AZERTY keyboard, none of the number keys are registering

Additional information: The issue seems to disappear whenever I switch to a QWERTY layout

Hello, yep i was about to post it , none of the Azerty keys works on the First row on keybinds, bottom are fine  tho  A/E/SS (Q/E/SS) works even if you try to remap on rebind option it shown wrong keys ...

 

Edit : Key from 1 to 0 on dont work

Edited by Azzuray
additional
  • Like 4
  • Thanks 1
Link to post
Share on other sites

Hi,

 

I also have a issue with key bindings

Bug Summary: Gamepad Buttons Not Reconized. Cannot bind any Gamepad buttons Movement Control. 

Reproduction steps: Using a Logitech Cpu Gamepad Dont have to do anything.

Additional information: The issue never resolves says i can even press Gamepad buttons but it does nothing.

  • Like 2
Link to post
Share on other sites

Bug Summary: Gamepad Option is no longer available in Options/Game/Camera settings

Reproduction steps: Opened the Settings and go to Game/Camera tab and the Gamepad option is no longer at the bottom of that tab.

 

  • Like 6
Link to post
Share on other sites
48 minutes ago, Vansan2000 said:

Bug Summary: Gamepad Option is no longer available in Options/Game/Camera settings

Reproduction steps: Opened the Settings and go to Game/Camera tab and the Gamepad option is no longer at the bottom of that tab.

 

You Cant even Manually Map the buttons to a Profiler, NC Soft Please fix this i have waited for a Very Long time for this and this is becoming underwhelming i cant even play.

  • Like 1
Link to post
Share on other sites

Bug Summary: since BD got his "Wind Slash removed and replaced with Hurricane Slash , it doesnt actualise on IA Amulet ...

Reproduction steps: Go on merchant and try to change ...

Attachment:urOOaFq.png

Additional: BD Wind 

Link to post
Share on other sites

Bug Summary: Can't type and run anymore

Reproduction steps:

1. Run

2. Press enter

3. You will stop and after you type, the next time you press w, you will sprint

 

Additional information: This worked flawlessly on UE3, and is an important tool for talking on the way to a raid or party.

Link to post
Share on other sites

Bug Summary: Changing resolution caused fps to plummet

Reproduction steps:

1. The game was running in 1080p (which is less than my monitor's native resolution) so I decided to alter the resolution in "graphics settings"

2. I selected borderless window mode

3. I set the resolution of the game to "2560 x 1440 (wide)"

4. I selected "apply"

5. Immediately, my fps plummeted to a point at which the game may as well have been frozen

Additional information: The game was running at 60fps in 1080p. Now it launches in this same state and I am unable to log in due to an inability to enter the multi-factor authentication code as a result of extremely low fps.

Edited by voldar
Link to post
Share on other sites

Don't know if its a bug or it is intended mechanic, but Dragon Trader Junsorei doesn't offer the chest for belt/gloves that should be offering when you complete the 300 run marathon. However it does offer the breakthrough chest. This means the only way to obtain the new gloves and belt is dropping chest from Forest of Echoes. Is this intended or there is an error in the build and we should have this chest available but locked to achievement?

Link to post
Share on other sites

Also uzume ring earring and bracelet gone from Junsorei Trader, those of us who did 300+ runs can't buy an accessory now and rely on boss drop in Hard Mode. Hello? I think you guys screwed up with the updates, this should be done with Mythical dungeons when this accessories are not relevant anymore, now you screwed it super hard and getting gloves/belt is going to be an even harder grindfest than 300 runs because good luck dropping 8 chests (2 per party member so 2x4=8), that assuming you are running with a static group, if you're running with random people, good luck have fun. Please fix Dragon Trader Junsorei.

Link to post
Share on other sites
2 hours ago, SonNiku said:

You Cant even Manually Map the buttons to a Profiler, NC Soft Please fix this i have waited for a Very Long time for this and this is becoming underwhelming i cant even play.

its seem that the developers decide to left that freature die... so now we (the controller players) can move out to other games... yea im mad about it.

  • Like 2
Link to post
Share on other sites

Bug Summary: Turning ("Camera X-axis Speed") inconsistently drops dramatically while airborne

Reproduction steps:

1. When running and jumping to glide across the first gulf in Silversteel Laboratory, my character barely turned at all, I had to lift my mouse and swing twice to make the ~45 degree turn.  Upon landing, turning was normal again.  (After this and before the remaining examples I increased "Camera X-axis Speed" to the maximum of 100)

2. When jumping down from the long platform where the first combat occurs in Silversteel Laboratory to the round platform where the second occurs, again my character turned extremely slowly, and again this was fixed upon landing.

3. When running out of the pipe leading to the final combat in Silversteel Laboratory this again happened (note that I didn't even jump this time, so it's not triggered by the jumping).

Additional information: In the first case above I was windstriding, jumping, and on the ascending part of the jump when the slow turning occurred; in the last case above I was not windstriding (not even gliding), not jumping, and descending.  The only similarity was being airborne inside Silversteel Laboratory.  I have not been able to reproduce this issue anywhere else so far, and couldn't even reproduce it consistently inside of Silversteel Laboratory.

edit: I was just able to replicate a similar issue while in combat in Sandstorm Temple, with turning speed dropping dramatically, although not quite as much as in the above examples.

Edited by willietrom
Link to post
Share on other sites

Hello,

 

I've logged in after the patch and received the resurgence outfit selection chest.  I wanted to see what it looks like before i picked the outfit and tried to use Shift + left click.. it doesn't seem to be working.

It also isn't working when i try to see an outfit another player is wearing.  It worked fine before the patch.. please advise 🙂

 

Thanks,

Sèah

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...