Jump to content
Forums

FPS Loss - May 23 2018 - Windows 10 Update: KB4100403


Ludicium
 Share

Recommended Posts

Just wondering if anyone else is experiencing FPS loss after the May 23rd Windows Update - the most recent one (KB4100403 - Build 17134.81)?

My FPS was fine until this most recent update - currently, I'm not even able to run dungeons anymore as when the boss fight starts, I instantly drop down to 2-7 FPS. Prior to this update I was at a stable 20 FPS in dungeons (playing on a Laptop - yes).

Along with that Koldrak Lair and even Celestial Basin boss fights/events have all suffered too.

I've turned all graphic settings down to 1 except for Monster Effect Quality cause...I need to be able to see the attacks. Prior to this, I had my settings on a mix of 3-5 and was fine. I am still experiencing FPS loss even with these changes.

 

Not relevant but, for those who are curious, my laptop is running on a i7-7700HQ - 4 cores, NVIDIA GeForce GTX 1060 - yes, I know, I'm limiting my FPS hard w/ a laptop, but my work doesn't allow me to have the luxury of a desktop - but that's besides the point, was just curious as to if anyone was experiencing similar issues as myself or if anyone has found any kind of solutions.

 

I have assigned all cores to BnS, and set priority high (played with normal too).

Link to comment
Share on other sites

7 hours ago, The Hepta K said:

Disable your Bluetooth in device manager.

It helped increase it by 1-4 FPS - still not the normal FPS I'd get prior to the update though.

@Kisong - along with @The Hepta K's suggestion, I also tried repairing the files - not sure if disabling the bluetooth was helped, or if it was the repair file, but maybe try that?

Link to comment
Share on other sites

Have turned down graphics settings in both Nvidia control panel as well as in game -- no difference.

 

During non-combat, I can get 48FPS no prob (have it limited to 48).  Have modern machine (max 3.1GHz) and

modern graphics card (1080GTX).  My first thought was they accidently left internal debugging turned on that

disabled optimization. 

 

Second thought is XIGNCODE running in a separate process again.  Previously it

seemed to all run in 1 process, but now it looks like 2 and looks like all the I/O from the Client is sent

through the 2nd exe and back... like it is auditing all the I/O that's going on.  That might explain all the slow

down right there, since if its trying to process all of the Client's I/O -- even with no processing in the new

process, the I/O consumption and I/O overhead would slow things down.  Then any processing the new

xigncode thing does would be added to the extra I/O overhead.  That *could* be a large part of it, though

it might be that with some debug overhead turned on... dunno. 

 

Consistent with the I/O overhead -- it seems like my keypresses in battle are somewhat lagged.  Like I'll press a key

and it won't take immediately -- and if something else comes up to interrupt it, the key is tossed.

 

Have noticed on some auto-repeat keys -- they can block out or noticeably delay processing of

another key coming in...  Almost like there is a buffer-queue of keys and all the keys are being slowed down

because the buffer is lagging.  Would explain why battle is worse, as keypresses are going fast and furious then and

if the buffer starts to fill, lag would go way up -- it doesn't drop the keys, but they are processed too late for what

is currently happening.  So say my kb or mouse sends pulses at 200ms or 150ms intervals, if the average

time to process a key is slowed down due to the I/O overhead, then I/O can get behind and video refreshes

are starved for data.  AT 48FPS, need full screen's worth of data (2560x1600 for me), every 21ms, instead, w/lags

am seeing maybe 83 ms/update giving 1/4th the update rate.  So it really could be tied to something that

slows down I/O processing -- like sending all the I/O through an external audit-prog that then passes the

I/O back for processing or sending over the network.

 

If you need to have the XIGNCODE stuff -- can't you build the client so everything is in 1 process?  That way

you'd save a bunch of I/O overhead transferring everything between processes and forcing a bunch of

context switching (and likely resulting in abysmal cpu-cache usage).

 

I don't have any Blue-Tooth to disable  all my net connects are wired.

 

Dunno if new maintenance version is different or not... too early to tell for me.

 

 

Link to comment
Share on other sites

I have exactly same problem as OP. My two friends applied that big Windows 10 update and stuck at 15 fps max. Before the update, they both had average of 55 fps and no lagging whatsoever. Fortunately I don't have that version of win 10 yet but I'm scared. Pls look into this NCsoft, it's ruining our gameplay experiences.

 

Oh, and we are all playing on laptops if it helps and already tried that BT disable, drivers update and made sure we are running the game on dedicated graphics cards.

Edited by Yndyss
  • Like 2
Link to comment
Share on other sites

Update:
I think I have found a solution - might just be for laptop users so (@Yndyss) as I am using a laptop. Apparently, I think the update might have changed our battery settings. Do not click on "Power options", etc. that probably didn't change, however, if you click on the battery icon itself, there should be a slider, slide that to "Best Performance" - mine was apparently set to "Balance". Once I made that change, I am now getting ~70 FPS.

Link to comment
Share on other sites

On 6/8/2018 at 1:19 AM, Ludicium said:

Update:
I think I have found a solution - might just be for laptop users so (@Yndyss) as I am using a laptop. Apparently, I think the update might have changed our battery settings. Do not click on "Power options", etc. that probably didn't change, however, if you click on the battery icon itself, there should be a slider, slide that to "Best Performance" - mine was apparently set to "Balance". Once I made that change, I am now getting ~70 FPS.

Tried it - still garbage. For some reason, not only is my FPS ludicrously low (7fps during combat today in Sanctum), but my ping is in the mid-to-high 200s, when it should be lower (barely over 100, 150 tops).

 

I've even tried doing a lot of the work in other guides. Nada.

 

Decided to just revert to the previous, non-updated version - runs fine.

Edited by SilverFoxR
Link to comment
Share on other sites

On 8. 6. 2018 at 7:19 AM, Ludicium said:

Update:
I think I have found a solution - might just be for laptop users so (@Yndyss) as I am using a laptop. Apparently, I think the update might have changed our battery settings. Do not click on "Power options", etc. that probably didn't change, however, if you click on the battery icon itself, there should be a slider, slide that to "Best Performance" - mine was apparently set to "Balance". Once I made that change, I am now getting ~70 FPS.

Yeah, I tried that as well and nothing changed. Now I have this f**ed up windows version too and my fps dropped from avg 55 to 24. I tried this "best performance", things from video below, updated driver for dedicated GPU and disabling bluetooth again. Bluetooth gave me cca +3 fps and disabled in-game special effects and windows settings tweaking something like +4. But when I'm battling bosses, it lags horribly. Same goes for my 2 friends. Today I'll try to reinstall BnS, but I don't expect much. 

 

I saw some forum threads elsewhere about this win10 update issue. So it seems like it's not BnS only. Fix to this mess clearly needs to come from Microsoft or NCsoft. I'm afraid we can do sh*t about that.

 

 

Link to comment
Share on other sites

On 09/06/2018 at 11:03 AM, SilverFoxR said:

Tried it - still garbage. For some reason, not only is my FPS ludicrously low (7fps during combat today in Sanctum), but my ping is in the mid-to-high 200s, when it should be lower (barely over 100, 150 tops).

I've even tried doing a lot of the work in other guides. Nada.

Decided to just revert to the previous, non- version - runs fine.

 

4 hours ago, Yndyss said:

Yeah, I tried that as well and nothing changed. Now I have this f**ed up windows version too and my fps dropped from avg 55 to 24. I tried this "best performance", things from video below, updated driver for dedicated GPU and disabling bluetooth again. Bluetooth gave me cca +3 fps and disabled in-game special effects and windows settings tweaking something like +4. But when I'm battupdatedling bosses, it lags horribly. Same goes for my 2 friends. Today I'll try to reinstall BnS, but I don't expect much. 

I saw some forum threads elsewhere about this win10 update issue. So it seems like it's not BnS only. Fix to this mess clearly needs to come from Microsoft or NCsoft. I'm afraid we can do sh*t about that.

 

Ah shucks, that stinks. I'll continue to try new ways of fixing it - keep you guys posted. Sorry my suggestion didn't do squat.
I guess, welcome to the window's update that screwed everything..club XD my heart goes out to you guys. 
But, yeah, I tried the suggestion in the video too, didn't do squat for me too :/

I really wish and hope that they're working on Unreal Engine 4 and getting it out to us - we seriously need it, UE 3 is just so outdated that the FPS we get from our newer gen. PCs/Laptops is so bad...

 

Or like you said, hopefully they'll do something to fix it, as it's clearly not just affecting a handful of players - another 5 members from my clan and another friend are also facing this sudden FPS loss due to the window's update - dropping down to ~20 FPS too.

Edited by Ludicium
Link to comment
Share on other sites

OK guys, so I may have solution. It's not ideal, but works for me. Here is the story:

 

As I posted before, I tried to reinstall the game and it didn't work - as I thought. (And I'm not speaking about sh*t I went through to install the game - disabling antivirus + antimalware, running launcher in compatibility mode, ...) So next thing I tried was running the game in 32-bit version. You can easily do it in launcher settings.  And then fps was high as before the windows update.

 

But here is the catch - I read elsewhere, that this 32-bit version is unstable (for me it crashed during loading screen when I switched workspaces, but dungeon runs are fine for now). Also it's like riding a bike when you have lambo in garage. But it's the closest thing to solution I can think of now...

 

Hope it helps.

Link to comment
Share on other sites

4 hours ago, Yndyss said:

OK guys, so I may have solution. It's not ideal, but works for me. Here is the story:

As I posted before, I tried to reinstall the game and it didn't work - as I thought. (And I'm not speaking about sh*t I went through to install the game - disabling antivirus + antimalware, running launcher in compatibility mode, ...) So next thing I tried was running the game in 32-bit version. You can easily do it in launcher settings.  And then fps was high as before the windows update.

But here is the catch - I read elsewhere, that this 32-bit version is unstable (for me it crashed during loading screen when I switched workspaces, but dungeon runs are fine for now). Also it's like riding a bike when you have lambo in garage. But it's the closest thing to solution I can think of now...

Hope it helps.

Oo! I forgot about the 32-bit version of the game! Thank you for the reminder! I'll definitely tell my clanmates about this temp. fix. 

 

The thing is with BnS and it's FPS is that due to the outdated UE3 making it so that it's insanely heavy on the CPU processor, so lowering it from 64-bit to 32-bit will lessen the strain on the CPU, allowing for better FPS - makes for faster loading screens and launch of the game, but at the same time, you have to pray that you don't crash during the loading screens XD

 

But yeah, thanks again for this fix! ^^

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...