Adeptguy

[Bug] Mouse is NOT locked to fullscreen mode (with workaround!)

Recommended Posts

Adeptguy   

Im using a laptop so obviously I have a single monitor. Note: this bug happens at any resolution in fullscreen mode. Having said that:

 

The first time I entered the tutorial area where I could move around I immediately noticed that when I move my mouse a bit too long in only one direction the mouse jumps out of fullscreen mode as if it was windowed mode. When I move the camera then it isnt as smooth anymore and actually is game breaking because the frames stutter massively, we are talking about missing a nearly full second worth of frames. Imagine playing with 5 FPS. But this has nothing to do with FPS, it has to do with the mouse jumping out of "window" in "fullscreen" mode.

 

I can only come to the conclusion that what you call "fullscreen" mode is a fake fullscreen mode, also called "borderless windowed mode". This is again, a game breaking bug that prevents people from playing the game smoothly and effectively when your mouse causes you to stutter majorly because it keeps jumping out of your window. No wonder when you alt-tab out from "fullscreen" mode it goes instantly, usually in other games you get a temporary black screen for a second or so before it tabs out, in B&S it goes instantly. Another indication of borderless windowed mode.

 

Please add an actual fullscreen mode where the mouse is kept inside the actual game window. I could not make a screenshot of this, believe me I tried... But you can replicate it easily. Steps:

1. Be in fullscreen mode.

2. Hold alt and move the mouse wherever you think is a good spot and let go of alt. I personally move my mouse to the very center of the screen for guaranteed visual feedback.

3. Move the camera in Blade and Soul Camera mode (there are two modes, this is the default one but still making sure) in one direction. I prefer moving my mouse to the left.

4. Keep moving and eventually you will see for yourself, the mouse jumps out of window, as if the game is played in a window (because the mouse is not locked to the fullscreen mode obviously, only explanation).

 

If you need more details or evidence, I guess I can provide it but this should be sufficient. After all I havent discovered America here...

 

 

 

EDIT:

After trying the following thing myself I can confirm that there is a workaround for this issue, ITS STILL NOT FIXED THOUGH! But at least there is a workaround for it.

Important: after you apply said workaround, its fixed forgood. So you dont have to do this everytime. Credits to Spongebob for pointing it out!

 

On 19-1-2016 at 8:32 PM, Spongebob said:

its annoying that it still happens but you can "fix it temporarily" by pressing ALT+ENTER at the exact same time the screen will go black for second then just change your resolution to something else then back the cursor should no longer appear

 

On 19-1-2016 at 11:18 PM, Spongebob said:

its right alt+enter and you have to time it right for it to work like literally press them at the exact same time dont hold one then press the other

 

Edited by Adeptguy

Share this post


Link to post
Share on other sites

+1 for this to get fixed please im just going to wait until this is fixed to start playing its to annoying to try and play while this is happening

Share this post


Link to post
Share on other sites
Adeptguy   
12 minutes ago, Spongebob said:

+1 for this to get fixed please im just going to wait until this is fixed to start playing its to annoying to try and play while this is happening

I feel you man, Ill try to play on my char but I bet it will be so annoying that the game will already make me quit it before I even began.

Share this post


Link to post
Share on other sites

its annoying that it still happens but you can "fix it temporarily" by pressing ALT+ENTER at the exact same time the screen will go black for second then just change your resolution to something else then back the cursor should no longer appear

Share this post


Link to post
Share on other sites
Adeptguy   
2 hours ago, Spongebob said:

its annoying that it still happens but you can "fix it temporarily" by pressing ALT+ENTER at the exact same time the screen will go black for second then just change your resolution to something else then back the cursor should no longer appear

That doesnt even work for me lol. I get nothing when I press either the left or right alt + enter. Its like its stuck on borderless windowed mode.

Share this post


Link to post
Share on other sites

its right alt+enter and you have to time it right for it to work like literally press them at the exact same time dont hold one then press the other

Share this post


Link to post
Share on other sites
Adeptguy   
On 19-1-2016 at 11:18 PM, Spongebob said:

its right alt+enter and you have to time it right for it to work like literally press them at the exact same time dont hold one then press the other

It would seem that it is true what you said, you have to literally press both buttons at the exact same time for it to work. I will edit my original post but this still remains an issue though. That the community found a workaround for that doesnt mean its fixed, but thanks for passing this very usefull info along! :)

Share this post


Link to post
Share on other sites
3smycer   

Why is this still an issue? Is there any known solutions or trix to fix this in 2020 that I've missed?

Share this post


Link to post
Share on other sites

Does this affect performance in any way? I tried it and it does indeed work, I didn't need to change resolutions after and it worked with left or right alt enter. It puts it in like a true full screen mode and if you ever want to undo it alt enter left nor right won't undo it you have to go to client.exe in program files x86 (or wherever you installed bns to) ncsoft bns folder bin64 if you're using 64 bit client bin for 32 bit and uncheck the high dpi scaling checkbox but then you'd be back to square one. I did the fix and it works before I could only move to the right or down, up or left would be like if you continuously tapped alt rapidly to flash the mouse cursor and lower your fps. So performance would go up without the annoying mouse cursor coming through but otherwise is it harder on your system I wonder? I haven't ran anything to test it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now