Jump to content
Forums

Laptop Overheated?


CatOnFirez

Recommended Posts

Hi,

 

I  tried to play Blade and Soul with my laptop and the GPU temperature went as high as 91celcius.. which is not funny.

The problem only happened when I run this game.. 

 

Already reduce and minimize the graphic setting in the game but it seems the GPU temp keep at 80-91...

 

Please help.. 

Link to comment
Share on other sites

34 minutes ago, TheSenpai said:

Not a whole lot you can do in a situation like this. First stop would be to check for a driver update, but I have a feeling in this case, support will blame the GPU.

 

Thank you for the reply. My drive is up to date and this is worrying me as I'm playing at high risk. I wonder if there any laptop users facing the same problem as I am.

 

 

Link to comment
Share on other sites

My laptop spec as below :

i7-4702MQ 2.20 GHz (8 CPUS)

12GB RAM

DirectX 12

GPU (Render) : Nvidia Geforce GTX 760M

Display 1 and 2 : Intel (R) Graphics 4600

 

Usually at other game my max temp is 70 after several hours of gaming however this game easily went over 90 within 10 minutes.

I've sent services and dust off last few months ago.

Link to comment
Share on other sites

Get the latest drivers from Nvidia for your GPU.

When you can play other equivalent games then there must be a problem with the software.

Have a look in the Nvidia control panel. Try to reduce some quality settings there.

Link to comment
Share on other sites

On 1/19/2016 at 6:42 PM, Drao said:

Get the latest drivers from Nvidia for your GPU.

When you can play other equivalent games then there must be a problem with the software.

Have a look in the Nvidia control panel. Try to reduce some quality settings there.

 

Thanks for the  reply.

I've selected the Performance setting  instead of Quality at Nvidia panel.

Still wonder what could rise the temperature so fast when run this game.. I'm so afraid to play when see my temp went as high 95 today :(

Link to comment
Share on other sites

If your laptop has a proper ventilation, you might still look into frame limit. If you removed the limit without vsync, your card might be getting needlessly loaded. Probably not, but still a shot.  (In a different game, I once noticed my GPU is going nuts and reaching mid-80s, and the reason for that was that it was running 400 fps)

Speaking of which, even with the "frame limit" setting the game runs unlimited fps on cutscenes, unless you enable vsync. 

Link to comment
Share on other sites

as for laptops - very few laptops were designed for gaming - and BnS is demanding for an MMORPG. This coupled with an older GTX 7xxm card. It´s expected. It´s extremely hard to optimize airflow and cooling in a laptop, especially if you have a passive cooled GPU - so best advice is reduce your graphics settings and possibly your resolution. Make sure the laptop is placed on something that can move the heat away easily (like a stone table or a cooling pad) and not something that isolates (like playing in bed on the blanket).

 

Better yet - get a desktop pc, I could recommend you a full build for around $600-1200 depending on your location from stores in your country. And depending on how high end you want it to be.

Link to comment
Share on other sites

BnS is CPU intensive not GPU.

I think the 760M (with your System) should be good enough to play the game at least at mid settings with 1080p.

In my opinion your not coming any further here with your problem as it is very specific related to one GPU.

Report your problem directly to Nvidia. Maybe you get any help there.

 

 

Link to comment
Share on other sites

1 minute ago, Drao said:

BnS is CPU intensive not GPU.

I think the 760M (with your System) should be good enough to play the game at least at mid settings with 1080p.

In my opinion your not coming any further here with your problem as it is very specific related to one GPU.

Report your problem directly to Nvidia. Maybe you get any help there.

 

 

BnS is gpu intensive at max settings. It barely even loads my CPU to 15-20% while GPU is capped.

Link to comment
Share on other sites

Enhance is right - there is absolute no reason why a non overclocked cpu would overheat an entire laptop at 90+ celcius.

In fact, (depending on intel core or amd core and how many true cores the cpu has) the cpu would throttle then reboot at more than 80c.

 

The only possibly explanation is an overworked gpu combined with poor cooling and airflow. Possibly dust and other nasty stuff adding to the problem. I´ve seen examples of smokers clogging their fans and pc components to a degree where there was obvious coil whine on fans and massively reduced effective cooling.

 

 

Link to comment
Share on other sites

On 1/19/2016 at 6:42 PM, Drao said:

 

 

Something wrong again when I want to reply it's auto quote someone lol..

 

First of all, thank you guys for the replies. I've the cool pad and fan blowing near my laptop just for the sake of this game and the problem still persist.

I don't think I ever touch on FPS thingy, probably it's still as default which limited the FPS rate.

 

Don't think I can afford a desktop PC anytime soon, due I've other commitment to pay at end of month.. Hmm kinda disappointed because I can't play for long..

Whenever my temp went up 90, I will immediately quit the game.

 

Link to comment
Share on other sites

  • 2 weeks later...
On 1/19/2016 at 4:34 PM, CatOnFirez said:

Hi,

 

I  tried to play Blade and Soul with my laptop and the GPU temperature went as high as 91celcius.. which is not funny.

The problem only happened when I run this game.. 

 

Already reduce and minimize the graphic setting in the game but it seems the GPU temp keep at 80-91...

 

Please help.. 

Hi, I had the same problem my GPU would hit 90c, I fixed the problem rather simple.

 

Go into Settings > Graphics > Default Setting, half way down under Frame Rate, change the limit Frame Rate to lowest you can get it which should be 40, then turn on Vertical Sync. Job down your PC shouldn't go above 50-70 depending on the weather.

 

*Note, download MSI afterburner and turn on the GPU temp so you can watch your temp ingame, then play around with your graphics settings until your happy with the temp. I've got mine running rather high settings and sitting on 60-70 and its summer here.

Link to comment
Share on other sites

On 1/30/2016 at 5:58 PM, SaizoSol said:

Hi, I had the same problem my GPU would hit 90c, I fixed the problem rather simple.

 

Go into Settings > Graphics > Default Setting, half way down under Frame Rate, change the limit Frame Rate to lowest you can get it which should be 40, then turn on Vertical Sync. Job down your PC shouldn't go above 50-70 depending on the weather.

 

*Note, download MSI afterburner and turn on the GPU temp so you can watch your temp ingame, then play around with your graphics settings until your happy with the temp. I've got mine running rather high settings and sitting on 60-70 and its summer here.

 

Hi,

 

Thanks a lot, I'd as you  said above and it does help to reduce the temp from 90 to 70-80 only.

 

Again, thanks to all who did suggested the solution in this thread.

 

Best regards,

Cat

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...