Jump to content

NC Launcher 2 does not work


Recommended Posts

I have reinstalled the launcher, tried comps mode with win8, run as admin, installed into new location and this thing still will not start. I'm at the point where I uninstalled everything and now without the launcher working I cannot reinstall the game, Any idea's?


Oh and this did work yesterday and has been working fine. 

Link to comment
Share on other sites

  • 2 weeks later...

Try this out, it worked for my brother and I, is a bit scary as you need to add access permissions to Everyone.


Rclick(right click) NCSoft folder, lclick properies

Click on Security tab > edit > add

in that bottom box, type Everyone > lclick 'check names'  > lclick okay

lclick on Everyone in the top windows then at the bottom, lclick full control allow.

lclick okay and lclick yes, wait a while for it to finish and try the game.


this works too, if 'run admin' doesn't resolve issues ie not loading or loading very very slowly.

runnning software as admin usually works unless explicit permissions disallow inheritance.




Link to comment
Share on other sites

  • Create New...