Jump to content
Forums

Low FPS Problem on same settings


RavTH

Recommended Posts

I am not sure why but can somebody explain this to me why I can play on different bns version with this settings 70-100 FPS No problem.

7cce71d2c831c97165229a173cf1212c.png

While I get barely 40-50 fps on this version of bns with this settings.

4396aac291b39f5461a211cb4998bbc6.png

 

is there something wrong with this client?

I optimized my settings on NVIDIA Control Panel but no luck.

My system sepcs:

CPU: Intel(R) Core(TM) i7 3770k
GPU: NVIDIA GeForce GTX650
OS: Windows 10 Pro

Link to comment
Share on other sites

Something is wrong for me since the last update. I keep getting serious graphics lag and fps between 2 and 10.

 

AMD FX-8370 Eight-Core

AMD Radeon R9 290 4GB

16GB Ram

 

I am quite sure I should be running this game pretty good....as I was with 70+ FPS

I changed nothing on my system, just updated BnS and got screwed

Link to comment
Share on other sites

19 hours ago, Sunaj said:

Something is wrong for me since the last update. I keep getting serious graphics lag and fps between 2 and 10.

 

AMD FX-8370 Eight-Core

AMD Radeon R9 290 4GB

16GB Ram

 

I am quite sure I should be running this game pretty good....as I was with 70+ FPS

I changed nothing on my system, just updated BnS and got screwed

Could there be a chance that the executable Client file can be corrupted due to update content translations?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...