Jump to content
Forums

FPS Drops *Any tips?*


Xiviuz

Recommended Posts

I've searched and searched and searched and I've tried a lot to fix my FPS problem.

I've entered Nvidia control panel, set the priority of the game to High, turned down all graphics and turned them up. Nothing works.

I still hit rock bottom 8-20 FPS so damn often and it's gotten worse after every maintenance update.

 

Nvidia GeForce 940M

i5 Core - 4210U 1.7 GHz - turbo boost up to 2.7 GHz   ><   (no idea how to turbo boost tho).

8GB Ram

 

Please post any possible solutions that might help! :)

Link to comment
Share on other sites

Try ...

 

  • Turning on V-Sync in the in-game graphics options
  • Lowering your detail settings; especially resolution, shadows and view distances, in the in-game menus.
  • Make sure your power options are set to High or "Performance" or whatever.
  • Turning off things which run in the background. Especially stuff like F.lux which alter the screen
  • Making sure your PC isn't overheating, by downloading a utility like CPU-Z to check the temperatures.
  • Opening the launcher, going into settings and running a repair.
  • A bit of standard system maintenance using things like CCLeaner and defragging your HDD (If it's an HDD and not an SSD)
  • Checking your internet connection is stable and try to switch to a wired connection, if it's wireless.

 

That's about all I can think of right now, short of saying upgrade your laptop lol. But it's not worth it to upgrade for this game.

I don't think U-edition CPUs are so ideal for gaming, for various reasons. However it's an oldish game, so you shouldn't be having too many issues.

That said however, I myself get frequent drops too, but I've learned to ignore them. The game has a reputation for being badly optimised as well,

so you can take some solace in that I suppose. Also, turbo-boost is automatic; although it's for that reason it's kind of important to keep things cool,

so that the CPU won't slow itself down to prevent overheating.

Link to comment
Share on other sites

Thank you! really appreciate it :)
I will try it when i use my other computer. I just tried using my 5 year old computer with worse specs than my new one, but this one has windows 7 and my other one has windows 10 and better specs. I think windows 10 really mess it up some how?
Again, really appreciate your reply! thank you :)

Link to comment
Share on other sites

Haha, well that can explain it see. That's what I said about optimization lol. Chances are, since the game is like 4 years old (although has only been out around a month for EU and NA), it's more optimised for Win 7 than Win 10! I think it still runs DX 9 lol. While Win 10 is way ahead of that; which is meant to appeal to gamers. Haha, it's probably a textbook example of optimization. Is your other computer a laptop as well?

 

Try to run windows update and also update your Nvidia GPU drivers; which is easy if you have downloaded "GeForce Experience" from their website.

Link to comment
Share on other sites

Try this, when you have the game up (preferably at character select screen) open task manager and go to the "Details" tab. Right click on the BnS client .exe, go down to "Set Priority" and set it to "High" if it's not already. While you're there, click "Set Affinity" and make sure all your processors are checked. This helped me on my potato and a half.

 

Edit: you might need to do this each time you start BNS up

Link to comment
Share on other sites

I think it's an issue with Win8/10. My desktop is 4-5 years old with similar spec as my laptop which is 3-4 years old and it runs this game smoothly with 9 billion other applications running in the background, my GF has to set her settigns to lowest and drops the resolution down to play. Solo and dungeon is fine but one you get to the 10-20 range the game skips, BW just crashes the game. The only difference I see, and from other people listing their specs is the OS. Laptops and Desktops with Win 7 and lower specs outperforms PCs with Win 8 or 10 on this game. Maybe its time to downgrade my OS.

Link to comment
Share on other sites

1.download nvidia Inspector. (google it)

2. run the game.

3. alt tab and run nvidia inspector.

4. go back to the game (the grafics will reload)

5. go to setting active combat mod in advanced setting.

 

p.s: ONLY works on nvdia cards.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...