Jump to content
Forums

Game crashes randomly without any error message


Recommended Posts

Try these:
1- Disable your firewall.
2- Disable your Anti-Virus.
3- Start the game from the NCLauncher.exe in the game folder instead of the shortcut.

 

For the error message "The game is already running":
1- Press the "ALT + CTRL + Delete" buttons on your keyboard or just run "Task Manager" by right clicking on the task bar and choosing it..
2- Go to "Processes" Tap.
3- Search for the game process, it will be usually called "NCLauncher.exe" or "Blade and Soul.exe" or something like that.

4- Terminate the process and relaunch the game.

Link to comment
Share on other sites

15 minutes ago, Jouju said:

Try these:
1- Disable your firewall.
2- Disable your Anti-Virus.
3- Start the game from the NCLauncher.exe in the game folder instead of the shortcut.

its a fresh windows install, not 20 minutes old.

for security reasons i wont disable windows firewall or windows antivirus.

also, launching the nclauncher.exe directly gives me this error message: http://i.imgur.com/k36m7jF.png

 

Quote

For the error message "The game is already running":
1- Press the "ALT + CTRL + Delete" buttons on your keyboard or just run "Task Manager" by right clicking on the task bar and choosing it..
2- Go to "Processes" Tap.
3- Search for the game process, it will be usually called "NCLauncher.exe" or "Blade and Soul.exe" or something like that.

4- Terminate the process and relaunch the game.

there is no process running.

Link to comment
Share on other sites

If you're using windows 8.1 or windows 10 you'll find a button saying "More details" at the left corner of "Task Manager" this will show you all the processes running in your PC..
Also, I've been mistaken, you must run it from the shortcut on the desktop instead of the "NCLauncher.exe" in the game folder..

Disabling your Anti-Virus and Firewall may fix this, you can add an exception to the firewall settings instead of disabling it and run your Anti-Virus on "Gaming Mode"..
You can find how to add an exception to your firewall here: http://www.wikihow.com/Add-Exceptions-to-Windows-8-Firewall

Link to comment
Share on other sites

I used process explorer, but this time I didnt close the Launcher Window thingy.

The results are interesting. The Client and everything seem to be still running: KOTxX90.pngAs soon as I kill the Client (actually I think, killing GameMon.des should be enough) I can restart BnS again.

 

But thats still annoying, this time I was able to play ~15 minutes before it "crashed" (I dont even get the game crashed window. Only the window hides)

Link to comment
Share on other sites

I suppose it's your Anti-Virus stopping the game client.. Try using "Gaming Mode" option with your Anti-Virus..
If this didn't work, try these:
 

1- Run the game as Administrator.

2- Run the game in a compatibility with Windows 8.1, 7 or XP (SP2 or 3).

Link to comment
Share on other sites

try this 

 

Razer:

  • Go to task manager
  • Choose "Services"
  • Find "Razer Chroma SDK Service" and choose it
  • You can't stop it by right clicking it, it says access denied. You need to click that "Services"-button on lower right.
  • Find "Razer Chroma SDK Service" again, click "Actions" and "Stop" (it's grayed out on me, because I've already done it)
  • Click "Actions" again and choose "Properties"
  • Open the "Startup type"-drop box, and choose "Disabled", Apply, OK.
Link to comment
Share on other sites

I tried it out and so far I've been able to go at least 1+ hours without crashing. I ended up just doing all the recommended steps at once:
- Avast in gaming mode
- Let the game (and awesomeium) through my firewall

- Disabled the Razer SDK and kept it from starting on startup
- (And just for good measure) turned off Razer Synapse completely. 

So far I've had smooth sailing. A few stutters (hardly noticeable) but no crashes as of late. Thanks for the help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...