Sign in to follow this  
Exertus

Cannot Purchase Founders Pack?!

Recommended Posts

Exertus   

Okay, so I'm a little bit defeated right now as official launch is in a few hours. I've had this issue for about 2 or so days. I initially purchased the initiate founder pack and decided that I liked the game too much not to get the masters upgrade. However, every single time I clicked on the upgrade button a webpage would open and close and it'd give an error that says "Sorry, you do not meet the minimum requirements". I've tried many many times on various browsers including the ones on my mobile devices all with adblock disabled. I've sent in two support tickets and have yet to receive a reply - I was asked to try again in my first ticket and while it still didn't work I took a screenshot of the error and sent it in, but still no reply yet. Please guys, you're my last hope! Does anyone have an idea as to how I can get the upgrade? (Curious enough it let me upgrade to the disciple level...) :S

 

Edited by Exertus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this