Sign in to follow this  
Pulsing

High gpu load at characters selection screen

Recommended Posts

Pulsing   

I have a GTX 2070 super in my PC. At characters selection screen, my GPU load shoot up to 100% so as the GPU temperature and FAN speed. Once I enter the game, the load drops back to 30 to 40 percent.  How is this possible. Does characters selection screen require more GPU power?

Share this post


Link to post
Share on other sites

I have the same issue, but once i turn on the Vertical Sync (settings > graphics tab > Default Setting > Vertical Sync), the issue is solved, but the down side is that my fps will also be limit to max 60 fps (dunno how or why)

 

Share this post


Link to post
Share on other sites
RinDman   

Vertical Sync will synchronise your FPS to your monitor refresh rate, it was made this way to avoid screen tearing effects.

 

Other possibility is to limit your FPS and keep your power settings to auto on Nvidia panel. 

 

But this game is poorly coded, it proves the engine can use your GPU up to 100% ...

 

You'll see how the game runs poorly in raids  :)

Share this post


Link to post
Share on other sites

I recommend you to turn off Vertical Sync and turn shadows (all if it) down to low or off. Shadows cause a lot of issues for load on a GPU. Especially in this game as it does in SWTOR. I make sure Shadows are turned off in all the games I play just for that reason.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this