Sign in to follow this  
Hwarang Zhao

Low fps on high end PC

Recommended Posts

Okay guys,i frankly tried ALOT of stuff in order to fix my fps in this game (FPS in raids is what im interested in, not idle FPS)

I think there's not a thing i havent tried, but just in case im making this post for brainstorming

Im able to have 120 FPS on maxed out settings while idle, but as soon as my char tastes a bit of fight (raid, f8) FPS just drops to 15-30 and stays on it.

Note that this FPS drops happens even if i entirely lower all of the graphics settings , which makes me think there is no help in this god forsaken game. There is simply no logic behind a fact that i get same fps with reduced and with enhanced graphics. Below I'll list stuff i tried and my specs.

I tried:

 

- dx12 wrapper ( no change )

- Using bns buddy with all sorts of mods that remove textures and animations (gave me maybe 2-3 FPS in fights)

- nvidia profile ( this actually makes my FPS worse , the "let the 3d application decide" option in nvidia gives me better results )

- drivers checked

- reinstalled the game

- disabled fth

- using "ultimate performance" as a power plan

- OCed my cpu

- some more minor stuff, but i read that people mostly suggest stuff listed above so stating that they are done

 

my rig:

win 10 LTSC

i9 9900k @5.0 Ghz

rtx 2080 super

16 gb ram 2666MhZ -> manually oced to 3166Mhz

if u need any more specs, let me know

 

Okay guys, you know the drill, give me some juicy fixes!

 

 

 

Share this post


Link to post
Share on other sites

Generally the super duper performance enhancements that some users claim to suddenly skyrocket the FPS in BnS by are Voodoo BS - or the improvements are so low that only plebs with a toaster PC may feel an actual improvement. 

 

The solutions you tried are certainly not connected with your issue. DX12 wrapper, BNS buddy do little to absolutely nothing -- or even worse... A custom Nvidia profile may only benefit players with an Nvidia card that would normally belong into a museum... On your card, GPU settings for this joke engine are an absolute never mind (you may rather wonder how to improve the visual quality over default settings).

 

With your config things should be much better and they should be somewhat consistent - even you will still encounter FPS drops due to engine limitations they will be way less severe/they will only occur with much more characters and effects on screen.

 

Now it´s impossible to provide a satisfactory remote diagnosis like this but you can/should check a few things (and forget about the voodoo stuff):

 

-CHECK THOROUGHLY FOR THIRD PARTY PROGRAMS! And let go of the overzealous virus scanner, of the online cooperative office suite, of the ask.com search bar, of the whatever questionable things you may have running in the background. 

 

-"Drivers checked"? Absolutely sure? Also: not always the latest NVidia driver is the best - new bugs may have been introduced (check Nvidia board/reddit). Especially with super duper "RTX enabled"... 

 

-make sure you are not ping crippled - if you are waiting for server response this will also impact the fluency of your gameplay

 

-IDK but even on my OCed 9900k,1080 TI i (Windows 7) am not setting all full detail. Especially some of the Special Effects cripple the performance a lot (because of CPU limitations, it has nothing to do with GPU unless you are running museum hardware!). As a suggestion find my settings below, but experiment for yourself (effects for others set to 2 since this is the last setting that sill displays critical animations, for AA i am using ReShade). My FPS are somewhat okay to me which means normally not far below 60 and usually above 100.  

lFyHdTF.jpg

Share this post


Link to post
Share on other sites
57 minutes ago, weaponzero said:

Generally the super duper performance enhancements that some users claim to suddenly skyrocket the FPS in BnS by are Voodoo BS - or the improvements are so low that only plebs with a toaster PC may feel an actual improvement. 

 

The solutions you tried are certainly not connected with your issue. DX12 wrapper, BNS buddy do little to absolutely nothing -- or even worse... A custom Nvidia profile may only benefit players with an Nvidia card that would normally belong into a museum... On your card, GPU settings for this joke engine are an absolute never mind (you may rather wonder how to improve the visual quality over default settings).

 

With your config things should be much better and they should be somewhat consistent - even you will still encounter FPS drops due to engine limitations they will be way less severe/they will only occur with much more characters and effects on screen.

 

Now it´s impossible to provide a satisfactory remote diagnosis like this but you can/should check a few things (and forget about the voodoo stuff):

 

-CHECK THOROUGHLY FOR THIRD PARTY PROGRAMS! And let go of the overzealous virus scanner, of the online cooperative office suite, of the ask.com search bar, of the whatever questionable things you may have running in the background. 

 

-"Drivers checked"? Absolutely sure? Also: not always the latest NVidia driver is the best - new bugs may have been introduced (check Nvidia board/reddit). Especially with super duper "RTX enabled"... 

 

-make sure you are not ping crippled - if you are waiting for server response this will also impact the fluency of your gameplay

 

-IDK but even on my OCed 9900k,1080 TI i (Windows 7) am not setting all full detail. Especially some of the Special Effects cripple the performance a lot (because of CPU limitations, it has nothing to do with GPU unless you are running museum hardware!). As a suggestion find my settings below, but experiment for yourself (effects for others set to 2 since this is the last setting that sill displays critical animations, for AA i am using ReShade). My FPS are somewhat okay to me which means normally not far below 60 and usually above 100.  

lFyHdTF.jpg

I didnt mention that I also did a clean win 10 installation, the LTSC one is the kind of win 10 that doesnt have bloatwares inside so ye, im 100% sure about the 3rd party programs and drivers, I installed the ones from my motherboard website + i am using a paid version of iobits driver booster to cover other minor updates up. My ms in game is weird, thats true, but its always 120-150, considering i live in Bosnia which is not so far away from servers location "allegedly".  I run at max settings with sfx for others at 2 and personal sfx at 2 , i get 120 fps without any prob. The issue here are fights. U mentioned ur fps doesnt go far below 60? Is that the case in raids , 12-man content and f8? Ty for response tho ! I love to share experiences.

Share this post


Link to post
Share on other sites

I see... I´m currently not playing endgame content so idk, but a year ago dungs were fine for me, also general crowded areas and PvE are.

It shouldnt be as it is for you, so the question is what is the difference in between our configs (other than you using Windows 10).

 

-Disable the ingame crappy and CPU heavy AA and see how it fares (i never ever used it, perhaps that is the difference for you, if FPS improve by a lot without it you could use a different AA method such as GPU-dependent SSxAA or ReShade)

 

-I suppose you are playing on an SSD but still microstutter from content streaming might be a thing for you. If you can, try an M2 SSD.

 

-This driver thing you are using does not sound like a pure scam according to net feedback, however it is not needed and i tbh wouldnt trust it. With Win 10 you shouldnt worry about drivers anyhow, i mean if there is any real world benefit to Win 7 then this might be the one.

 

-Are you maybe using third party input methods?

Share this post


Link to post
Share on other sites
Dagana   

Try locking ur fps in at 60, it wont jump up n down so much, i am running a ROG pc and i have same issue, also try view distance and shadows. seems to smooth it out a little

Share this post


Link to post
Share on other sites

No, locking fps wont help, tried it numerous of times in all sorts of scenarios. Also ye i play with AA disabled.

 Actually, only thing im using is razer synapse for my ornata and black mamba. Idk still.

Share this post


Link to post
Share on other sites
Kaigame   

Was going to ask yesterday but had issues logging in here. the 9900k has an integrated GPU, are you sure that isn't being used at all? I would imagine you could probably tell if it wasn't but from what you are describing your fps seems a bit low for a 5Ghz 9900k and a 2080S. Unless your CPU is throttling due to overheating maybe?

Share this post


Link to post
Share on other sites

Well, im pretty sure i setup my graphics card to be a prefered video card, but for the sake of it, how can i be 100% sure ? 

- Also i really doubt that an integrated gpu would be able to accomplish 120 fps at max settings at all time while not in fights or very crowded areas.

- I did stress tests and highest temp my cpu reaches is 85 celsius, avarage on 63. I doubt its the heat. Ty for response !

Share this post


Link to post
Share on other sites
Kaigame   
4 hours ago, Hwarang Zhao said:

Well, im pretty sure i setup my graphics card to be a prefered video card, but for the sake of it, how can i be 100% sure ? 

- Also i really doubt that an integrated gpu would be able to accomplish 120 fps at max settings at all time while not in fights or very crowded areas.

- I did stress tests and highest temp my cpu reaches is 85 celsius, avarage on 63. I doubt its the heat. Ty for response !

I recently went to the Red side, my previous cpu had no iGPU so i have no idea, there should be a setting somewhere either in the nvidia control panel or windows display setings i would have though. But yes, highly unlikely the built in GPU could do 120fps anywhere.... :)

 

Those temps look ok, so it won't be that.

Share this post


Link to post
Share on other sites

Ye, no chance temps could do that to me, I even bought and installed a 280mm aio cooling solution so that i could oc and get somewhat reasonable temperatures. Rest of the components are even colder.

Share this post


Link to post
Share on other sites
Kaigame   

Do you have GPUZ installed? if not get it.

 

When you are playing, check what your running stats are, gpu temps, core clocks, gpu usage, also note the PCI-E bandwidth and version(it may show as 1.1 when idle).

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Kaigame said:

Do you have GPUZ installed? if not get it.

 

When you are playing, check what your running stats are, gpu temps, core clocks, gpu usage, also note the PCI-E bandwidth and version(it may show as 1.1 when idle).

 

 

Good suggestion, maybe even better would be HWInfo since it monitors pretty much any stat about your hardware, i e may help determining CPU throttling and other potential issues: https://www.hwinfo.com

Edited by weaponzero

Share this post


Link to post
Share on other sites

Actually, I use hwmonitor and cpuz, for gpu i use msi afterburner,i even setup the fans of gpu manually to work at higher % when(if) facing high temps, what would i be able to find out from gpuz thats not from afterburner? 

- Also a funny thing is that bns doesnt even use my gpu, the usage of my gpu never exceeds 3%, even when i installed d12 wrapper, which is supposed to use a heck tone of gpu memory. On my old laptop I have a gtx 980m graphics card, and when using d12 wrapper, usage of gpu reaches up to 80%, but on a rtx 2080super it hardly reaches 3% which is also a WTF fact. I mean i know that gpu is kinda powerful, but i expect a 15ish % usage at least, even tho its supposed to be even more but i know bns is cpu heavy game.

- Also, I even think that OCing all of the cores is useless since bns doesnt use all, so in this scenario, i think Ocing only 2 or 3 cores should do the trick equally as OCing all of them. I think that, even by default, this cpu has core 0 OCed to 5, rest are a bit lowered values.

 

 

Edited by Hwarang Zhao

Share this post


Link to post
Share on other sites

EDIT: Okay after thoroughly testing all sorts of stuff i could think of, i decided to give it a go at 32 bit. Even for the sake of it, i tried playing some 12 man content with complately maxed out settings and my fps not going very much below 60, even when sb ends and ppl start scattering around being able to acomplish up to 100 ms IN THE FIGHT ITSELF. I dont know how can this be possible, 32 bit is known as very unstable and caused me to crash alot of times randomly, sometimes i crashed 6 times in a row whilst trying to trade a dude. Since obviously there is smth wrong with 64 bit client for me, is there any way to make 32 bit more stable ? Maybe apply some compatibility mode ? Or any way to transfer the goodness from 32 bit to 64 bit? How is that possible, a simple 32 bit client unlocks so much better graphics and overall responsiveness in game.

Share this post


Link to post
Share on other sites

Removing the animations(effects) will make x32 somewhat stable,but nothing will help people that are having fps drops on classes with high attack speed(spectral bm/archer) the game engine/servers just can't keep up with 5+ APS.

Edited by Intersolar

Share this post


Link to post
Share on other sites
GoogleMe   

Before you start the game change windows resolution to 800 by 600 or lower then start game. My computer was using resources the game could use. 

 

Share this post


Link to post
Share on other sites

i would first install msi afterburner-

i hope the latest version will already work for windows 10 latest update,

you need a second program which does the overlay- this second program comes with the installation. - some tuner

the tuner hat compatible issues with windows 10 update some while ago.

 

after that you can monitor your fps, combined with cpu core/thread usage and gpu usage.

you will soon observe your bottleneck.

 

if there is no special mystic gpu driver problem related to dx9

i have the idea that one thread/core of your cpu bottlenecks it, not because your cpu isn powerful, but its simply influenced by the core/thread where all the network -netcoderelated management runs from the game- maybe your ping/latency is low and this influences the fps performance.-

whta is your internet - how much download/upload - wlan/lan? which ping to b&s=?

 

 

 

Edited by Expseeker

Share this post


Link to post
Share on other sites

Im terribly sorry for late response , after some time i just stopped trying and gave up playing the game since there are alot more demanding games that i can run at ultra settings without a tiniest of stutters in fps. 

 

I am alrdy using msi afterburner , and i even tweaked my gpu for a tiny bit , just to try giving it a bit of juice, unfortunately without any visible results.

 

My temps are very normal when it comes to stressing my machine so ,i repeat, heat is not the issue here.

 

There simply isnt any logical or consistent patern in fps drops other that im able to have 100fps in mushin with max settings and a billion people, yet when i start a fight with 6 ppl i drop to 12 fps, thats the only consistent patern here.

 

Highly doubt this i isp based cuz i change my wareabouts alot , and i tried several ISPs out of which some gave me better ms , and some gave me worse ms. Best ms i ever played on is around 100ms in fights , worst around 150 ms. This is all lan we are talking about ofc. My dl/up is 20mbit/5mbit which is about 2.2mb/s download and 0.5mb/s upload , and at one point i even had worse dl/up than that and this didnt impact the fps in any way.

 

Ty for the response man and sorry for late response like this , figured least i can do is provide some feedback for people that can benefit from this post.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Don't quote me on this but based on what I have read and personal experiences with the game, I can say main probable cause for these fps drops is damage calculations and perhaps loading certain animations etc. when fighting. Hence why fps drops come only when fighting and why it is way worse with 12 players. 11 other players' damage calculations = 11 times more lag cause your cpu can't handle it anymore. That's my conclusion about it. 

Why I think this might be the case is because of how it only happens while in combat and how much more different new weapon effects, item effects, soul, talisman, heart, all that we have gotten to the game. So much more stuff to calculate in real time than what there was say 2 years ago. Old game engine probably can't handle it well and neither can your cpu, probably. Nothing to do with graphics or windows settings :P

Edited by Amarathiel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this