Sign in to follow this  
Kaigame

AMD RX 5700 series

Recommended Posts

Kaigame   

Hi all, 

 

Is anyone else playing this game on a Radeon 5700xt? Just want to try and see if anyone else is having similar issues, stuttering like crazy, massive frame drops?

Share this post


Link to post
Share on other sites
5 hours ago, Kaigame said:

Hi all, 

 

Is anyone else playing this game on a Radeon 5700xt? Just want to try and see if anyone else is having similar issues, stuttering like crazy, massive frame drops?

If you have recently bought RX 5700 Series GPU and haven't done a fresh windows install, please download DDU (Display Driver Uninstaller) 

https://www.guru3d.com/files-get/display-driver-uninstaller-download,14.html This program will remove all of your GPU drivers, the ones you previously had, windows basic drivers and your new ones that you may have.

 

Please download the Driver of RX 5700 Series before using DDU, it's highly recommended to run DDU in Safe Mode (Offline network mode), Do not download Auto-Detect AMD because you will be offline and it will not work, you have to download the Driver installer.

 

Once DDU is opened you will be greeted with this tab, tick the ones I marked, Even though it says (NOT Recommended) but for what we about to do you need to select it.

 

wH93lOL.png

Then select GPU / AMD

 

and do Clean and do NOT Restart, This option may cause issues like black screen, if this happens just plug your internet cable back and upon restart of your computer it will re-download windows basic drivers and repeat steps. 

 

If you were not greeted with black screen then all of your GPU Drivers have been completely deleted of your system and you should proceed and install the drivers you have downloaded prior to starting all this.

 

d3cFgry.png

 

after installing your GPU drivers you can now reboot system.

 

 

Recommended usage:

  • The tool can be used in Normal mode but for absolute stability when using DDU, Safemode is always the best.
  • Make a backup or a system restore (but it should normally be pretty safe).

  • It is best to exclude the DDU folder completely from any security software to avoid issues.

Requirement:

  • Windows Vista SP2 up to Windows 10 May 2019 update 1903 (18362.xx) (anything higher is at your own risk)

  • NVIDIA, AMD, Intel GPUs

  • Microsoft .NET Framework 4.5 or higher

Recommended usage

  • You MUST disconnect your internet or completely block Windows Update when running DDU until you have re-installed your new drivers.

  • DDU should be used when having a problem uninstalling/installing a driver or when switching GPU brand.

  • DDU should not be used every time you install a new driver unless you know what you are doing.

  • DDU will not work on network drive. Please install in a local drive (C:, D: or else).

  • The tool can be used in Normal mode but for absolute stability when using DDU, Safemode is always the best.

  • If you are using DDU in normal mode, Clean, reboot, clean again, reboot.

  • Make a backup or a system restore (but it should normally be pretty safe).

  • It is best to exclude the DDU folder completely from any security software to avoid issues.

 

Some people had amazing results and for some people it had no effect, but in the end it's worth a try. 

 

 

but if you still need help you can try and contact support - https://support.bladeandsoul.com/hc/en-us , If this solution helped you, please let me know.

 

if DDU didn't helped and support haven't helped you, then the best thing you can do is contact AMD or write in their forums and report it, as RX 5700 series are currently having a lot of driver issues since release - https://community.amd.com/community/support-forums/drivers-software/content

Edited by SayhaSeer

Share this post


Link to post
Share on other sites
Kaigame   

I always use DDU between driver installations. It's an AMD issue by the looks of it, even more specifically, this card does not like BnS Shadows.

 

If i turn Shadow Visibility and quality down to 3 and 1, and everything else at 5, the game runs smooth as silk. As soon as turn up shadow details, performance tanks!

 

Overall performance is probably a little worse than my ageing GTX 980ti in this game i think..... sad

Share this post


Link to post
Share on other sites
3 hours ago, Kaigame said:

I always use DDU between driver installations. It's an AMD issue by the looks of it, even more specifically, this card does not like BnS Shadows.

 

If i turn Shadow Visibility and quality down to 3 and 1, and everything else at 5, the game runs smooth as silk. As soon as turn up shadow details, performance tanks!

 

Overall performance is probably a little worse than my ageing GTX 980ti in this game i think..... sad

Well this game is more demanding on CPU then GPU, You can have 10 years old GPU and a Good CPU and you will run game perfectly fine including raids with 30-60 FPS with smooth experience and with players enabled but not maxed out on graphics, So GPU doesn't play a big role in Blade and Soul unless if you want to play maxed graphics I guess, however it will change on UE4 Engine, You can try making  blade and soul profile in AMD Radeon make sure Radeon Chill is off, Set Anti-aliasing mode to enhance application settings or use application settings either of them is fine, but you can check which one works better for you and see if that will have any better effect on the game performance. 

 

Or another option that you could try is Running Blade and Soul in DirectX12 I've read in Discord and BnS Buddy forums that it helped a lot of people in performance but don't quote me on that since I don't have performance issues I never tested DX12 myself, so use it at your own risk. 

 

When RX 5700 XT Got Released I purchased the Reference Card with intention to return it a month later... while I was waiting for Aftermarket Cards, Now I Pre-Ordered RX 5700 XT Red Devil so I hope driver issue didn't go worse then it was for Blade and Soul >.>, So while I was using reference model I didn't had any crazy problems like you mentioned, it did run slightly worse then This current old GPU I am temporary using, but nothing too crazy, they have updated their drivers quite a lot of times now so you could try using a lower driver version and see how much impact you will have and if you find an older driver that runs more smoother then the newer you should let AMD know so they might tweak it for the better. 

Edited by SayhaSeer

Share this post


Link to post
Share on other sites
Kaigame   

I'm well aware of the limitations of this game engine, but also aware that there is no good reason why my 980ti should outperform my 5700xt. I went with the reference card, and watercooled it. Although i do need to dismantle the card and check the fitting, and make a few modifications to my loop, it's running good enough at the moment and keeping temperatures low enough whilst overclocked so i have no heat issues.

 

GPU plays a big enough role if i could quite comfortably play with all settings maxed out before, and now i can't. Even the character select screen starts choppy before smoothing out. At times i am getting well in excess of 100fps but the drops and dips are weird, also it would seem that the card isn't run at full speed all the time, but thats what these cards do nowadays...

 

I was meant to try to dx12 thing last night, but to be honest, i completely forgot, i've got the links and will see how that goes.

Share this post


Link to post
Share on other sites
Kaigame   

Wow, the DX12 wrapper is working amazing, everything is up to max detail and running smoothly, no more frame rate or stutter issues!!!!

 

Only done a quick test, but the game is running so nicely now, i'm going to enjoy playing this game again. many thanks for the tip :D

Share this post


Link to post
Share on other sites
20 hours ago, Kaigame said:

Wow, the DX12 wrapper is working amazing, everything is up to max detail and running smoothly, no more frame rate or stutter issues!!!!

 

Only done a quick test, but the game is running so nicely now, i'm going to enjoy playing this game again. many thanks for the tip :D

haha, as long as it helped ^^, the performance with DX12 will only increase, I saw patches coming out pretty regularly and a lot more people started to use and see a big performance increase in FPS and stability, but hopefully UE4 comes out soon fixing the major problems of BnS So that players don't need to keep searching for solutions of how to make game run better >.<

Share this post


Link to post
Share on other sites
Kaigame   
18 hours ago, SayhaSeer said:

haha, as long as it helped ^^, the performance with DX12 will only increase, I saw patches coming out pretty regularly and a lot more people started to use and see a big performance increase in FPS and stability, but hopefully UE4 comes out soon fixing the major problems of BnS So that players don't need to keep searching for solutions of how to make game run better >.<

I won't hold my breath for the UE4 update, although it will  be welcome when it comes, the bugs are going to be many

Share this post


Link to post
Share on other sites
eNlinx   
On 9/6/2019 at 8:04 PM, Kaigame said:

Wow, the DX12 wrapper is working amazing, everything is up to max detail and running smoothly, no more frame rate or stutter issues!!!!

 

Only done a quick test, but the game is running so nicely now, i'm going to enjoy playing this game again. many thanks for the tip :D

Can you elaborate what exactly you did. I have the same issues but i cannot find a good resource online how to run bns with dx 12.

Share this post


Link to post
Share on other sites
Kaigame   
13 hours ago, eNlinx said:

Can you elaborate what exactly you did. I have the same issues but i cannot find a good resource online how to run bns with dx 12.

Instructions: https://github.com/megai2/d912pxy/wiki/Installing

There is a link to the download in the there also, ignore what it says about turning down shadows, running ultra smooth with everything at max here.

The only issue is that the world takes a little longer to render initially, it looks weird for a few seconds, but soon sorts itself out.

 

Still working great, to elaborate a little further, you place the proxy software in its folder in your game folder(bin64 for the 64bit client.

mine is: C:\Program Files (x86)\NCSOFT\BnS\bin64\d912pxy

In that folder in the dll\release folder you'll find a d3d9.dll, move that to the bin64 folder

Also in the d912pxy folder is a bns_config.ini, rename to config.ini and thats it.

 

Launch the game and see the difference.

 

 

Edited by Kaigame

Share this post


Link to post
Share on other sites
eNlinx   

how can i confirm if this worked or not.

 

The first time it seems it worked as object loaded, but second time feels it just reverted back.

Share this post


Link to post
Share on other sites
Kaigame   
13 hours ago, eNlinx said:

how can i confirm if this worked or not.

 

The first time it seems it worked as object loaded, but second time feels it just reverted back.

The first time a map loads it has to load the shader cache so everything will look odd, the second time that same map loads it doesn't have to generate the shader cache again and should look fine, you should still notice the same performance increase.

 

What frame rates are you getting? What version of the proxy are you using? What issues are you experiencing? can you post a video? Whats the content of your bns64 folder look like? Are you using the same client(32 vs 64)?

13 hours ago, eNlinx said:

do i have to do it every time the game patches ?
 

It might be due to patch.

no, you don't have to update it everytime, just make sure that the d3d9.dll file is still there and the folder still exists, 

Share this post


Link to post
Share on other sites
eNlinx   

running everything at max with vsync,

 

I have normal 60fps however when i get in a dense area it will drop to 45. Same as before i installed the fix.

 

So im not sure if it actualy did something or i just had a placebo effect

Share this post


Link to post
Share on other sites
Kaigame   
44 minutes ago, eNlinx said:

running everything at max with vsync,

 

I have normal 60fps however when i get in a dense area it will drop to 45. Same as before i installed the fix.

 

So im not sure if it actualy did something or i just had a placebo effect

Thats to be expected, seems like it's working fine for you.  BnS is unplayable for me without the proxy, if i move the camera around i drop to single digit fps without it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this