Saekko

Can we get some answers to the performance issues?

Recommended Posts

Saekko   

Back in the day (like on launch) BnS ran great. I don't recall everyone having issues with getting 2 fps in a fight and 180-400+ ms until MSP was released. Ever since that day it's been hell. Why don't we see any mention of this in patch notes or announcements or anything? 

Here's a funny story. A few months ago while in a clan 6v6 my PC LITERALLY caught on fire. RMA'd the EVGA 970 that was the cause and waited 6 weeks to get a new one. Four whole days later it died. Before the fire the game ran terribly and after replacing the GPU with a 2070 ... surprise! still runs like ❤ ❤ ❤ ❤. I expected that though because it's an MMO so the CPU is doing most of the work. So I just built a whole new PC with a i7 9700k at 5.4GHz, STRIX 2070, 32gb of ram, and the game and OS are on a Samsung m.2. Game STILL runs like ❤ ❤ ❤ ❤. (Still expected that though)

Then I had an interesting conversation with an Intel engineer. This guy tells me the reason BnS has these FPS and ms problems is because they're using poor servers, and nothing we can do is going to help. 

Then I hear that new A;iR game ran like crap just like BnS BUT the new TW version runs FAR better and it's because of the servers. Maybe Intel guy was on to something...

Can we get some information on this? Is the reason this game runs so bad that it's almost unplayable really because somebody is too cheap to give us proper servers? And were they downgraded at some point with no mention of it in patch notes?

Share this post


Link to post
Share on other sites
Grimoir   

I literally have no performance issues on my rig, no crashes, no huge fps drops. In the past 2 weeks i maybe had 1 freeze in raid but that was after the boss was dead and during loot distribution for like 1 second. I almost never hide characters, and only do it for certain mechanics or if i need to see the floor better when everyone is grouped.

 

That being said, the game relies heavily on the CPU, your GPU does not matter all that much when it comes to performance and FPS. 

 

Now i agree the game has issues, but its hard to believe its all the game or the servers when there are people who do not face any issues.

Share this post


Link to post
Share on other sites
Saekko   

@Fiana I've tried every "fix" you can find on youtube, BnS buddy, discords, reddit, and google. It doesn't help. Probably because my rig like most others built in the last 10 years are more than enough for this games requirements.

@Grimoir What are your specs? You're one of about two people I've ever seen say "I literally have no performance issues on my rig" . No one I've ever played with in the last two years has got a stable 60+ fps or sub 70 ms (in game ms) and one of them was on a $5000 rig. 

"games rely more on the discrete GPU for the rendering of the images and calculations for the game , in multiplayer games, the decoding and coding of the information is performed by the server of the game which is not related on any way to your CPU , the frame drops that we found on multiplayer games are actually "lagged inputs/ outputs" from the server "  -Intel guy

This would explain why I get 120 fps while alone but the second I see another player BAM -90 fps. And the fact that A;IR runs great in TW but like trash in KR with the only difference being the servers makes me more convinced. 

Share this post


Link to post
Share on other sites
Grimoir   
53 minutes ago, Saekko said:

@Grimoir What are your specs? You're one of about two people I've ever seen say "I literally have no performance issues on my rig" . No one I've ever played with in the last two years has got a stable 60+ fps or sub 70 ms (in game ms) and one of them was on a $5000 rig. 

My rig costes me like 1200 euros xD anyway my specs: intel core i7 8700K, RTX 2070, 32 GB DDR4 3200 ram, SSD Samsung Evo M2,. I run the game at max settings.

 

55 minutes ago, Saekko said:

"games rely more on the discrete GPU for the rendering of the images and calculations for the game , in multiplayer games, the decoding and coding of the information is performed by the server of the game which is not related on any way to your CPU , the frame drops that we found on multiplayer games are actually "lagged inputs/ outputs" from the server "  -Intel guy

This would explain why I get 120 fps while alone but the second I see another player BAM -90 fps. And the fact that A;IR runs great in TW but like trash in KR with the only difference being the servers makes me more convinced. 

The game runs on your local machine, which means its rendered on your PC, that has very little to do with the servers. If it was ping, then yes but purely FPS wise no. BnS is still on UE3, and the engine itself utilizes CPU heavily.

 

also: i do have FTH, bluetooth etc turned off, and i always make sure my pc is updated in terms of OS, drivers, and clean from junk.

 

 

Share this post


Link to post
Share on other sites

Answer to the topic - NO, at least not from developer or publisher.

You may try the guides and hacks for some GPUs but it's often futile (because BnS is badly done and relies on CPU more). You can try external tools like suggested above or have NASA PC, but the game itself will never be optimized and fixed properly. 

 

One more thing: UE4. Yes, they have plans. With what's happening so far in game, there is high likelihood it will actually get worse, not better.

Edited by Dellecross

Share this post


Link to post
Share on other sites
Saekko   

@Grimoir The only difference in our build is I have a 9700k lol there's no way you run great while mine runs like trash 

Share this post


Link to post
Share on other sites
7 hours ago, Saekko said:

@Grimoir The only difference in our build is I have a 9700k lol there's no way you run great while mine runs like trash 

this game just makes zero sense, everyone seemingly gets different experiences, in fact I've never managed to get more than 5fps on literally any Intel platform (tested from 2 core duo's to an I5 6600k, best results I got were actually from a 2 core duo).

However I have no issues folding 150ms 60+Fps during TT raids (120ms 120fps otherwise) on my ryzen 5 2600; all I'm trying to say is that there is some unholy coding going on here, screw logic this is just what this game does.

Edited by RagingPhenix

Share this post


Link to post
Share on other sites
Grimoir   
2 hours ago, RagingPhenix said:

this game just makes zero sense, everyone seemingly gets different experiences, in fact I've never managed to get more than 5fps on literally any Intel platform (tested from 2 core duo's to an I5 6600k, best results I got were actually from a 2 core duo).

However I have no issues folding 150ms 60+Fps during TT raids (120ms 120fps otherwise) on my ryzen 5 2600; all I'm trying to say is that there is some unholy coding going on here, screw logic this is just what this game does.

I personally think it has to do with the Pc's and not really the game itself (altho it does have issues).

Even on my old PC with an old i7 processor (think it was i7 3470 or close to that) and a amd r9 380 i had no issues.

Share this post


Link to post
Share on other sites
Fiana   

@Grimoir you can't call your rig a normal, not every player have that spec.. so you can't put "i never have problem" with your setup

@Saekko when you play the game, have you see the task manager? and see how much resource its use?
maybe you forget to use 64bit and that why you have limited performance

when i pull graphic setting to all 5, i only able to get 20-40 in dungeon
and below 7 fps in raid,

 

in game like PSO2, FF14, Wow i never have this kind performace issue when i use max graphic setting
well, i guess this game just need more work
or maybe the programmer slacking off

try to lower the game setting i guess, maybe it's can help

Edited by Fiana

Share this post


Link to post
Share on other sites
14 hours ago, Fiana said:

@Grimoir you can't call your rig a normal, not every player have that spec.. so you can't put "i never have problem" with your setup

@Saekko when you play the game, have you see the task manager? and see how much resource its use?
maybe you forget to use 64bit and that why you have limited performance

when i pull graphic setting to all 5, i only able to get 20-40 in dungeon
and below 7 fps in raid,

 

in game like PSO2, FF14, Wow i never have this kind performace issue when i use max graphic setting
well, i guess this game just need more work
or maybe the programmer slacking off

try to lower the game setting i guess, maybe it's can help

honestly except CTRL+F changing settings has little effect on my FPS. I get some extra FPS setting shadows to 1 but otherwise my FPS is the same no matter what I set the other settings to; only changes are to how good the game looks.

 

14 hours ago, Grimoir said:

I personally think it has to do with the Pc's and not really the game itself (altho it does have issues).

Even on my old PC with an old i7 processor (think it was i7 3470 or close to that) and a amd r9 380 i had no issues.

They were PC's I was rebuilding, so a clean windows install, I used to try and run BnS just for the hell of it since it's poorly optimized

Share this post


Link to post
Share on other sites
Saekko   

I've tried literally everything you can find on the internet and everything I could think of on four very different PCs over the last 2 years. The thing I'm getting at though is there is clearly a problem which everyone here seems to acknowledge. And it's being completely ignored by NCSoft. The very least they could do is publicly say "We know the game runs like trash" and tell us what the cause is and if we can ever expect a fix for it. 

I don't even care about content or trove or anything else anymore because the game runs so bad I can't enjoy anything I get. If I didn't think my raid group needed me I'd have already quit.

Share this post


Link to post
Share on other sites
Am 27.6.2019 um 23:17 schrieb Saekko:

@Grimoir The only difference in our build is I have a 9700k lol there's no way you run great while mine runs like trash 

Hes known to whiteknight the hell of everything ingame and on the forums often with a 2nd account too, thats why no one takes him seriously, because hes usually lieing. 

 

The games just badly optimized on an engine thats no good for mmo. We probably got another memoryleak last patch, because since then most people report its using up way more ram than it used to. Add to it the influx of a ton of people on bad servers and that a part of the graphics are rendered serverside and u got the current trainwreck.

Edited by Crona Darkdance

Share this post


Link to post
Share on other sites
Zorex   

Look, it's great that some people manage to play the game without issues. I'm genuinely happy that you get to enjoy the game. But please don't be dismissive of other people's legitimate issues.

 

There is a huge portion of the player base that simply can't enjoy the game due to getting 5-15 FPS since the patch. When the game goes from 30-40 FPS in raid before the patch to 5-15 FPS after, with near-constant stuttering, something is very, very wrong. This is literally a textbook example of a software regression: The game went from working fine (for certain values of 'fine' anyway...) to performing horribly on the very same system(s) immediately after the patch. I'm not even exaggerating; I logged in before and after the patch on last Wednesday and it was a night and day difference in performance. This simply cannot be swept under the rug as 'NOTABUG'. In any half-decent software company, regressions are the highest priority type of bug to be fixed.

 

Speaking as someone who, on a professional level, has implemented a profiler (the kind of tool software developers use to actually pinpoint performance issues), I can assure you there's a staggering amount of things that can impact the performance of a piece of software. Hardware alone is very rarely the explanation.

 

Edited by Zorex

Share this post


Link to post
Share on other sites
Astarae   

 I hinted at another reason why some have better response times and no probs -- their login is in a privileged-user/server-priority queue.  Right Now and since the server merge it's been real clear, the main delays are on the server -- I see some that could be local, going between areas I can cpu spiking, but when I beam into a heavily populated area like mushins -- 33 FPS average on Channel 1.  I switch to channel 2.  Bing!  over 100 FPS -- same view, same location, just that there are fewer people around.

Have noticed a similar effect on ping, but lowest in-game I get is about 98ms, with times in parties having it be more like 130-140ms.  By myself, 125ms or lower.

 

That's ALL server, so yeah, the Intel guy might be right -- just using underpowered HW for servers that don't have enough cpu bandwidth for all the users.

 

 

Share this post


Link to post
Share on other sites
Grimoir   
2 hours ago, Astarae said:

 I hinted at another reason why some have better response times and no probs -- their login is in a privileged-user/server-priority queue.  Right Now and since the server merge it's been real clear, the main delays are on the server -- I see some that could be local, going between areas I can cpu spiking, but when I beam into a heavily populated area like mushins -- 33 FPS average on Channel 1.  I switch to channel 2.  Bing!  over 100 FPS -- same view, same location, just that there are fewer people around.

Have noticed a similar effect on ping, but lowest in-game I get is about 98ms, with times in parties having it be more like 130-140ms.  By myself, 125ms or lower.

 

That's ALL server, so yeah, the Intel guy might be right -- just using underpowered HW for servers that don't have enough cpu bandwidth for all the users.

 

 

No, because even if you do ctrl+f the game is still rendering thats why your fps drops, when you swap channels the people that arent around dont getr rendered and thats why you see no to less drops. It would be a server issue if you would stream the game and play it via a streaming service because then everything is done on the remote PC, but fps is still purely only local not server.

 

 

Share this post


Link to post
Share on other sites
Garlend   

IMO, I think it is the server. If you look at the preview stream you can see that NC West has 40-250ms ping (250 is probably from first loading in, etc). I think 40ms is a little high for only having a few ppl on it. With a higher load on it most likely doubles or more. So by then your playing with a 56k ping.

 

When I play a new character I have no issues with fps doing the story but when I reach newer areas with players my fps lowers and my ping also get slightly higher as well. That is why I think it is a server issue than a client one but the client does have some issues as well. Like when you press enter to type and it cuts off the first key press after of the word you are typing.

Edited by Garlend

Share this post


Link to post
Share on other sites
Misaki   

It's also little bit about what class you play. Some classes are way more laggier than others warlock and i guess now the new BM spec are super laggy and manage to kill your fps nicely. Of course all that goes to the performance issues BNS already has but i never had any issues on my alts like i had on my main (warlock) my FPS tanked on my main way more as to compared to lets say to a gunner.

Edited by Misaki

Share this post


Link to post
Share on other sites
SkFy   

Is anyone else having horrible lags after last patch which make no sense?
Even with 60 fps the game looks horrible... nothing is smooth at all :s no matter what I try..
Other games run perfectly fine... just bns has ebola like usual.

 

Also if I try to chat or open my inventory my mouse cursor keeps showing a loading icon

Edited by SkFy

Share this post


Link to post
Share on other sites

Yes. Lately it becomes so even with hidden players and optimized for combat graphics I get 20-30 fps only. No idea why (and honestly I gave up on trying to fix it because other games which are way more demanding to graphics work just fine on high settings). And ping .. well, no way to have it below 100ms at all for me.

Share this post


Link to post
Share on other sites
Mango95   

Hi, I've been sort of a long time player of BnS and I love all the new updates and whatnot but I have a small complaint. Back before this recent big update, I was able to play this game is the highest quality setting with no lagging or glitching. I also remember the startup screen not taking 5 minutes long to load. But after this update, I can't even play the game at like a number 3 setting sadly. I lag a lot and and glitch. In some specific areas or when I'm loading into an area, I will go down to 6 to 5 fps. I've seen a lot of forums, outside of the BnS forums, of people complaining about the lag. I've seen people with the most up to date computers complain about the lag and how un-optimized it is. Now I really like this game a lot, I really do. I honestly don't have any complaint about this game other than it really really REALLY needs to be optimized. Please guys, I don't want to just stop playing this game because of how laggy it is but at this point, it's really getting to me. Now, I'm no game creator, I don't know the processes of how to optimize a game and how hard it can be. I may be asking for too much but all I want to do is play this game peacefully without lagging out in the middle of a fight and than 5 seconds later I'm already dead. Please please please just optimize the game. Please. Also I'm not hating on the the game nor the creators, I love this game and I want to see it strive. So please optimize the game. 

Share this post


Link to post
Share on other sites
prietess   

Agreed.

 Became even more laggy at raids for some reason.... freezed many times...................................... Didn't happen that much last time (before last week update)

So bad.........................

Share this post


Link to post
Share on other sites
Poporo   

Optimization is horrible, they like begging us to leave the game and never come back.

Share this post


Link to post
Share on other sites
NightFer   

Since the last major patch from 2 weeks ago there was (and maybe still is) a memory leak affecting the crowded areas like mushins tower where a lot of characters gather. You dont need to be a genious to see it happening. Its not the first time this happens and it takes time to fix since they need to figure out why its happening. Give them time, until then, dont stay long in those areas.

To the people who say its a bad server issue: its not! we run on the same server (with later on them being modified for better performance) as we had back in the release days with millions of people playing. Never trust an engineer who knows nothing about software :D even if he works for NASA. Back in the old days the servers were way more crowded.

Current FPS issues are caused by (I will not put my head under this one, its only speculations) UE4 textures running on UE3 environment, its been like this since they made that change a few years ago. The engine doesnt care what kind of RIG you have, it runs on a single core with little to no rendering from the GPU side. If your CPU have integrated GPU, good for you, it will run smoother, if not, you are screwed. Thats how UE3 works. UE4 on the other side moves everything out of the CPU loading heavily your GPU. Will it be better? Maybe. Will it be worse? Highly doubt it.

MS lag is entirely on your ISP routing to the server location (Frankfurt for EU and idk where in Texas the US server was :D ). I live 2000+ km (sorry, no american measures here) away from the EU server and I have 80-130 ingame ping. How to fix that? Move closer to the server or use VPN for better routing.

 

And just to add up for the people that are going to ask me or blame me for whiteknighting, I have 15-20fps in raids, 40-60fps in dungeons with no crashes (other than afking in the memory leaking areas since my RAM overloads and the game crashes on its own), other than the normal fps drops in raids and such. Running on i5 7400, GTX1050TI with 16GB of DDR4 2400MHz and the game itself on an Intel SSD. Game running on 2 or 3 graphics settings with ingame limiting the FPS to 60 (you dont really need more, yes I can run 120 but whats the point anyways since it drops to 20 in raids whatever you do). Some other options ingame can make your game render less which means less fps drops, but find that out by yourselves.

Edited by NightFer

Share this post


Link to post
Share on other sites
vor 7 Minuten schrieb NightFer:

Since the last major patch from 2 weeks ago there was (and maybe still is) a memory leak affecting the crowded areas like mushins tower where a lot of characters gather. You dont need to be a genious to see it happening. Its not the first time this happens and it takes time to fix since they need to figure out why its happening. Give them time, until then, dont stay long in those areas.

To the people who say its a bad server issue: its not! we run on the same server (with later on them being modified for better performance) as we had back in the release days with millions of people playing. Never trust an engineer who knows nothing about software :D even if he works for NASA. Back in the old days the servers were way more crowded.

Current FPS issues are caused by (I will not put my head under this one, its only speculations) UE4 textures running on UE3 environment, its been like this since they made that change a few years ago. The engine doesnt care what kind of RIG you have, it runs on a single core with little to no rendering from the GPU side. If your CPU have integrated GPU, good for you, it will run smoother, if not, you are screwed. Thats how UE3 works. UE4 on the other side moves everything out of the CPU loading heavily your GPU. Will it be better? Maybe. Will it be worse? Highly doubt it.

MS lag is entirely on your ISP routing to the server location (Frankfurt for EU and idk where in Texas the US server was :D ). I live 2000+ km (sorry, no american measures here) away from the EU server and I have 80-130 ingame ping. How to fix that? Move closer to the server or use VPN for better routing.

I live in Germany probably like 200km from Frankfurt and i have 80 - 130 Ping aswell. How do i get more FPS if i have an Integrated GPU ? I am using the I7 9700k i always thought my RX 580 is better than my Intel HD 630 or whatever my I7 got.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now