Jump to content

Lvl 2/3 Quest Letter Broken? I'm stuck at start, please help!

Recommended Posts


So... I've heard about this game before and I finally decided to try it out. Already seen a few minor bugs (this early on, damn!) but this one is just insane and I really need help.

I literally started the game 10 minutes ago, I just got my sword (I'm playing Warden) and was asked to destroy some dummys in the training area. After this I get a letter that I'm supposed to open and read it and it has some rewards on it and saying "Thank you for playing Blade and Soul". There's a button on it saying "Confirm" which appears as locked though. And near it it says I "can only get the rewards once I reach the level". 

I guess I should be Level 3 after the dummy thing, but I'm actually 90% into Lvl2???


There's no other quests at this point in the game, no mobs to kill no other areas to go to either (the ones that exist are empty), so I'm stuck. At level 2??


I've tried to suicide with my character by jumping off to the clouds. My character takes forever to reach death point and then won't respawn xD

I tried restarting the game, everything's the same.


I tried a second character, did the dummy thing again, and again, I'm still level 2 and can't proceed with the game.


I mean... maybe there was some kind of nerf to XP in some patches that maybe are making this happen without people's knowledge? It's been 3 years since release after all, so I wouldn't be surprised... But I only wanted to try out this "amazing combat system" people talk about and maybe have some fun, but I can't even play more than 5 minutes like this xD


Can anyone help please? Am I doing something wrong here?


Thanks in advance


Edit: Maybe this should be in the Bug Reports section. Sorry for the mistake ^^"

Edited by Daelock
Wrong Section to post this on. Just wanted to apologize for the mistake
Link to comment
Share on other sites

it is not bugged, you are looking in the wrong place at the wrong letter ;)

The letter meant is in your quest list, I saw many people having this problem have also not shown their quest list and therefor missing it.

So where it should be: in standard setting on the right are your current quests listed. There should be a scroll symbol, which you can click (either with alt or open inventory or something).

This list can be hidden, with the small triangle next to it. So if you have a grey triangle on the upper right screen, click it, it should expand and you should see the letter.

The letter you tried is some stuff (potion, etc.) you get at level 10.

Link to comment
Share on other sites

Damn, I feel really dumb lol. You were right! I was clicking on the bottom but there was a tiny letter icon on the quest itself that I just couldn't notice at all haha

Thank you for the help ^^"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...