Jump to content

Game crashes on start up

Recommended Posts

Just going to go ahead and just copy my support ticket here with the hopes someone else has solved this issue outside of the 5+ hours I did of reinstalling and googling the issue without success. One thing I haven't attempted is running in 32 bit(edit:also not working) but considering my hardware and the fact that I can run pretty much every newer title on high while streaming without issue I don't see that as an option to fix the issue.


I've done multiple installs and multiple file repairs on each drive I've installed the game on. I have also started Windows in selective boot mode to rule out 3rd party applications and cleared all my caches, DNS, allowed firewall access for both BnS and the Launcher, and checked to make sure my sata controller isn't an issue. I would attatch a DXdiag file from after the game crashes but every time I launch the game it hard locks my computer and I need to do a hard reset. I'd do a fresh install of Windows if I felt that was the issue but I just reformatted a month ago so I can't see my OS being corrupted being the issue. This just makes me super sad because I enjoyed this game a lot, but now that I have a nice PC it won't even launch.



Intel 8700k 
16gb 3000mHZ ddrr4 
512gb nVMe + 1TB SSD


Edit: It's also worth noting I have no issues installing the new launcher, and the game downloads fine(albiet slowly).


Edit2: I'm doing another fresh install because I just read the support article pertaining to Razer synapse. I originally uninstalled thinking I was over it but I'm going to give this last thing a shot and I'll let everyone know how it goes.


Edit3: Going to wait on support, there is no file in my documents for me to edit because the game will quite literally not start. I did wait around for a good 5 minutes after the lock up my 2nd scrreen went black which made me think maybe there's an issue with it trying to run on that instead. I unplugged it and had the same issue on my main monitor, so that's ruled out. I'm personally out of ideas so hopefully support can fix the issue. Also tried to disable Bluetooth as that was a random comment I read somewhere but that's also a no go.

Edited by Mr E Meats
More info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...