Sign in to follow this  
Nimble Fumble

Mechanika Wing bugged after awakening patch

Recommended Posts

Posted (edited)

Before the awakening patch, my character was wearing the Mechanika outfit with the Mechanika Wing. When I logged in after the patch, the Mechanika Wing was unequipped and shown as "lost item". Each time I try to equip it, I get the message that I must equip the Mechanika Outfit to wear the wing, even though the outfit is equipped. I tried to equip both things multiple times and in different order, but I get the same error message. Please fix it, I really like this set. Thanks in advance!

Edited by Nimble Fumble

Share this post


Link to post
Share on other sites
Grimoir   

do you have a customized mechanika costume? I get this error when i try to equip any adorment to a customized version of the costume. if i try equipping it on the original costume it works.

Share this post


Link to post
Share on other sites
kiskenoo   
1 hour ago, Grimoir said:

do you have a customized mechanika costume? I get this error when i try to equip any adorment to a customized version of the costume. if i try equipping it on the original costume it works.

No, i got the original costume and does not work at all. Also my friends tried and dont working for them too

Share this post


Link to post
Share on other sites
6 hours ago, Grimoir said:

do you have a customized mechanika costume? I get this error when i try to equip any adorment to a customized version of the costume. if i try equipping it on the original costume it works.

No, I am using the original costume, but it's not working.

Share this post


Link to post
Share on other sites

Greetings everybody,

 

We have forwarded this to the appropriate team members and they have confirmed that there will be a future patch to fix this.

 

Thank you for your patience in the meantime!

Share this post


Link to post
Share on other sites
9 minutes ago, PhoenixMitra said:

Greetings everybody,

 

We have forwarded this to the appropriate team members and they have confirmed that there will be a future patch to fix this.

 

Thank you for your patience in the meantime!

Thanks, Phoenix, much appreciated.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this