Hels

Game has PS2 textures on max graphic settings.

Recommended Posts

Hels   

So my issue is purely graphical, unlike all problems I see are about fps, which I have no problem with at all. I am really puzzled as to why even when I have graphics settings at the highest of 5, turned on all extra details on, also highest settings, and with anti aliasing to boot to only still feel like I'm playing a PS2 game. Which is really weirding me out as I see other players on Youtube with Ultra settings on and it has such beautiful realism. To give a retrospect, I had a very similar issue with the Witcher 3. Also to give a bit of insight I just built this PC yesterday. Even on supposed all graphic qualities set to ultra, it had the same ps2 looking textures, but I fixed it with graphical fiddling on my drive, resolution scaling and in game settings. All ultra settings with Ryzen 7 1700x cpu with GEFORCE GTX 1070ti gpu and it runs fantastically and beautifully now. Hoping I could do the same with this and nope. Just PS2 texture nostalgia. So any tips or fixes for this? Or am I just whining and it looks like this non Ultra users? With online digging, the only similar sounding issue someone else had on this game that I have found, was during closed beta. My PC build for you tech savy people: https://pcpartpicker.com/b/CHD2FT

 

1zewlqv.jpg

 

Share this post


Link to post
Share on other sites
Hels   

Nvm, you can all ignore this thread. I did some fiddling with the properties on the client and fixed the problem. Now its beautiful and not 4 and half graphical generations old.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.