HatredInfinite

64bit Client Horrible FPS Since Yesterday

Recommended Posts

So since I came back to the game about a month ago, I've had no problems. 64bit client running fantastically, 120fps at idle or while playing low-intensity/low-population areas, always at least 60fps in situations like raids.

 

Yesterday I went to play after work and my FPS seems capped at 38 (such a strange number, but it was consistent) in 64bit client, no matter where I am, no matter what I do. Then in ANY combat (tried Naryu Sanctum and Mushin's Tower 13-15) I get slow-downs, frameskips, and screen freezes. 10-15fps at best in these scenarios.

 

I had changed no settings at all prior to that, either in game client OR Windows. I tried a full uninstall and reinstall. The problem persists. I loaded up 32bit client and I have 120fps in low-population areas and 70ish in places like Mushin's Tower. What's the deal with the 64bit client, why would it suddenly stop working?

 

 

EDIT: My laptop:

Windows 10 64bit

i7 7700hq 2.8ghz

16gb ram

GeForce GTX 1060

Client and Windows installed on same SSD

 

Edited by HatredInfinite

Share this post


Link to post
Share on other sites
Grimoir   

64bit works fine for me. Are you sure there were no windows updates that installed or your video drivers that updated?

Share this post


Link to post
Share on other sites
Fooder   

Same here, the difference is I've never logged in the last few months so I don't know when it started. The game was working fine in 64bit six months ago.

 

Sometimes it doesn't even start, xincode window in the corner doesn't appear and the client.exe just closes after a few seconds.

 

When it works all seems fine at the character screen, then in game I have around 30 fps, sometimes lower, sometimes higher. This on a GTX 1080 and just 1080p screen.

 

The 32bit client instead works as usual, no performance problems, and also loads 10 times faster. There's something massively wrong with the 64bit client. (also, while on 64bit in-game I had both CPU and GPU at 20%, the computer was just idling despite the poor performance)

 

I've tried disabling fullscreen optimization and other things, deleting the configuration files, but nothing worked. Only 32bit client is ok.

 

There seem to be plenty of people having problems, I've read suggestions about disabling bluetooth and other things. I've also tried that but on W10 bluetooth comes back up after restart even when deleting the info files. Probably some drivers embedded with the motherboard drivers. But I'm not going to mess with that further just because NCSoft can't code.

 

I very rarely have issues as this is a clean PC with just a few program installed, there's nothing that can conflict with this. I'm also on W10 1803 as the newest 1809 didn't came up yet, and I've installed the game in a different disk drive, so I cannot test the trick of moving it into "program files".

Share this post


Link to post
Share on other sites
Fooder   

I was able to fix it but I don't know how because I was trying a number of things at the same time.

 

But testing all of them didn't bring the problem back, so it might be something that triggered some sort of reset.

 

I suppose the most likely reason of the fix is that I moved the launcher from the default "Program Files (x86)" to "Program Files", but when I moved it back the problem was still fixed, somehow.

 

My guess is that it made Windows reset something that then carries over even if you move it back to its default directory.

 

Another option would be for NCSoft to rename client.exe to client64.exe, I wonder if these sort of bugs are triggered because both 64bit and 32bit have the exact same name for the ".exe".  Maybe just a name change to differentiate them might fix some conflicts...

 

 

Share this post


Link to post
Share on other sites
Fooder   

I got the solution, most likely.

 

I was doing tests switching between 64bit and 32bit after the problem was gone. Then suddenly the 64bit wasn't starting anymore. I tried moving again the directory, but the 64bit version still wouldn't start at all.

 

I eventually figured it out: after the (failed) attempts to disable completely bluetooth Windows reverted the configuration to the default.

 

Here's what happened:

I have of course bluetooth appearing in the device drivers, because that's part of the motherboard. But since I don't actively use bluetooth, I have it disabled in the options (Start > Settings > Devices > Bluetooth, there's an on/off switch). This is what caused the launching problems with the game, and I suppose the performance too.

 

What then happened is that when I tried to remove bluetooth drivers completely I didn't succeed, and on reboot Windows not only restored the drivers, but it also RE-ENABLED bluetooth in the settings. This is what actually seems to have FIXED all the problems.

 

I've accurately tested this, if I enable bluetooth the 64bit client starts, if I turn it off it fails to launch and just sits there waiting and doing nothing.

 

TL;DR, on Windows 10

Start > Settings > Devices > Bluetooth > you should see an on/off toggle. Turn it on and try running again the 64bit client.

 

This might also explain why only a few of us are seeing this problem. If other people haven't bothered disabling bluetooth in the options then they wouldn't notice anything wrong.

 

In any case, NCSoft should fix this.

Share this post


Link to post
Share on other sites
Bread   

I'm glad I happened upon this thread. I hadn't thought of switching to the 32-bit client. Doing that fixed my framerate problems as well.

 

Just to pitch in to this thread: I've got exactly the same problem. The 64-bit client suddenly started performing horribly about two weeks ago. I first tried fiddling with my drivers a lot. Actually uninstalling my drivers and using the ones that Windows 10 automatically downloads worked for me for a little while (only one instance of playing B&S, to be precise), but it seems to have been a fluke. Areas where I'd usually get 75 fps (which is what I've got the game capped at) were only giving me 20 fps and boss fights had me dealing with no more than 4 fps at times. Incredibly frustrating. Anyway, of course I'd prefer to use the 64-bit client, but using the 32-bit one will do for me for the time being. Definitely hope NCSOFT will fix this mess soon though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now