Milleinia

FPS was formerly 77-80 avg now can barely get to 31

Recommended Posts

So, I haven't played since December and literally haven't logged into the game until today and my fps is barely reaching to 30. I didn't change anything, still using the same laptop, still with the same settings and my fps is lower than normal. I already checked if anything extra is running in the background and it's nothing besides the usual when I play games (youtube, and 2 other tabs). Is it possible the update/updates that I missed have interfered with the optimization? Because I've seen this happen in Vindictus to some of my old friends back when we played it.  If not, any additional insight would be thoughtful if I can fix it or not.

Share this post


Link to post
Share on other sites
Souba   

You aren't the only one this has happened to for sure. I for one have been struggling to get decent FPS out of this game ever since one of the larger updates during winter of last year, and it has only gotten worse with every subsequent update. My computer exceeds the specs needed for B&S and it used to run perfectly at 60 frames. Now I have to play on the 32 bit client to even get a relatively smooth 30 out of it... I've tried so many fixes that just haven't worked.

 

One thing that was discovered by someone a while ago was that turning off tracked quests fixed certain graphical hitches for smoother FPS- this was working really well for me until the last couple of updates, but you might want to try it anyway.

Share this post


Link to post
Share on other sites
Xzard   

The rumor is that a Windows 10 update broke some games. You should check that out in bns reddit, I saw some solutions there.

Share this post


Link to post
Share on other sites
RavTH   
6 minutes ago, Xzard said:

The rumor is that a Windows 10 update broke some games. You should check that out in bns reddit, I saw some solutions there.

I highly doubt it, each maintenance I feel like game is slowly downgrading.

Share this post


Link to post
Share on other sites
Souba   
11 minutes ago, RavTH said:

I highly doubt it, each maintenance I feel like game is slowly downgrading.

Actually, he's not wrong. There are now components to windows 10 meant for "gaming" that do interfere- ever since the last windows update the already existing issues with B&S got worse for me (And I've been having issues with some games that I've never had problems with before) so this could be a part of what's causing trouble, though undoubtedly the aweful game engine is also at fault

Edited by Souba

Share this post


Link to post
Share on other sites
Xzard   
12 minutes ago, RavTH said:

I highly doubt it, each maintenance I feel like game is slowly downgrading.

He said that he didn't have those problems on December, without changing anything on his PC, but for sure Win10 updated.

Share this post


Link to post
Share on other sites
Riss77   

I also lost a lot of framerate after updating to Windows 10 version 1803, reverted to version 1709 and I was good again.

Share this post


Link to post
Share on other sites

Maybe the spectre / meltdown fix or something. Intel's "fix" slowed down some harddrive intensive operations by almost 30%. :p

Edited by ander01se

Share this post


Link to post
Share on other sites

just do what I did; don't buy into trove, get a better PC instead. Went from having issues holding 30FPS to 121fps NP

 

Share this post


Link to post
Share on other sites
8 hours ago, Xzard said:

The rumor is that a Windows 10 update broke some games. You should check that out in bns reddit, I saw some solutions there.

I did have my windows 10 update a few months ago, so even if it's a rumor I'll check into it. Thank you

Share this post


Link to post
Share on other sites
9 hours ago, Souba said:

You aren't the only one this has happened to for sure. I for one have been struggling to get decent FPS out of this game ever since one of the larger updates during winter of last year, and it has only gotten worse with every subsequent update. My computer exceeds the specs needed for B&S and it used to run perfectly at 60 frames. Now I have to play on the 32 bit client to even get a relatively smooth 30 out of it... I've tried so many fixes that just haven't worked.

 

One thing that was discovered by someone a while ago was that turning off tracked quests fixed certain graphical hitches for smoother FPS- this was working really well for me until the last couple of updates, but you might want to try it anyway.

 

I feel ya, used to run 77fps so smoothly in dungeons and raids and now I drop to 13 fps just from opening inventory. Thanks I'll try that out as well 

7 hours ago, Riss77 said:

I also lost a lot of framerate after updating to Windows 10 version 1803, reverted to version 1709 and I was good again.

How did you revert it back? 

Share this post


Link to post
Share on other sites
HateMe   

Google how to disable FTH under windows 10. That should instantly fix this for you.

Share this post


Link to post
Share on other sites
Riss77   
4 hours ago, Milleinia said:

How did you revert it back? 

Windows update, see history, uninstall updates or the backup recovery if you have some backup somewhere before the big Windows feature updates.

Share this post


Link to post
Share on other sites
Fieryfly   

I bought the next upgrade to Comcast's speed increase to 500mbps down 75mbps up package. I also am doing a PC upgrade from a Intel i5 4670K to a Intel i7 8700k & Z270 MSI mainboard 32 Gb DDR4 3866Mhz memory, 512GB Samsung NVMe 970 Pro M.2 drive. December of 2017 I was getting 115-120 frames and now Im having serious FPS issues in Vt lowest so far has been 7 fps, average is 20-30.. its like Blade and Soul took a dump. If they want my money & my continued support of their game.. they must invest more time in resolving this issue.

Share this post


Link to post
Share on other sites
HateMe   
1 hour ago, Fieryfly said:

I bought the next upgrade to Comcast's speed increase to 500mbps down 75mbps up package. I also am doing a PC upgrade from a Intel i5 4670K to a Intel i7 8700k & Z270 MSI mainboard 32 Gb DDR4 3866Mhz memory, 512GB Samsung NVMe 970 Pro M.2 drive. December of 2017 I was getting 115-120 frames and now Im having serious FPS issues in Vt lowest so far has been 7 fps, average is 20-30.. its like Blade and Soul took a dump. If they want my money & my continued support of their game.. they must invest more time in resolving this issue.

what you are describing is not an issue with Blade and Soul its an issue with your machine / OS. Look into disabling the FTH feature. I build my PC a few weeks back aswel with I78700k, Samsung 970 Evo M2 and 1080 GTX TI. And i had also 20-30 FPS, once i disabled FTH and Bluetooth from my motherboard my fps went to 120+

Share this post


Link to post
Share on other sites
LiNe171   
22 minutes ago, HateMe said:

what you are describing is not an issue with Blade and Soul its an issue with your machine / OS. Look into disabling the FTH feature. I build my PC a few weeks back aswel with I78700k, Samsung 970 Evo M2 and 1080 GTX TI. And i had also 20-30 FPS, once i disabled FTH and Bluetooth from my motherboard my fps went to 120+

Windows 10 has FTH? When i search about it i only see FTH on Windows 7..

 

Edit: I Think i found how on reddit thread about bns

Edited by LiNe171

Share this post


Link to post
Share on other sites

Simple answer - the big Windows 10 2018 update attempted to fix a bug in certain graphics cards that could be exploited to bypass security on a computer system. Unfortunately, what they did to guard against the exploit also puts more strain on your system, causing lower overall FPS and higher ping.

 

You can try to revert to a previous version of Windows 10 or to look up a way to disable the system Windows added, but it might only be a temporary solution, knowing how Microsoft loves forcing updates down people's throats whether they want it or not.

Share this post


Link to post
Share on other sites

What I notice is that the avg GPU temperature skyrockets on my machine. Can easily go to 80+ so that I physically feel it with my hands on top of the laptop. No other game does it - and thing is that I don't see a high FPS, it is usually 60 but randomly drops to 30..40 with no real reason (even in an empty space without any objects). So yes, it's pretty sad.

Share this post


Link to post
Share on other sites
SkyStorm   

Power consumption of your graphics card and fps are only loosely related. Any gpu benchmark or stress test will make a video card nice and toasty at a relatively low fps. I used to throttle my GPU at 90 to prevent overheating (the card had a crappy fan that couldn't be replaced).

Share this post


Link to post
Share on other sites
5 minutes ago, SkyStorm said:

Power consumption of your graphics card and fps are only loosely related

Power consumption in general is not related to FPS. But what it is related to is the level of load (sheer calculations) that's put on the GPU. And high level of that is usually an evidence of a poor optimization. And if something has poor optimization - it will tend to end up performing poorly on larger percentage of GPUs. I'm still at luck to run it at ~60 just because of raw GPU power but many aren't so lucky.

Edited by Dellecross

Share this post


Link to post
Share on other sites

Blade & Soul should be renamed to lag and soul. Never saw a laggy game like this, with bad optimisation and high ping.

Share this post


Link to post
Share on other sites
Souba   
20 hours ago, SilverFoxR said:

Simple answer - the big Windows 10 2018 update attempted to fix a bug in certain graphics cards that could be exploited to bypass security on a computer system. Unfortunately, what they did to guard against the exploit also puts more strain on your system, causing lower overall FPS and higher ping.

 

You can try to revert to a previous version of Windows 10 or to look up a way to disable the system Windows added, but it might only be a temporary solution, knowing how Microsoft loves forcing updates down people's throats whether they want it or not.

What is this process called? I can't seem to find it's specific name and I'd like to take a crack at disabling it on my machine.

Edited by Souba

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now