Jump to content
Forums

Constant crashing, dungeons won't load regularly


Rui Rui
 Share

Recommended Posts

So probably a month or so ago my game would constantly crash and EC have problems loading. I've never had this problem when I first got the game... :/
When Blade & Soul crashes I don't get the "Blade&Soul has stopped worked" pop-up the game just closes without warning. I get no FPS drops when it happens as well.
With EC not loading in properly is when you get to the part where you go into these rooms and kill the mobs, its just not there and would take 10 secs to a minute to load in.

I don't have any screenshots or recordings that I know of but when I take some I'll edit the post.

I'm not that smart when it comes to computers but I did my best to list what I could find out about my PC if it helps.
Ram: 16 GB DDR3
Graphics: NVIDIA GeForce GTX 1050
Processor: 3.3 GHz AMD FX

Link to comment
Share on other sites

On 7/4/2018 at 8:08 AM, HateMe said:

Not sure if it helps for you, but assuming you run windows 10, add the blade and soul folder as exception to windows defender.

I will do so once I can and ill let you know if that worked. 

Edit: Crashes stopped happening as much but I still get the loading issues with the dungeons

Edited by Rui Rui
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...