IAmWho

SOLVED!! 64bit low fps cap and 64 bit Launch failure

Recommended Posts

IAmWho   

Issues I have encountered and bugged me for ages:

1. Having FPS capped at <20 in 64 bit client on high end PC, and had to switch to 32 bit, but from this I will have an extremely high potential FPS~120 but drops bad in combat, sometimes it causes screen freeze too.

 

2. Using 64 bit client, after you clicked launch then waited for it to load, the game disappears after loading Xigncode. (it also disappears in Task Manager if you pay attention to it. It will normally start and stop at ~70mb memory while xigncode scans it, then increases while the loading picture pops up in your screen)

 

Note: When I say FPS cap, it doesn't mean you are fps lagging because you are using a low end PC, what I mean is: When I play other game on ultra or even high graphic settings, they never gave me lag, everything was fluent and nice. When it is capped, it is like something is limiting your FPS, in my case, it is limited to 1/6 of it (now I have 120 FPS :HajoonSurprised:) so like, for the time i have 60 fps in raids, during capped time, it will be 60/6 =  10 fps..... yep. If my computer is really that bad where I can only get 20 FPS max, then why the heaven in 32 bit client I can have 120FPS? Therefore something is there doing stupid stuff. 

 

After all of the research and experiment I did to this game for years.

 

Solutions that I tried but not so effective:

 

1. FTH stuff, more detail here: 

 

2. Upgrading or downgrading your graphics card (most Nvidia users are having this issue). This one did work for me during October~December last year (2017), where I did not upgrade my graphics card driver, but downgraded them to a version in August, however, this stopped working this year. You can try this if you want, re-install, uninstall won't hurt much, just need a couple of restarts. (I'm using Nvidia 960M, it shouldn't be that laggy for real, so this should not be the main problem to fps caps)

 

3. Right click the Blade and Soul icon on your desktop>properties>Compatibility here make sure you do not select any compatibility, just simply untick it, simple. Some times this solves my first problem (FPS cap), but not every time, it really depends on luck which disappointed me a lot.

Source: 

I got my experience from here, but at windows XP sp3, it only solves client disappearing issue, while fps cap issue is still there for me.

 

 

4. People say run as administrator. I personally don't find this really useful. 

 

5. Quit everything in the background including your anti-virus. Well this is a good way to boost up a bit if you are on a low end PC, but it really has nothing to do with the FPS cap issue and the disappearing issue. 

 

Solutions that helped and worked:

 

1. Uninstall your Bluetooth completely. Don't laugh please, I was triggered when I see this solution, how the **** will this work? Well, I just gave up and tried this, since I uninstalled my Bluetooth last month, my game never crashed again, never lagged again, NEVER, NEVER, repeat NEVER. We don't really need Bluetooth nowadays, do we? so uninstalling it won't hurt, give it a try and put your feedback here :)

PS: how to remove Bluetooth https://support.microsoft.com/en-ca/help/889814/how-to-remove-bluetooth-wireless-device-support-in-windows-xp-service

 

2. Right click the Blade and Soul icon on your desktop>properties>Compatibility here make sure you do not select any compatibility, just simply untick it, simple. (this is repeated from last section, but I find this essential to do if you don't want to run into any errors)

 

3. For Nvidia users only! after completing above, if you still want some boost in FPS, this guy helped me a lot:  

 

 

So good luck BNSing.

Hope this will solve this issue for all fellow players in the future and enjoy lagless 64 bit client!

 

Will keep editing when I come up with something else I forget.

 

UPDATE Jan. 2019:

It's been almost a year now, and I never had any issue with this fix lol

Edited by IAmWho

Share this post


Link to post
Share on other sites
Kazutou   

Bro thank you it worked this problem just recently appeared on me, i have been trying to fix it for the last 2 days i uninstalled did file repair everything ❤ ❤ ❤ ❤ed around with my Nvidia settings but got nothing. If i unticked the compatibility it wouldnt launch but if i Windows XP (service pack 3) it would launch but i would be capped at <20fps. After i deleted Bluetooth completely and unticked the box it launched and FPS is back to how it used to be. Thank you man, helped alot!

Share this post


Link to post
Share on other sites

I did the FTH thing u suggested and it made my game not start up if I dont put the 64bit client to run as admin and in compatibility mode windows 8. My pc doesnt have bluetooth in it so its already uninstalled technically and still im getting 20 fps cap.

Edited by Ichirou163

Share this post


Link to post
Share on other sites
IAmWho   
10 hours ago, Ichirou163 said:

I did the FTH thing u suggested and it made my game not start up if I dont put the 64bit client to run as admin and in compatibility mode windows 8. My pc doesnt have bluetooth in it so its already uninstalled technically and still im getting 20 fps cap.

As I mentioned, FTH is not an effective solution to this, please refer to the bluetooth part

Edited by The Hepta K

Share this post


Link to post
Share on other sites

Remove  any compatibility mode and then turn your Bluetooth off from settings after that try again and Launch it.  Well that  worked for me  on Windows 10 Thanks ! Hepta K

Edited by DarkSlayer3D

Share this post


Link to post
Share on other sites
On 4/28/2018 at 7:54 AM, The Hepta K said:

As I mentioned, FTH is not an effective solution to this, please refer to the bluetooth part

You completely missed the part where Ichirou163 said that they do not have Bluetooth on their PC.  I do not either, not all motherboards have Bluetooth hardware.

 

There is NO option in Device Manager, or anywhere, to turn Bluetooth on or off, or disable any" drivers.  As a matter of fact, when I try to force something, I get a dialogue saying that my computer "does not support Bluetooth" and "does not have it installed." (sic)

 

That being said, the current April Update for Windows 10 is just not compatible with the 64-bit BnS client.  I've reported this to BnS Support several times over the last several months, being that I discovered it while participating in the Windows Insider program, but NCSoft has completely ignored my bug reports on the problem.

 

Of note, on the Insider builds, I also was unable to run the 32-bit client, so I had to uninstall the Insider build, just to play BnS.  Now that the April Update is Live, at least the 32-bit client works.  I know that Microsoft did implement some new driver security enforcements, I also had a problem with My,com's anti-cheat that they had to patch, so since IGNCode is failing to launch in 64-bit mode, but works in 32-bit, I suspect that they fixed it for 32-bit, but haven't gotten to 64-bit yet.  64-bit seems to be problematic for a lot of NCSoft's games , if anyone remembers Aion's experiments with it.  Even Guild Wars 2, (ArenaNet, but still NCSoft) had to custom build a 64-bit client, that does run into it's share of problems with occasional Windows updates.

 

AFAIK, there are no "tricks" to getting the 64-bit client to work with this new April Update.  I've even tried a "clean install".  So, it's up to NCSoft to debug and fix it, so I imagine that, like with everything else, they'll get around to it when they get around to it, but hopefully something will be patched into this upcoming update on the 9th.

 

 

Share this post


Link to post
Share on other sites
IAmWho   
On 5/6/2018 at 11:04 PM, Sekkerhund said:

You completely missed the part where Ichirou163 said that they do not have Bluetooth on their PC.  I do not either, not all motherboards have Bluetooth hardware.

 

There is NO option in Device Manager, or anywhere, to turn Bluetooth on or off, or disable any" drivers.  As a matter of fact, when I try to force something, I get a dialogue saying that my computer "does not support Bluetooth" and "does not have it installed." (sic)

 

That being said, the current April Update for Windows 10 is just not compatible with the 64-bit BnS client.  I've reported this to BnS Support several times over the last several months, being that I discovered it while participating in the Windows Insider program, but NCSoft has completely ignored my bug reports on the problem.

 

Of note, on the Insider builds, I also was unable to run the 32-bit client, so I had to uninstall the Insider build, just to play BnS.  Now that the April Update is Live, at least the 32-bit client works.  I know that Microsoft did implement some new driver security enforcements, I also had a problem with My,com's anti-cheat that they had to patch, so since IGNCode is failing to launch in 64-bit mode, but works in 32-bit, I suspect that they fixed it for 32-bit, but haven't gotten to 64-bit yet.  64-bit seems to be problematic for a lot of NCSoft's games , if anyone remembers Aion's experiments with it.  Even Guild Wars 2, (ArenaNet, but still NCSoft) had to custom build a 64-bit client, that does run into it's share of problems with occasional Windows updates.

 

AFAIK, there are no "tricks" to getting the 64-bit client to work with this new April Update.  I've even tried a "clean install".  So, it's up to NCSoft to debug and fix it, so I imagine that, like with everything else, they'll get around to it when they get around to it, but hopefully something will be patched into this upcoming update on the 9th.

 

 

I don't think clean install solves this problem, since this game is having issues with other settings in PC's config, to what I have discovered, and from all of my friends' computer, compatibility is basically the main thing to make you run 64bit regardless of the fps being capped, meanwhile, Bluetooth played a part in capping your fps, and only capping. But if you don't have Bluetooth installed on your computer, I guess it would be the computer hardware issues. An enough geared computer should have Bluetooth compatible, and hence disabling it will solve your problem when you have a playable computer to this game.

If you have a low configured computer, then lag has nothing to do with fps cap, 64 bit processing rate is way too heavy for the computer to run.

Share this post


Link to post
Share on other sites
Yndril   
On 4/28/2018 at 4:54 PM, The Hepta K said:

As I mentioned, FTH is not an effective solution to this, please refer to the bluetooth part

FTH was the thing that was causing the FPS problems for me, I excluded Client.exe, restarted the computer and removed the state, have been working as it should since.  No more fighting in less than 4 FPS.

 

 

Share this post


Link to post
Share on other sites
Hotsuchi   

How does one uninstall bluetooth on windows 10? cause i know its got it but I do not see it under device manager

Share this post


Link to post
Share on other sites
IAmWho   
On 9/4/2018 at 10:13 PM, Hotsuchi said:

How does one uninstall bluetooth on windows 10? cause i know its got it but I do not see it under device manager

if it's not under device manager, then bluetooth is probably not installed on your computer :/

Share this post


Link to post
Share on other sites
Tawnea   

I gotta say this game is garbage.  I've formatted my PC and the problem went away for a bit and now it's back, it's on and off some days works fine and others I just can't get the game to run the 64 client above 10fps.  Even when I load the game I know when it's going to run slow cause even loading it takes much longer so it's not video driver related.  The 32 bit client runs fine but it crashes alot!  I've tried every fix I can find on the forums and youtube and nothing works, until it just decides to work suddenly after a few days at 60fps.  Seriously..

 

So many of the bugs that plagued this game from day 1 are still here it's super annoying I want to throw this game in the bin and spit on it. 

Share this post


Link to post
Share on other sites
Tawnea   
18 hours ago, DeadyOwO said:

@Tawnea Try moving your client folder from "Program Files (x86)" to "Program Files".

It's on a seperate drive f:\games\bns

Share this post


Link to post
Share on other sites
IAmWho   
On 1/20/2019 at 8:22 PM, Rmccn08 said:

wtf it actually worked. thanks

Glad it worked, you are welcome :)

Share this post


Link to post
Share on other sites
Hogokyu   

it did not work for me but it doesn't matter.. this is my last month paying for the game.

I just cba to talk to GMs and giving them logs, only to have them ask me for even more logs... they are just doing damage control at this point.

 

There is no official post regarding this and no effort made whatsoever to fix it as far as i can see.

Share this post


Link to post
Share on other sites
IAmWho   

Well, this solution worked for so many people so far including me on all the machines I’ve been using. Really hope the support team can see this and act upon it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now