Jump to content
Forums

Fix for low fps (Nvidia)


Antiheld
 Share

Recommended Posts

Game was running horrible on my laptop before,  25 fps and 10 fps during combat, with a lot of screen "freezing". Fixed issue by changing Manage 3D Settings in Nvidia Control Panel. Made new prefixed profile for Blade and soul in Program Settings tab. 

Here are links for screenshots of settings i'm using in Manage 3D Settings.

https://drive.google.com/open?id=1dDNTCSgkK79XucqrBJ-eR-uHqyyXjnZN

https://drive.google.com/open?id=1W3KhR_DwScDik2_irg6MvymS0SBjwLg1

https://drive.google.com/open?id=1XGLlT2SUiAgOw6dCHyPid9uWW881nV4O

 

Also in game settings i'm using Optimized for combat. Extra effects Off expect for Depth of Field: On. Having Depth of Field: Off seems to cause fps drops. 

Game is running now smooth 60 fps. I even was able to drop Optimize for Low End PCs settings which i had on before. Also having for example Chrome open in background causes loss of fps for some reason. 

 

Computer specs:

7700HQ, 1050 2GB and 8GB ram. 250Gb PCIe SSD. 

 

 

 

Edited by Antiheld
Link to comment
Share on other sites

Well, you didn't fix the issue. You just reduced graphic settings to a very low quality. Your notebook should run fine with much better settings but there is an issue with nVidia drivers and Windows 10 gaming mode right now. Disabling Windows 10 gaming mode, using nVidia GeForce Experience and installing the latest DX9 drivers might be an option to you to have better graphic quality AND higher FPS rates. If that doesn't work you can still play with reduced settings.

Edited by Cohen
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...