shujin51

Solution to low fps on 64bit client!

Recommended Posts

shujin51   

Since stupid bns reddit removed my post for whatever technical support reasons, I decided to post it here to help the community!

This solution is for those who are stuck at 20-30fps with the 64bit client!
Bear in mind that this might not work for everyone! There is no need to reinstall the game at all! Before I started doing all these things I also removed the folders "Xigncodes" from: C:\Program Files\NCSOFT\BnS\bin
C:\Program Files\NCSOFT\BnS\bin64
For some people, changing the compatibility mode to windows xp also works but sadly it didn't work for me.

 

ATTENTION! In case you still experience this low fps crap from time to time, open your task manager and observe how much memory the client consumes while trying to start the game with the game logo. Usually it should consume around 1200mb in the beginning and then goes up to 2000+ in about 20-40 seconds. If it stay low after a long time then end that task and restart game until it has the same pace as mentioned above. I do have to mention that I have 16gb though so the values might differ depending on how much memory you have. Folders still have to be in 64bit path!

 

Step 1: Move the folders from
C:\Program Files(x86)\NCSOFT
C:\Program Files(x86)\NCWEST
to
C:\Program Files\NCSOFT
C:\Program Files\NCWEST

 

Step 2: Download official NCsoft launcher from the following link and run it as administrator.
https://support.bladeandsoul.com/hc/en-us/articles/207195856-How-to-re-install-only-the-NCSOFT-Game-Launcher

Step 3: Rightclick on the shortcut of bns on the desktop and go to "properties".

 

Change the following things: (or just remove the part with (x86), dont forget to remove the space as well!)
Target:
"C:\Program Files\NCWest\NCLauncher\NCLauncher.exe" /LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com"
Start in:
"C:\Program Files\NCWest\NCLauncher"

 

Step 4: Run the game and let it patch the launcher and game folder. DONT FORGET TO TURN OFF 32bit in launcher settings!

 

Step 5: Have fun :)

 

If you have any questions my IGN is YoonSora on Jinsoyun EU server

Share this post


Link to post
Share on other sites
Wytsii   

Hello, I tried your solution, but when the folders are in the 'C:\Program Files' directory, Blade & Soul will run in 32-bit even if I uncheck the box in the launcher to run in 32-bits. It this supposed to happen?

Share this post


Link to post
Share on other sites
ooOoo   

also going to "task manager, details" and check all cores to be used and affinity to High makes a nice difference to the performance (have to do this each time you launch the game though)

Share this post


Link to post
Share on other sites
Wytsii   

The client uses all cores already, and i changed the details settings to high, but it still doesn't make any difference. I was at mushin tower standing next to the training dummies, and i got 5-10 fps.

Share this post


Link to post
Share on other sites
shujin51   
vor 3 Stunden schrieb Wytsii:

Hello, I tried your solution, but when the folders are in the 'C:\Program Files' directory, Blade & Soul will run in 32-bit even if I uncheck the box in the launcher to run in 32-bits. It this supposed to happen?

After the game launched, what does task manager say? Is it 32bit or 64bit? 

Share this post


Link to post
Share on other sites
shujin51   
vor 3 Stunden schrieb ooOoo:

also going to "task manager, details" and check all cores to be used and affinity to High makes a nice difference to the performance (have to do this each time you launch the game though)

Performance wise yes but that wont change the fact that the game is stuck at 20-30 frames. It has nothing to do with it. U can even put all settings at 1 and u will still be stuck at low frame rates. And with an i5 and gaming gpu, it isnt supposed to happen.

Share this post


Link to post
Share on other sites
shujin51   
vor 2 Stunden schrieb Wytsii:

The client uses all cores already, and i changed the details settings to high, but it still doesn't make any difference. I was at mushin tower standing next to the training dummies, and i got 5-10 fps.

Standing next to the dummies with all the people around is the worst you can do. The cpus arent made to handle hundreads of characters at one spot and if ur pc is just average then u have to deal with low fps when having all people visible. My main point is standing somewhere where no1 is around and still stuck at 20-30 frames. Other cases you will have to upgrade your pc :P

Edited by shujin51

Share this post


Link to post
Share on other sites

Hey I have a question after Step 1 I noticed after Step 2 it recreates a NCWEST folder in the x86 directory. SO after finished I have NCSOFT in the Program Files with NCWEST and another NCWEST in the x86 directory. I assume step 2 is to be fully completed before doing step 3 e.g. running the installer fully which I think is what installs the installer to x86. Unless ur also supposed to change the installer dir during installation. It detects the game in the Program Files folder and remembers previous settings and runs in x64 I havent tried to see if I notice a difference but just making sure this is the way its intended for this fix.

Share this post


Link to post
Share on other sites
Dany1589   
Quote

 

I followed your instructions correctly. But I have a question, when I checked task manager, NCLauncher Module is at 32bit, however, Blade & Soul by bloodlust(x64), is that normal? or no? I did followed your instructions correctly tho.

Share this post


Link to post
Share on other sites
Ereol   

transfering the installation files in x86 to x64 program files solves my problem. from 20fps to 60fps. thanks shujin51

Share this post


Link to post
Share on other sites
shujin51   
Am 4/6/2018 um 14:37 schrieb Ichirou163:

doesnt work

What was ur issue? Please tell me your specs of ur pc so i know if you can even pass 30fps

 

Share this post


Link to post
Share on other sites
13 hours ago, shujin51 said:

 

Idk I tried doing everything, exclude on antivirus, delete and redownload xigncode, changed directory, put the game on ssd, compatibility settings, reinstalled Direct X 9, Nvidia Control Panel Tweaks and it doesnt work.

 

I used two pcs already to test the problem and still it is the same on both

 

ROG Laptop:

i7 7700HQ 3.8Ghz 

256 SSD

16GB RAM DDR4

4GB GTX NVIDIA 1060

Asus Strix Motherboard

 

PC:

i7 3770K 4.0Ghz

16GB RAM HyperX Fury DDR3

256 SSD

6GB GTX NVIDIA 970

 

Edited by Ichirou163

Share this post


Link to post
Share on other sites
shujin51   
Am 11.4.2018 um 02:02 schrieb Ichirou163:

Idk I tried doing everything, exclude on antivirus, delete and redownload xigncode, changed directory, put the game on ssd, compatibility settings, reinstalled Direct X 9, Nvidia Control Panel Tweaks and it doesnt work.

 

I used two pcs already to test the problem and still it is the same on both

 

ROG Laptop:

i7 7700HQ 3.8Ghz 

256 SSD

16GB RAM DDR4

4GB GTX NVIDIA 1060

Asus Strix Motherboard

 

PC:

i7 3770K 4.0Ghz

16GB RAM HyperX Fury DDR3

256 SSD

6GB GTX NVIDIA 970

 

Did you update the launcher? You can just remove ncwest, reinstall the launcher and move the folder to the 64bit folder. After that if you notice that it take longer than a minute or so to start the game, then open task manager and kill it. DO it as often as possible until the game starts normal again. With ur specs, boot time should be around the same as mine. So around 1min or less. Pay attention to the ram it uses in task manager. If it increase rapidly then the launcher is doing it right. If it increases really slowly and not even pass the 2k ram then u need to kill the process and restart again and again. I know this is a pain but since ncsoft doesnt care about their game, we as players have to find a solution

Edited by shujin51

Share this post


Link to post
Share on other sites
On 4/14/2018 at 3:51 PM, shujin51 said:

Did you update the launcher? You can just remove ncwest, reinstall the launcher and move the folder to the 64bit folder. After that if you notice that it take longer than a minute or so to start the game, then open task manager and kill it. DO it as often as possible until the game starts normal again. With ur specs, boot time should be around the same as mine. So around 1min or less. Pay attention to the ram it uses in task manager. If it increase rapidly then the launcher is doing it right. If it increases really slowly and not even pass the 2k ram then u need to kill the process and restart again and again. I know this is a pain but since ncsoft doesnt care about their game, we as players have to find a solution

My launcher is updated and ive tried using bnsbuddy yet i experience the same laggy fps on 64bit

Edited by Ichirou163

Share this post


Link to post
Share on other sites
shujin51   
Am 28.4.2018 um 05:57 schrieb Ichirou163:

My launcher is updated and ive tried using bnsbuddy yet i experience the same laggy fps on 64bit

What do u mean by laggy fps? I need more details. What is your average fps, what problems you have right now when doing dungeons, raids. Laggy can have many meanings :P I cant see your screen so u have to make a more accurate problem statement

Edited by shujin51

Share this post


Link to post
Share on other sites
1 hour ago, shujin51 said:

What do u mean by laggy fps? I need more details. What is your average fps, what problems you have right now when doing dungeons, raids. Laggy can have many meanings :P I cant see your screen so u have to make a more accurate problem statement

by laggy i mean my fps is still locked at 20 fps whenever i use the 64 bit client. This problem happens even if i use bnsbuddy as the launcher and Ive done almost everything on the web on how to fix this game's client and it is still the same, locked at 20 fps. I even try to lower the graphics, check optimize for old pc but it has no effect on my fps.

Share this post


Link to post
Share on other sites
shujin51   
vor 19 Minuten schrieb Ichirou163:

by laggy i mean my fps is still locked at 20 fps whenever i use the 64 bit client. This problem happens even if i use bnsbuddy as the launcher and Ive done almost everything on the web on how to fix this game's client and it is still the same, locked at 20 fps. I even try to lower the graphics, check optimize for old pc but it has no effect on my fps.

 

try this out. Look at the solution in the comment section. Just in case, delete your whole game and leave no trace, restart and reinstall everything. Then simply try this trick. The issue with the fps lock is simply because for some reason it starts the game with onboard gpu instead of the pci-express.

Speaking of gpu. Did you put rendering in the nvidia settings to gpu instead of auto? I made a seperate configuration for bns only instead of using the global settings

Edited by shujin51

Share this post


Link to post
Share on other sites

I fixed mine by downloading bns buddy and enabling Multi-client option in the extras tab. Now I play 120 fps on 64 bit :)

Share this post


Link to post
Share on other sites

Normally I would get about 30 fps max with max graphics, which stayed constant even in fights. However, within the past 2 days, idle will give me 20 fps and fighting would bring it down between 3-8 fps even when i turned the graphics as low as possible. (I think BnS servers are having issues). So, now I went ahead and did this and now I max out at 120 fps idling and it still stays pretty high in combat with max graphics. 

 

NVidia 1060, 16gb ram, i7 core... I could definitely tell something was up XD

 

Edit: Oh, never mind. It doesn't work anymore. It worked only the first time I launched. Any time after I get the horrible fps issue.

Edited by RaptureGod

Share this post


Link to post
Share on other sites
LexiGurl   

Hello I was wandering if any update on a easy fps fix I've had just about done everything on the web an I only still have 6-9 fps my PC isn't old infact it should had been able to play okay with B&S but nothing works or stays long, help pls

Share this post


Link to post
Share on other sites
HateMe   
On 8/4/2018 at 7:49 PM, LexiGurl said:

Hello I was wandering if any update on a easy fps fix I've had just about done everything on the web an I only still have 6-9 fps my PC isn't old infact it should had been able to play okay with B&S but nothing works or stays long, help pls

What are your pc specs? which processor and video card and OS do you have?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now