Wytsii

Windows 10 Low FPS and launcher issue

Recommended Posts

Wytsii   

Hello all,

 

I've been having issues since the Windows 10 Fall Creator Update (dec 3), and I've seen other posts about this. I want to give clear information about the issues and I hope others can help me (and others) out to resolve the issues. I have send a ticket about my issues, but they gave up after about 8 tries to help solve my issues.

 

Blade & Soul won't launch (somehow solved):

Some people including me are having the issue when the launcher loads the game and the client doesn't appear/start after. To resolve this, you have to set the launcher's compatibility to Windows 8 or lower.

 

Low FPS issue (Frames per second):

In the 64-bit client I'm having the issue that I have max ~20 FPS, and ~5 FPS in dungeons/raids and sometimes it drops/freezes. In 32-bit it's a bit better, but not as it were before: ~30-50 FPS, and ~15 FPS in dungeons/raids with alot drops to ~5 or freezes.

 

  • I tried different settings in NVidia Control Panel, but none solved my issue.
  • I tried to solve this by changing Graphics setting, but settings low or high, it doesn't make any difference. Also my laptop could handle high settings before the Windows 10 Fall Creator Update.
  • I tried to disable background services and start-up programs on my laptop, but no difference.
  • I have updated all my drivers now and before I even tried older drivers for graphics card and CPU.
  • I did system scans to search for hardware/software issues, but there were no issues found.
  • I made a new profile on my laptop in case my own profile was corrupted, but there was no difference in playing B&S on the other profile/account.
  • I re-installed the launcher, and later I re-installed the whole game, I even deleted left-over files and folders to make sure everything was uninstalled before install.
  • I tried different compatibilities and turning off 'Optimize for fullscreen' setting in compatibility properties.
  • I tried turning off Game DVR in Xbox-app settings and turning off Windows Game Bar (Windows + G) in fullscreen.

 

Now, my next step I'm thinking about is to update my BIOS, but I doubt it has to do anything with this issue...

 

My laptop's specificationshttps://www.msi.com/Laptop/GL62-6QF.html#hero-specification 

Windows 10 Home 64-bit

Intel® Core™ i7-6700HQ CPU @ 2.60 GHz (not overclocked)

GeForce® GTX 960M graphics with higher performance

8 GB RAM

125 GB SSD, 23 GB free space (B&S is installed on this disk)

1 TB HDD

DirectX 12

BIOS version: E16J5IMS.10F

Share this post


Link to post
Share on other sites
Wytsii   
1 hour ago, shujin51 said:

I posted this a while ago. Try it out!

 

 

I tried your method to move folders and re-install launcher, I've read your steps about 10 times, so I'm sure i did it right. But somehow it still acts like 32-bit client while I unchecked that box in the launcher. Am I missing something?

Share this post


Link to post
Share on other sites
shujin51   
vor 10 Stunden schrieb Wytsii:

I tried your method to move folders and re-install launcher, I've read your steps about 10 times, so I'm sure i did it right. But somehow it still acts like 32-bit client while I unchecked that box in the launcher. Am I missing something?

Did you do step 3 right? Because that is the only explanation for the client to start with 32bit. U need to remove the "(x86)" from the shortcut because otherwise it will start with 32bit instead of 64. Sry for my late reply but I had to be at a party

Edited by shujin51

Share this post


Link to post
Share on other sites
Wytsii   
7 hours ago, shujin51 said:

Did you do step 3 right? Because that is the only explanation for the client to start with 32bit. U need to remove the "(x86)" from the shortcut because otherwise it will start with 32bit instead of 64. Sry for my late reply but I had to be at a party

I saw in task manager that the client is probably running in 64-bit, but it looked like 32 for me, because windows are bigger than normal. Maybe it runs a bit better now, but I'm not convinced that this really solved it, I used to have much better FPS than this in 64-bit.

Here can you see my settings: Hd9rsvF.png

Edited by Wytsii

Share this post


Link to post
Share on other sites
shujin51   
vor 4 Stunden schrieb Wytsii:

I saw in task manager that the client is probably running in 64-bit, but it looked like 32 for me, because windows are bigger than normal. Maybe it runs a bit better now, but I'm not convinced that this really solved it, I used to have much better FPS than this in 64-bit.

Here can you see my settings: Hd9rsvF.png

Thats normal. Xigncode is always 32 but the game itself has to be 64 and u have done it right. If windows are too big then maybe u have to scale it down in the game options. And yeah 64 bit looks a bit different tho while 32 bit looks a bit washed out. Even the scaling is different because 32 is usually for old pcs with lower resolution

Edited by shujin51

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now