Jump to content

Lightspeed not working


Recommended Posts

I'm in the process of leveling up a shadow spec gunner, and I just got to the point where I'm able to switch builds (in Dragonscale).


However, when I entered the F12 training room to test the mechanics, I noticed that when I stacked 100 dark light and entered lightspeed mode, my RMB ability was the same without the lightspeed effects of going into rapid fire.


Is this a bug, or is there something I haven't unlocked or what?

Link to comment
Share on other sites

On 10/11/2017 at 9:00 PM, LunaticAzure said:

Have you tried activating lightspeed outside of the training room? I can't remember if there's a level requirement.


Edit, I tried it in the training room, it does activate properly, so I assume there's another requirement.

I thought that could be the case as well, but I found out why in the end. The reason why I couldn't get it to activate was because there's two separate skills: Darkshot and Bullet Storm, with Bullet Storm being learned at lv 30 along with Tab. When I made the topic I wasn't lv 30 yet so that's why I couldn't use it. Thanks for trying to help though!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...