Stormbringer1

Gunslinger patch broke game for many PLEASE FIX

Recommended Posts

I have played B&S ever since it came to EU zone, and have had little issues playing the game. My game hardly ever crashed, I had decent good FPS to play the game even at high graphics settings with out problems BUT then came Gunslinger patch and it broke the game completely for me and from what I see in region and faction chat every time I'm online clearly also for alot of other players.

 

Now my game crash several times a day at any place and time in game, my FPS in raids and dungeons have dropped to an unplayable level of 20, 15 or even 10 FPS alot of times which makes game shutter and lag and make my DPS drop to 50% of what it was before AND THIS EVEN after I have been forced to lower my graphics settings to a minimum... and now raids are even only 12 players and almost kill the game on my system but before this patch I ran raids with 24 players on full graphics settings with no issues at all.

 

Considering I have experienced class expansions before with Soulfighter and Warlock with out that made the game run worse I am rather puzzled why this not huge expansion patch have made the game seem as if it is twice as large and hard on my system as before.... I have tried a full reinstall of game and all, and other tricks people suggest to no change, my computer run in perfect condition on all else heavy tasks and as said a change to crafting system and adding a gunslinger class should clearly not make such a huge impact on game size or drain on system so NC PLEASE acknowledge there is a problem with the code of this patch here on your forum where you list known problems and even more important FIX this broken patch  weather it be a code or optimization issue.

 

I like your game very much, I am Premium member and about 1 month from a 1 year renewal which was 100% sure before this patch, but at the current state the game is in after this patch, I can say I will not be renewning anything before you fix the mess this patch made for many players or atleast you let us know u are aware of the problem and work to solve it so I and others can play the game as normal again.

Share this post


Link to post
Share on other sites

i can sadly only agree, before this patch all ran fine, had near no problems, rarely a crash a day, and sometimes not even that, lag/stutter was fixable with hide other players for a short time but this patch BROKE SOMETHING and that is not just for a few people, alot ppl complain that their FPS drop like stupid, they crash randomly without any pattern  to see, different places and times, sometimes in social areas, sometimes when only player near and far..

 

THERE IS A PROBLEM that was caused with the GUNSLINGER UPDATE and im not willing to renew my yearly sub before i see this acknowledged, no more money from me (or alot other ppl that think the exact same way) the fact that so far no word was lost about an issue of this size, well it makes no good impression, almost as if NCwest wouldnt care one bit if they lose alot players due to something THEY messed up...

 

and the game will lose alot of the core playerbase that was true to B&S since launch day if this isnt acknowledged/worked on soon...

 

im a day 1 vet myself and so far no other class introduction nor system change have ever before hit the game to a point where it became near unplayable...

 

 

so could we kindly get a word about anyone being aware of the issue and anyone at NCwest looking into it atleast maybe?

 

 

with best regards and in hope for a (possibly soon) fix, Naomy

Edited by NaomySugarpaws
typo

Share this post


Link to post
Share on other sites
Terakil   

i too have fallen victim to this issue, although i experienced it after the maintenance on 27/9/2017. up until that time all was well. i too suffer the obscene load times fps/latency issues that you have mentioned above. having looked into it i can see there has been no plausible response or acknowledgment of this issue by ncsoft on forums or elsewhere. this is a bad problem for alot of players to the point that where the load times are so bad i am being accused of leeching in the event dungeon because of heinous load times that can only be described as extremely lethargic........a one armed sloth moves quicker. please fix this NCSoft as you are the ones that broke it.

Share this post


Link to post
Share on other sites

For the first week of the Rise of the Gunslinger update, my character seemed more reactive. Attacks chaining were easier to do despite higher than average ping (160-200ms). Since two weeks ago, my RMB attacks will sometime stop for no reason unless I spam it every single time: Can't hold it anymore. People thought that it was an issue with the Gunslinger class only, but it's far more widespread. Destroyers, Summoners and Blade Masters have this problem too as far as I know.

As for overall game performance, it didn't change much for me, but I have a better than average GPU (Nvidia GeForce GTX 1060). Still, game runs as if I were trying to play a recent game on a 6-7 years old mid-range Gaming PC... I know some clan members have increased loading times, despite the game being installed on a SSD with plenty of space left.

Plus, servers seems way more unstable now: A lot of disconnection, poor latency (and a lot of spikes) and this is experienced by players from all around the world. We've got players from NA and EU in our clan, and well, almost everybody's latency got worse. We could argue that there are a lot of new players or returning players with the Gunslinger, but my guess is they just don't care. I got disconnected 5 times in a row in PvP today, lost my rank and no, this isn't my ISP: every other game is fine.

Sadly, I'm tired of this poorly optimized game with a crappy launcher (Closing the game when you get disconnected or when you're trying to log when your account is "already" connected, really?).

Edited by Pyrocyborg

Share this post


Link to post
Share on other sites

Can confirm what Pyrocyborg said about RMBs as a Blade Master (would also like character-randomly-quitting-draw fixed but that's not happening according to these 1.5 years).

Servers have gone terrible now - me and a lot of my clanmates have been experiencing random lag surges that just don't go away for several minutes + overall average ping seems to have increased.

Share this post


Link to post
Share on other sites
5 hours ago, Stormpooper said:

Can confirm what Pyrocyborg said about RMBs as a Blade Master (would also like character-randomly-quitting-draw fixed but that's not happening according to these 1.5 years).

Servers have gone terrible now - me and a lot of my clanmates have been experiencing random lag surges that just don't go away for several minutes + overall average ping seems to have increased.

Exactly, the game is running fine, and boom, out of nowhere, 400-300ms and then it goes back to normal. It's been like this since after the Gunner update. I also play Global MapleStory, which servers are also located in California, and I have no latency spikes.

Edited by CristianoJa

Share this post


Link to post
Share on other sites
Windy   

Hello,

I can confirm all of stated above by the OP.The game runs very badly on my machine and ,as much i was expected to see the 64 bit client to improve the performance ...it ran so good and i was very happy..so bad it didn't last long .The Gunner patch made the game run even worse then when I was playing the 32 bit versio,in addition it has crashes and sometimes put my entire pc in freeze.To mention that something really conflicts -because at random when I run BnS ,i get episodes of BSOD.No other games that I run or any other applications would make my pc behave like this .Please ,NcWest ,take in consideration that your players can't play the game anymore.Something have to be done,and no is not our ISP,the problem is general .Thank you .

Share this post


Link to post
Share on other sites

I can definitely attest to the latency issues, it has literally been going on since the patch release and is not getting any better and F8 has became nearly unplayable at times having even worse latency than open world

Share this post


Link to post
Share on other sites
Terakil   

Well its been 2 months since i reported this problem and still no fix all ncsoft want to do is blame me and my equipment/connections for the problem. I have tested checked everything the problem is server end proven by my isp. NCsoft are unwilling to take responsibilty and see fit to blame the issue on players and their equipment rather than looking at the issue that these patches caused. they even tried to blame these issues on the recent ddos attacks even though these problems were prevailent well before the ddos attack happened. NCsoft's response has quite frankly been poor. Has anyone here had a succesful response/fix?

Share this post


Link to post
Share on other sites
Terakil   

Also addto the fact that still all this time down the line and still no response in the forums with regard to this problem. Do NCsoft really care? their response and lack of action seems to suggest they don't. I have played this game for some time now and really enjoyed playing it until they broke it, I had been looking for a game that checked all the boxes and i found it with blade and soul. Just to have the fun pulled out from underneath me.......now due to this issue it has soured the experience for me and made me resentful , angry and to be honest completely unfaithful in NCsofts customer services/support. Also they dont seem to care if you have paid into the game the seem insistent in shifting the blame on anything that doesn't relate to them even though from this thread it is abundantly clear they broke it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now