Liinxy

XIGNCODE3 Issue Request Thread

Recommended Posts

Liinxy   

If you are encountering issues with XIGNCODE3, head over to the customer support Knowledge Base article to read the FAQ. If you are still having troubles with XIGNCODE3 after reading the FAQ, please reply to this thread using the following template and try to include as much detail as possible. To help with troubleshooting, please submit a ticket to Customer Support if you haven’t already and be sure to attach the XEM.log requested below.

ISP
Name of ISP you use to connect to the Internet.

 

Antivirus/Firewall Software
Name of the Antivirus or Firewall Software you use for security protection.

 

VPN and External Software
Do you use any VPN or any other software that may interact with how Blade & Soul runs?


Date & Time
Date and time of when the issue occurred. Please be sure to state the time zone of your region. (Example: Pacific Time = PST/PDT)

Frequency
How frequent does the issue occur?

 

Character Name
Which character did the issue occur on?

 

Server
Server where the character resides.

 

Description

Please try to include the following details.

  • What the issue is and what you were doing when the issue occurred? (Updating, Launching the client, Dungeon, etc.)

  • If an error message appeared when the issue occurred, please include what the message said.

     

Sending XEM.logs to Customer Support
Sending XEM.logs will help us in our troubleshooting process. Below are the steps to locate and send the file:

  1. Go to the BnS Folder. (C:\Program Files (x86)\NCSOFT\BnS)

  2. Then, go to bin(64) > XIGNCODE3 folder.

  3. Create a zip file containing all the files inside the XIGNCODE3 folder.

  4. Submit a ticket with the file to Customer Support at https://support.bladeandsoul.com/hc/en-us

Share this post


Link to post
Share on other sites
Dotimus   

i'm not going to fill the rest because i already did it with the support request

 

FPS cut in half on normal dungeon and drops to ONE FPS on raids  when using mouse software to bind mouse4 and mouse5

 

Do note, the game works without any problem on the first run after a reboot,

if you close the game  (like when you go to lunch) and start it again the FPS drops

There is no problem after a reboot

 

so, is not that you can't use mouse software, just the games bugs out on any launch after the first.

 

 PS: lets us bind mouse buttons directly in the game like any modern game does and make mouse software unnecessary

 

Edited by Dotimus

Share this post


Link to post
Share on other sites

I would say, with this new "gameguard" thing is laggy.

dropping FPS a lot.

in 32 bit version client cant handle crowded places like before. client suddenly crashes or not responding.

Share this post


Link to post
Share on other sites

ISP

Lanxhouse Telecom
 

 

Antivirus/Firewall Software

Windows Defender, Windows Firewall (both deactivated, both with exceptions set anyway)
 

 

VPN and External Software
No Ping Tunnel v14


Date & Time
6/2/17 around 11pm gmt -3 

Frequency
Randomly here and there, can be annoying

 

Character Name

Apple Bloom / Luna Latte
 

Server
Jiwan

 

Description

What the issue is and what you were doing when the issue occurred? It happens anytime anywhere, specially when there are big fights like in aomak in Basin or BT runs or even randomly anywhere.

Sometimes I get error 1000, sometimes 300, sometimes it doesn't say anything I just get lagged a lot then disconnect or sometimes it just freezes and closes, no forbidden words given ;)

Also this may be related to 64 bit client issues i'll make a topic about it please help us. 

 

So cute Liinxy <3

 

Share this post


Link to post
Share on other sites

For whatever reason Blade & Soul doesn't release the paged memory when it crashes. It can't even crash properly now. Once I reopen it I get a second XINCODE icon on my taskbar and another process instance that pages another 2+GB of ram without releasing the already paged memory. RIP this stupid xin thing. Not only is it debilitating the fps but also acts as a memory leak.

 

edit:
I should also point out that ending the extra process that hogs memory closes the extra xincode instance. Fix it pronto. My ram is for what I want to use it, not for your program to hog it all.

Edited by MassiveEgo

Share this post


Link to post
Share on other sites

     Since the introduction of    XIGNCODE3  my FPS during world boss fights (celestial basin, dawn of khanda vihar) has gone down by more than 70% from 20-25 fps down to 3-5 fps. In dungeons is noticeable also but not  as bad as during world boss fights and crowds.Also my ping in the last 2 weeks went from a average of 100-110ms to 140-160ms. Also these numbers make no sense, 1.7gb of ram out of 6gb is not 66.8%, what's going on here?GqTeFHH.png

Edited by RagingNight

Share this post


Link to post
Share on other sites

ISP
Suddenlink

 

Antivirus/Firewall Software
Malwarebytes Premium/Windows 10 Defender/Windows 10 Firewall

 

VPN and External Software
No


Date & Time
3:20PM EST

Frequency
On start of game.

 

Character Name
None can't get past loading screen.

 

Server
None can't get past loading screen.

 

Description

Played all night last night, woke up this morning to login and play. Message pops up saying:

 

0xE019012E

Error: Suspicious program detected. Please close any other programs you have running and restart the game.

 

(Everything is running that was last night when I was playing for several hours straight)

Share this post


Link to post
Share on other sites
Aimz   

ISP

Windstream

 

Antivirus/Firewall Software

AVG

 

VPN and External Software

No.

 

Date & Time

I'm on Eastern Time but the issue occurs sporadically from the time I log in until I get frustrated and log out. 

 

Frequency

Every single time I load BnS since Xigncode3 replaced the old gameguard.

 

Character Name

All of them, but most frustrating on my main, Rysaki.

 

Server

Junghado

 

Description

At first I thought it was an issue with the Celestial Basin area due to all of the people but, I found that's not the case when I go to a much quieter area (and/or different channels of said areas) such as House of Pleasures in Zaiwei or even Foshi Pyres on one of my lower level characters. I constantly get a sudden spike of at least 300ms ping, even up to 800 or more sometimes. If I manage to stay in the game, the ping goes back down as if nothing happened for a little while, until it happens again at random intervals. Occasionally, I won't even be lagging and I get booted off the game with, "You have been disconnected from the server" prompting me to reload the game only to repeat the vicious cycle. The disconnects don't happen as often as the lag spikes, but both are incredibly frustrating since the game takes three times as long to load now.

 

If it helps, my setup includes:

  • Windows 10 Pro
  • Intel i7-4790k quad core OC'd to 4.0GHz
  • 32GB of RAM
  • Nvidia GTX 760 4gb edition
  • Asus z97-A motherboard

I have a 12mb down and >1mb up internet connection with a previously stable connection to the game. The in-game ms display usually reads from 100-150ms though it feels like my actual ping would be 50-80ms. I'd also like to add that my internet connection outside of the game is perfectly fine.

Share this post


Link to post
Share on other sites
2501   

For those complaining about in-game lag, it's tied to Celestial Basin spawn times, and increased server load in general. 3 mins before Basin announce, even cross-server dungeons will lag hard as they are hosted on the same servers, and even freeze for 20-30 seconds at a time. It's around these times that you will experience the most frequent disconnects. However, that seems unrelated to XIGNCODE3.

 

Network errors in BnS also have a peculiar way of causing AMD/ATI video drivers to crash unexpectedly, probably as a result of the modified UE3, and lack of client-side extrapolation (prediction) which also leads to FPS drops during periods of higher network latency, as the client is waiting for something to draw.

 

Edited by 2501

Share this post


Link to post
Share on other sites

ISP
GLOBE

 

Antivirus/Firewall Software
None

 

VPN and External Software
None


Date & Time
All the time

 

Frequency
every single day

 

Character Name
All of my character (got 3)

 

Server
Yunwa

 

Description

Before that last major patch, my client never hangs, CPU's not reaching 100% (client taking up to 90%) and memory not exceeding 5GB of RAM.

I lost my BM gold rank (class rank < 30 before ) due to this hang time at around 5-20sec (3-5x per game). Every single day I have to deal this hang time on all BnS place (6-24 Man, WW and arena).

I've been playing BnS for 1 year and 2 months now and this, this is the very first time I had to post, not to rant, but to let you guys know (NC) that you made a mistake (yet again, but this time it hits me to the bone).

 

I worked so hard to get that gold rank though I have 300-400 ms (note: I never experience this hang time before even if I got that kind of latency) and losing it just that, oh my. It made me curse NC so bad that if only I can punch them straight to their head through my monitor, I will definitely do it.

 

This XIGNCODE3 thing will always be detected by anti-virus/rootkit analyzer due to its behavior and I got no problem with that coz I know it's clean. But this XIGNCODE3 will never be able work as this noob tool can only analyze simple memory manipulation techniques (do the research please). Please hire net sec/sec developer and you will know that this tool will only hoard resources w/o proving anything.

 

Hopefully this thing will end.

 

Respectfully Your's,

AngryBnSPlayer

Edited by angryBnSPlayer

Share this post


Link to post
Share on other sites
Dotimus   
On 6/2/2017 at 2:19 AM, Dotimus said:

PS cut in half on normal dungeon and drops to ONE FPS on raids  when using mouse software to bind mouse4 and mouse5

Do note, the game works without any problem on the first run after a reboot,

if you close the game and start it again the FPS drops

There is no problem after a reboot

nice to see the issue fixed with the latest xing, no more reboots required since we got the new xing BNS gfx at startup

DchTxd.jpg

Edited by Dotimus

Share this post


Link to post
Share on other sites

ISP
TPG

 

Antivirus/Firewall Software
window defender and kaspersky

 

VPN and External Software
None


Date & Time
All the time

 

Frequency
every single day I load BnS since Xigncode3 appear 

 

Character Name
sinlin 

Server
yehara 

plz help 

Share this post


Link to post
Share on other sites
Tyrmnn   

anyone started having  no BnS splash  screen and xigncode3 hangs out and never sits on systray 

after like 10 mins then if you click on xigncode its goes not responding?

 

i had no problems so far but today this started 

Share this post


Link to post
Share on other sites
YuuAsuki   

ISP
Screen flashing and black out upon the log into character

 

Antivirus/Firewall Software
360 antivirus

 

VPN and External Software
No


Date & Time
7:20PM EST

Frequency
After log into character.

 

Character Name
SunSangXiang

 

Server
Yu

 

Description

After the update today, as soon as I log into the character. The computer screen start flashing as it is attacked by virus, then eventually black out and frozen the computer. I tried to restart the computer and the computer wouldn't start normally and had black screen multiple time. I have to use F10 to reset the computer in order to open the window. I immediately use the antivirus to detect the issue with "xhunter file". Even now without opening the game, my computer screen would flash even now and then. This new "XingCode 3" software is destroying my computer, I have been playing nexon games for long time and I love playing those games. Now, I really consider quitting before it destroy my computer completely. 

 

Share this post


Link to post
Share on other sites

ISP
SkyBroadband

 

Antivirus/Firewall Software
Firewall only.

 

VPN and External Software
Pingzapper


Date & Time
11/29/2017 after the Maintenance of that day UTC+8:00
Frequency
Always

 

Character Name
CouLz

 

Server
Zulia

 

Description

Xigncode3 Error 0xE0191009
This always Showed up  I tried A lot Of fixes searched on Google Nothing seem to work. Tried Disabling Firewall and starting it again and it didn't work.
The Game Launches Fine Though the Xigncode3 is the Problem

Edited by GreyBound

Share this post


Link to post
Share on other sites
Pandaful   

ISP
Shaw

 

Antivirus/Firewall Software
Defender

 

VPN and External Software
None


Date & Time
Mountain Time MST, 10:23pm 12/17/17 and many more before then


Frequency
Every time I boot up the game

 

Character Name
Don't even reach that screen

 

Server
Yura

 

Description

When I try to star the game it gives me an error that reads

"F:\Program Files (x86)\NCSOFT\Bns\bin64\XignCode\xcorona_x64.xem is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc0000020."

FOLLOWED by one of my hard drives that the game doesn't even exist on UNMOUNTING

Then after about 15 seconds the whole PC freezes and I have to force shut down the computer. Please help. I tried running the game in compatibility mode with Windows 8 as well as reinstalling the game. It yields the same results.

Edited by Pandaful

Share this post


Link to post
Share on other sites
csisy   

Without giving you additional information:

Sometimes when I start B&S, the XIGNCODE3 starts to load and at 50-60% it freezes, eats my CPU and RAM and basically "kills" my computer. I have to brute-force restart it, can't even open process manager... This starts to be really annoying and you should not use this crap.

Share this post


Link to post
Share on other sites
shujin51   

I rather suggest u invest in a better hack detector since all these xigncode, gameguard crap only decrease the performance of ur games! Also the loading screen time is way too long and I am using an SSD. It shouldnt be the case that we as users have to find other ways to fix YOUR bugs. Thats what you have to solve as a developer and not us. Having me launch the damn launcher multiple times only because xigncode "detected" something on my pc is just stupid. Other games just start and launch quickly so we dont have to wait long. Haven't had one single korean game in the past that would launch without taking 2-3 minutes....And having an anti virus installed is normal and shouldnt be deactivated. 

Edited by shujin51

Share this post


Link to post
Share on other sites
Kagemi   

It seems XINGCODE3 does not work with the current Windows 10 version (1803). The launchig process stops before the XINGCODE3 logo shows up.

\NCSoft\BnS\bin64\XignCode\xcoronahost.xem causes an exception in ntdll.dll.

Edited by Kagemi
Addition

Share this post


Link to post
Share on other sites

I've been trying to get back into BnS after a long hiatus, but this XIGNCODE thing has been a hilarious mess. I am unable to run the game and receive the same error code over and over again - 0xE019100B, which in XIGNCODE's own explanation, relates to "detection of program usage irrelevant to the game". Irrelevant. As in, not related to. Why am I being stopped from enjoying your hard work if whatever's setting off the detection is not related to the game's operation?

 

I have submitted a support ticket, and the support agent replied that,

Quote

A few of the programs that are known to cause this issue are:

  • BNS Buddy
  • Speed Hax 
  • B&S Bypass 
  • Etc.

I have never run any such program, and am attempting to run the game from a fresh install. As the support team has not responded to my inquiry as to what exactly constitutes "etc", I figured I'd ask here.

 

I am on Spectrum internet, using Windows Defender antivirus, and the game client is shut down either immediately, or upon opening the pin entry screen.

 

It puzzles me that a company as reputable as NCSoft would use such a shoddily made piece of software to safeguard its services.

Share this post


Link to post
Share on other sites
Psylocke   

For reference I am running Windows 10 v 1803, just this morning updated to 17134.81.  With NVidia GeForce 1080 on a reasonably high-end but not "cutting edge" gaming desktop.  It was running the game just fine before the forced update to Win 10 v 1803 OSB 17134.1.  After 17134.1 update the launcher would run, log me in, and verify the files but then XINGCODE never started and the game never loaded.  But I seem to have found a solution on my own.  Most of it was posted here (or elsewhere in the forums) but no single solution worked so I had to combine them all.  Hopefully this helps someone who is having the same issue.

First, you must disable your Bluetooth on your computer.  Apparently it messes with a bunch of stuff that it really should not mess with, in the new version of Windows. For this, click on your "Network" icon in the bottom right of your taskbar, then "Network & Internet Settings" in that list.  In the next window, go to "Status" from the left menu, then "Change network adapter options" from the right side of the window.  The new window that pops up should show all of your computer's networking devices.  Click once on the "Bluetooth" icon to select it, then click the "Disable" button from the menu bar at the top of the window.  If it says "Enable this device" instead of "Disable..." then it is already disabled.  You probably also have two more devices, one for wi-fi and one for ethernet.  Only one of those should be enabled; whichever you use to connect to your modem/internet.  Personally I use a CAT-5 cable connection so I leave Ethernet on and disable Wifi.  Cable connections will get you faster speeds and lower lags than wifi, due to the way the wifi antennas work.

Then manually check for Windows Updates.  Make sure you install them all so you are at Windows version 1803, OS build 17134.81 or higher.  That is the second step.  If you don't know how to manually check for updates, just start typing "Windows Update" into your search bar or Cortana will help you find it... or visit YouTube.

Third step is to re-install (fresh download) the NCLauncher "only."  You do not need to re-download the whole game.  That can be done from the support page here: https://support.bladeandsoul.com/hc/en-us/articles/207195856-How-to-re-install-only-the-NCSOFT-Game-Launcher 
Then you need to right click the launcher exe files and on the "Compatibility" tab check the box for "Run as administrator."

Once that is done, try to start the game again.  It should go through the login, file verification, and then it will take a minute or two but the XINGCODE screen and the game's "splash" screen should pop up soon after.  I cannot speak to the framerate or overall quality of running 64-bit this way because I only just now got it working, but based just on the main menu screen it seems ok.

Share this post


Link to post
Share on other sites

What's the use of Xingcode anyway when you see there are hoards of bots running free all over the place, its the real players that have to pay the price for the use of a very well known buggy and shoddy program 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now