Jump to content
Forums

Can't get game to launch


Recommended Posts

Life is slower so have the time to play this again after months.  Went in to startup but can't get the game to launch.  All the latest patches are done, get to the Play Now button, click it, game verifies files, says Launching game, nothing happens, ever.

 

I have tried File repair, I have tried disabling virus scan on my pc, I have changed settings to try running in 32 bit client mode, have tried running in Windows 7 & 8 compatibility.  Can't get the game to start.

 

Would really like to play again, if I could get the game to work..   Running latest version of Windows 10 Pro, updated Nvidia drivers, etc.  Not sure what else to try but would like to renew and play the game again.

 

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...