Jump to content

Massive c++ issue.


Recommended Posts

Well.. ill try to be short, im playing blade and soul(duuuh), everything was running out perfectly, until the recent update called skypetal that introduced the 24 main raid. After the patch was done, i got the c++ runtime library error, ' the application has requested the runtime to terminate it in an unusual way, please contact etc'

Things i have tried until now ( i may not have done them perfectly probably, im open to any suggestions and ill do them detailed with feedback here, kind of desperate) 

-Deleting everything containing C++ from control panel then reinstalling all from microsoft official page. 
-Enabling the 3gbmem_vista_win7_32bit program from inside the folder.
-Using a registry cleaner to delete the bad entry files.
-Clean booting to find a faulty program that may or not may block c++ library communication with bns
-Sending a ticket to the support ( due to them responding within 1 day and probably responding with the stuff i already did from the internet, wont work, and wait more for an actual fix, i came here for oppinions, already got a response to reinstall c++ files without results from them, ticket continues)
-Tried using system restore, but the last restore point was from a date when the game still didnt work due to the current issue, so pointless.
-Running the game on admin mode, and or rebooting after every change.

Again the game ran perfectly before the patch and id wish to fix it before 1 week or so until the game support gives me a viable solution, any ideas what should i do, the problem be or i should retry on doing?

My operating system is windows 10, i deem further specs as unnecesary but if needed i will provide a dxdiag. Please help this poor soul


(Update, since them i got some reponses from support AND tried the following also 

  1. Click the ""Start"" button to bring up the Start Menu.
  2. Type in CMD into the ""Search programs and files"" field but do not hit enter. Doing this will change your start menu to show the program ""cmd.exe.""
  3. Right-click on ""cmd.exe"" and select ""Run as Administrator.""
  4. Type ""netsh winsock show catalog >C:\LSP.txt"" without the quotes. This will save a file to the root of your C drive called LSP.txt. Please attach that file to this ticket. (We would like this report even if the issue is resolved)
  5. Once complete, type ""netsh winsock reset"" without the quotes. When the command is completed successfully, a confirmation appears, followed by a new
  6. command prompt line.

  7. As a way to try and resolve this I'd like for you to run the Windows System File Checker using the steps below.
  8. Click on the Start menu, choose All Programs, then Accessories, then right-click on the Command Prompt item and select Run as administrator

  9. Click Continue to authorize opening a command prompt with administrative privileges

  10. Run this command in the cmd prompt: sfc /scannow

  11. The cmd prompt should list text stating ""Beginning system scan. This process will take some time.""

  12. Wait for the scan to complete (this can take several minutes so be patient). This command will scan all protected system files and replace incorrect versions with correct Microsoft versions

  13. When the scan completes, the SFC tool will indicate whether or not it found any problems and whether or not it was able to fix them.

Already did a hijack scan and lsp one, those were right from the support tickets.. nothing. NOTHING worked.. i am really really desperate at this point hence i recently payed for some cosmetics and really enjoy the game.. please help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...