Jump to content

Launcher/Download Broke


KelhamMemestar

Recommended Posts

I spent a consistent 8hrs trying to fully download the game, every time on the second download at 99% I ran into the same error-E02018. I went searching for an answer hour after hour but everything I tried (changing DNS server, uninstalling and reinstalling, etc.) couldn't fix this. I then tried to install it on another computer but ran into exactly the same error over and over. I decided to press play (you can play the game without the second installment) and I really enjoyed the game, I have a lvl 22 assassin and have just tried to start the second section of the story, but I need to fully download the second part but it stops at 99%, if anybody knows the answer to this or if the developers need to find a fix then please let me know. I just need the developers to know about this issue so they can fix it with a future (and better/working) patch or for someone to inform me about a fix which actually does work.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...