Jump to content
Forums

Complete Lag


Recommended Posts

I just updated my client for the new patch (I've been waiting all day to play since I got off work late) and after I update it, it's nothing but lag. The title screen was lagging, it took about 3 minutes just for me to put in my pin and then it took like 8 minutes just for my character to load in. Not to mention the lag during actual gameplay. I barely got past the loading screen. Is anyone else having this lag problem ? I've never had a lag/processing problem before this update. This is a brand new laptop. I'm extremely frustrated and even more disappointed because I've waited literally all day to play. If someone could help me, I'd appreciate it.

Link to post
Share on other sites

Since you're on a laptop it could be worth checking if the game is running on integrated graphics or not. Sometimes it's set to that as the default, if you're using nvidia you need to go into the nvidia control panel > manage 3D settings > program settings > navigate to the blade and soul profile/add client.exe to the list and then select the nvidia GPU as your preferred graphics processor.

 

If you're on AMD...I've no idea how to do that, but if you don't know how a quick google sweep will probably solve that!

 

Hopefully this works for you ^^

Link to post
Share on other sites
22 minutes ago, Arianna said:

I'm not using any type of special program to run the game. I've never had to. Honestly, I haven't had any problems with the game until this recent update.

This might sound weird but....try connecting your laptop to the power adapter, do a restart and try again.

Link to post
Share on other sites
16 minutes ago, Arianna said:

It didn't work.... Now after I sign into NCS, BnS doesn't even pop up.

Seems more like laptop issue than a game issue. Could be a few things. I would suggest a file repair or maybe reinstall....

Check if maybe your hard disk isnt full....or if the drivers are all up to date

Link to post
Share on other sites
4 hours ago, Arianna said:

I'm not using any type of special program to run the game. I've never had to. Honestly, I haven't had any problems with the game until this recent update.

It's not a "special program", I'm just suggesting that you check the control panel for your graphics card? For telling your laptop to run the game using your high-powered GPU instead of defaulting to integrated graphics. Otherwise you end up with low FPS and an unplayable game, like you described.

 

What graphics card are you using?

Edited by Falanyr
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...