Jump to content

Updates are stalling

Recommended Posts

Hi all,


After a month and a half of not being home, I've started up Blade and Soul again. A month and a half ago, Blade and Soul ran perfectly fine with no problems (note that I downloaded the game outside my home on a school campus. This might be important?) and I could play. 


Recently, I factory reset my computer and was in the process of re-downloading and patching the game. To my confusion, I couldn't download the installer despite my internet working for every other site. What I did was have someone else download the installer, upload it, and I downloaded that to install. Now, comes the patch. The patch works for a couple minutes and then stalls to the point where the download speed is effectively 0. This is for my entire house's internet, as I tried to download the installer on a different computer and came to the same result.


I pinged the servers and got a timeout, so I'm not really sure how to approach this issue. Any help would be appreciated!


Thank you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...