Jump to content
Forums

Low FPS/Stutter Fix (Nvidia)


Archess

Recommended Posts

Hey, so ive been having really low FPS and drops when a boss does his huge attack i drop to 0 FPS for a couple of seconds or my iframe becomes imposible to use due to the stuttering that starts seconds before, ive had this issue since the game launched and i have a i7 cpu, 16GB ram and 680 GTX witch should run this game fine.

 

Ive tried a bunch of fixes from other people but none hit the spot, the issue is because this game uses only 40% of my GPU and when the stutter does a driveby shooting, it drops down to 15-25% and i am unable todo jack-shit all, with these changes your usage of the card should be 80-99% all the time and all the stutters goe away like a snowball in hell.

 

I had one friend with a 780 GTX test this and before he had to run the game in Optimize For Combat with all the bells and whistles off, witch makes the game not really nice to look at and i went from 60-70 frames to 100+ most of the time and am able to run it with all the details on high, without stutter, but especially the stutters are gone that gets you killed in dungeons/plains.

 

Steps to Follow

1) Download MSI Afterburner from guru3d or some other place and install it

2) Download Riva Tuner from the same place and install it

3) go into your 3D settings for Nvidia

4) set Multi-Display/Mixed-GPU to Single Display Performance mode

5) Set Power Management mode to Prefer maximum performance <- this works better for some cards, while it does nothing on its own for others, hence the Riva Tuner nudge

6) Run BnS and Set limit background FPS and FPS limit to 120 on both sliders

7) Set all the graphics options to enabled, sliders to 5 etc, just max it all out

8) Run Riva Tuner, go to Power User > Riva Tuner \ NVIDIA \ Overclocking, find "EnablePerfLevelForcing" and set it to 1

 

You might need to restart your comp, but your GPU should now be used for 80-99% at all the time while playing BnS and should increase FPS but fix your stutters, twiddle with your own ingame settings until you find the best match for your GPU for steady FPS when there a bunch of people onscreen.

 

Make sure Riva Tuner is active before launching BnS, i hope this works for some people as well as it did for me.

 

Good Luck!

Link to post
Share on other sites
  • Replies 84
  • Created
  • Last Reply
2 minutes ago, Tracmar said:

msi after burner is for checking and adjusting ur gpu if required . also it is a handy tool to see the clock speeds and temp 

 

Its just what he said, to check if your GPU is now taxed to around 99%, if it is not you skipped a step maybe ?

 

What card do you have ?

Link to post
Share on other sites

Boy am I glad that I made sure that my computer doesn't need extra programs or dirty driver hack type stuff just to run stably ^_^

 

Nonetheless. My favorite is DXtory, since I can lock my games at whatever FPS I want, cutting the overhead almost entirely and make my computers run warm instead of loud. I've also a nice addon that adds motionblur to almost every game that i've tried, so I tend to just lock my games at 24FPS. Except deus ex 3 which I looooooove, so I lock it at 120-constant :)

 

It'd be great if the gpu drivers were simply made better so people wouldn't have to inject stuff into them(rivatuner relies on the ORIGINAL drivers) but heey, keep the faith !

 

---

BTW, since I'm not a BnS forum regular here's a quick note: I make lots of edits because I don't like having a high postcount for something I could compile into a single post

Link to post
Share on other sites

Rivertuner has a stealth setting that allows your video and OC programs to hook into games. Ever wonder why you change stuff on your computer using crimson or other programs and it has no effect on the game? You need to enable stealth settings... OP has a solid tip, for those that choose to use it. 

Link to post
Share on other sites
2 minutes ago, KSett said:

Boy am I glad that I made sure that my computer doesn't need extra programs or dirty driver hack type stuff just to run stably ^_^

My computer runs fine with each and every other game out there, its just with BnS that my GPU is sleeping on the job, when it gets pulled from 99% down to 60-65% due to i dunno issue, it doesnt cause any problems, but when you get pulled down from 40% to 15-25% and sometimes even 0% it freezes the game/stutters.

 

To call it a dirty hack is a bit harsh, it just a tweak that does what Nvidia in performance mode should do, but for some reason does not.

 

 

 

Link to post
Share on other sites
5 minutes ago, Tracmar said:

Well even with the settings mentioned above , gpu usage is around 50% , did not miss any step 

 

Maybe need to restart again ? 

 

What GPU do you have? as my fix seem to work for 680 & 780 GTX GPU's.

 

Also did you enable enough stuff in BnS to cause enough load?

In my GPU ussage, if i disable enough things in BnS advanced graphics settings, my GPU % goes down.

 

But idd give it a try with a restart.

Link to post
Share on other sites
2 minutes ago, Archess said:

What GPU do you have? as my fix seem to work for 680 & 780 GTX GPU's.

 

Also did you enable enough stuff in BnS to cause enough load?

In my GPU ussage, if i disable enough things in BnS advanced graphics settings, my GPU % goes down.

 

But idd give it a try with a restart.

Well am on a GT 840m , not the best of GPUs but from what I have seen more than enough to run this game  

 

and yea enabled enough settings,  just kept AA off .. will try with it on . But so far, huge improvement in stutter when the gpu manages to get over 80

 

Link to post
Share on other sites

My fps drop is not video driver related because at a fresh reboot my fps goes around 45 fps average in town and 85 average in dungeon. Then afterwhile specially when i alt tab my fps drops to 8 fps average. But if i run other games my fps is just fine. I tried restarting the game and I still get same FPS, but when i do warm reboot on my computer I get back to 45-85 fps average again. I am suspecting gameguard because I haven't got this problem before, I only noticed this after the latest patch. I will try to monitor the gameguard process next time and give you guys an update.

Link to post
Share on other sites

for me it was also the GPU usage, even now in Mushin Tower its taxed at 81% with no npc's rendered, except mushin itself, most other locations 99% and only in dungeons it dips down near corners, but not anything harsh like before.

Link to post
Share on other sites
1 minute ago, Archess said:

for me it was also the GPU usage, even now in Mushin Tower its taxed at 81% with no npc's rendered, except mushin itself, most other locations 99% and only in dungeons it dips down near corners, but not anything harsh like before.

Anything additional that you have tried ? it is dipping to below 20 a lot for me :(

Link to post
Share on other sites
7 minutes ago, Tracmar said:

Anything additional that you have tried ? it is dipping to below 20 a lot for me :(

Most of the other fixes i could get my hands on have been applied to my pc, the Latency fix (Leatrix_latency_fix) the Gameguard fix, but they all didnt do a thing until i did this.

 

Maybe its a combination of, but then it shouldnt work on my friends 780 GTX because he has never applied any of the other fixes to his system.

 

edit: you are making sure Riva Tuner is active in your tray right ?

Link to post
Share on other sites
4 hours ago, Archess said:

8) Run Riva Tuner, go to Power User > Riva Tuner \ NVIDIA \ Overclocking, find "EnablePerfLevelForcing" and set it to 1

Thanks for this solution, i'm trying to apply it hense none of the other tricks I found worked for me. But, I must be stupid or blind coz' I can't even find the "Power User" menu you mentionned ! :o Would you mind screenshoting it ?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...