Sign in to follow this  
ARC-1276

This game is broken!

Recommended Posts

ARC-1276   

I had 0 problems with bots, even if they're mostly gone now. I have some problems with imbalance. BUT! There is nothing more vile, more game killing, than lag! 

 

THIS *cricket* piece of *cricket* has been the ONLY and THE ONLY reason I haven't yet gotten my diamond in 1v1! The ONLY REASON! I know I'm good, I know I'm great BUT WHEN I HAVE TO WAIT 10 SECONDS IN THE MIDDLE OF A MATCH FOR 1 *jinsoyun* SKILL! it's an indicator that something IS HORRIBLY WRONG! The servers for NA I heard are located in Texas, I'm in California. There is no way that I should be having this problem! I literally have set my options to "Optimize for Combat" which I assume just stops me from instantly DCing in the arena given the BS I keep seeing. My computer is diffidently not the problem and neither is my internet. How do I know this? Because I wasn't getting this much God *cricket* lag to begin with! 

 

This here will be the reason I quit this game and I just know it. Heck I know I'm not the only one who gets this problem from time to time. I know there are others out there who have to deal with this BS as well.

 

So NCsoft: Stop worrying about everything else and get your freaking servers to work! I bought a founders pack and so many freaking outfits with hopes of not only having my character look good, but also that you will use it WISELY. 

 

Ignore the "bots" and the "imbalance" and focus on making the game playable. Thank you.

Share this post


Link to post
Share on other sites
Syanonn   

Well... NCSoft may be able to fix bots/imbalance (doubt it)

But I seriously don't think they can fix your routing to their server

Share this post


Link to post
Share on other sites
khynnea   

It's probably not the internet? Granted, it has its moments.. but they turned gameguard back on yesterday after it being off for a while. So a lot of us have gone from having virtually no server side skill lag, no spontaneous disconnects throughout the day, and much less rage while playing... to an awful lot of all three.

 

 

 

Edited by khynnea

Share this post


Link to post
Share on other sites
ARC-1276   
5 minutes ago, khynnea said:

It's probably not the internet? Granted, it has its moments.. but they turned gameguard back on yesterday after it being off for a while. So a lot of us have gone from having virtually no server side skill lag, no spontaneous disconnects throughout the day, and much less rage while playing... to an awful lot of all three.

 

 

 

Exactly. Like I said, I didn't have this issue in the Arena from before, but now I do. It cannot be my internet if the game was running without a flinch from before. Now, even if I shut off all the applications running on my computer, I can't duel for *cricket*! 

 

Point of the matter is that I know I'm not the only one with this issue and I'm sure there are others with even worse stories than my own.

Share this post


Link to post
Share on other sites
forJAT   

Well I would be able to do my crafting resets if I had the lag issues but NOOOOOOOOOOOOOOOO  Game guard throws this error at me ..  And there has not been ONE dev response to the GG issues today  ... sad /smh                                    OjkYyad.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this