Sign in to follow this  
GenesisAria

Game Performance & Combat Optimization mode

Recommended Posts

This is something that's been bothering me forever... 
Most people's computers run pretty bad in this game when there's lots of mobs or players on screen, that's an inherent fault of UE3. SO what happens is, most people end up ticking the box for "Combat Optimization".

But when you do this a lot of options are greyed out. The combat optimization mode reduces things like model and animation detail which is essential, but it disables terrain effects so we can't see DragonChar or DragonFrost for example... It also disables the option for FXAA - which makes no sense, FXAA uses virtually nothing to run, that's why it's so popular.  It also greys out cross filter, shadows, and ambient occlusion.

 

I say these need to NOT grey out when the opt mode is ticked, cuz it makes my game run smooth as ever, but even if i turn my graphics to minimum, it still runs worse than optimization mode with everything else max.  This means optimization mode changes a bunch of stuff that you can't change otherwise, again the model detail and the animation quality of character and monster models.  All of the ini files are unavailable, so there's no way to manually fix these things to get a game that both looks nice and runs well.

Share this post


Link to post
Share on other sites
Morcra   

yeah. i recently bought this computer. its made to play games of this era at a good pace. but i run this game like shit. it just fluctuates nonstop .

Share this post


Link to post
Share on other sites

UE3 doesn't do that.

I'm not even talking about unreal performing bad, that's unavoidable usually (without really intense optimization).  The game can be made, with existing settings, to both look decent AND run nicely, if only the options were available to change.  Tick the Combat Optimization box and all the stuff you actually want on is greyed out, even though they don't affect how well the game runs noticeably.  FXAA uses nothing, cross filter uses nothing, terrain effects uses nothing.  Shadows and ambient occlusion are quite heavy, but they more consistent and manageable than the model detail and such that causes massive lag when there's a ton of mobs.  In Tera Online, i was able to get really nice but cheap shadows through messing with the ini files: i had clean shadows that only cast on the ground and NOT on other characters (that causes a lot of performance drain)...

 

Regardless, the ability to fix it is not available.  It needs to be made available.  There is no reason for the Check box to grey out other options.

Share this post


Link to post
Share on other sites
Final   

So true..OP

I did find away around this my self not sure if people know this or not. 

You can have nice looking graphics and still use combat optimisation, however you do need a GeForce card for this to work.

 

First put the game in optimisation mode then exit 

 

Second open up GeForce Experience click on Blade & Soul then click optimisation ( basically what happens GeForce experience edits the ini file)

 

Once this has been done you will have nice looking graphics while been in optimise mode. For example you will have shadows enable ,FXAA ,cross filter and ambient occlusion. 

 

The sliders will still be grey out but all of them will be on 5 depending on your graphics card.  Some stuff are still the same as you would expect for beening optimisation mode , like the fidelity of the characters and the skill effects.

 

 

side note : if you got a powerful graphics card try playing the game between 2k and 4K using DSR this gave me a little fps boost as my graphics card was been utilised more.  I had the same problem in another game that had bad optimisation called naruto storm 3 if I play this game in 1080p I would get fps drops and some stuttering but when I crank it up to 3k solid fps not one fps drop lol. 

 

Specs 

i7 4790k 4.4GHZ

16GB DDR3 2000MHZ

Geforce 980 @1340MHZ

HDD 1TB

Edited by Final

Share this post


Link to post
Share on other sites

Doesn't help for people with ATi cards.  A recent update of gameguard or perhaps the game itself made it so that RadeonPro, and even FXAA Injector no longer work.

Share this post


Link to post
Share on other sites
Purestic   

You can change the config if you want. Go into the game, tick Optimization Mode, go to Documents->BnS->NCWEST->ClientConfiguration.xml (open with Notepad) and search for the settings you want to increase. Save, start game, now you have Optimization Mode with a few increased settings.

Edited by Purestic

Share this post


Link to post
Share on other sites
8 hours ago, Purestic said:

You can change the config if you want. Go into the game, tick Optimization Mode, go to Documents->BnS->NCWEST->ClientConfiguration.xml (open with Notepad) and search for the settings you want to increase. Save, start game, now you have Optimization Mode with a few increased settings. Worked for me.

This didn't work.  I changed a bunch of stuff and made it read only, it seems to have completely ignored the settings.  I just discovered that Combat Optimization Mode also breaks the normal bloom.

Edited by GenesisAria

Share this post


Link to post
Share on other sites
Purestic   
On 24.3.2016 at 3:09 AM, GenesisAria said:

This didn't work.  I changed a bunch of stuff and made it read only, it seems to have completely ignored the settings.

You have to activate Optimization Mode first. It works for some once they edited the .xml config afterwards. Or it depends on the settings you change.

Edited by Purestic

Share this post


Link to post
Share on other sites
Pulmi   

Same problem for me. I run all other games pretty well on my pc and on high settings, wow, guild wars 2, swtor etc. but BNS is unplayable when a lot of players are on screen, even with ctrl + f I drop to single digits fps. I tried various methods but nothing works, not even the "optimize for low-end pcs" which makes the game look like something you play on your 3DS. The first day they fix this issue I'm going to purchase a freaking 1yr membership. I really like this game but my experience is ruined by the fps issue.

Share this post


Link to post
Share on other sites
Purestic   
3 minutes ago, Pulmi said:

Same problem for me. I run all other games pretty well on my pc and on high settings, wow, guild wars 2, swtor etc. but BNS is unplayable when a lot of players are on screen, even with ctrl + f I drop to single digits fps. I tried various methods but nothing works, not even the "optimize for low-end pcs" which makes the game look like something you play on your 3DS. The first day they fix this issue I'm going to purchase a freaking 1yr membership. I really like this game but my experience is ruined by the fps issue.

https://www.reddit.com/r/bladeandsoul/comments/42y25u/blade_and_soul_optimization_guide_needs/

If you use Nvidia.

Share this post


Link to post
Share on other sites
1 hour ago, Pulmi said:

Sry, I forgot to mention I'm using an ATI card.

Same here.

 

Note: the topic wasn't about the game's bad performance, it's something we can't get around with this Gen7 engine.  It's about the inability to turn up OTHER settings when combat optimization mode is on.

2 hours ago, Purestic said:

You have to activate Optimization Mode first. It worked for me once I edited the .xml config afterwards. Or it depends on the settings you change.

I play with Combat Optimization Mode + Low-End Optimization Mode with increased textures, increased distance + FXAA. (Low-end removes all the shadows and stuff and makes the game more bright) Well I'm not a 100% sure if the FXAA works, couldn't really see a difference even without the Optimization-Modes.

That's what i did, it doesn't work. The game ignored all my settings in the xml.

Edited by GenesisAria

Share this post


Link to post
Share on other sites
spfan87   

There's nothing you can do.

 

You want to have good FPS, don't play a game running on UE3.

Share this post


Link to post
Share on other sites

I really don't get it, how can melee players even play much less enjoy this two major events when almost everyone either gets almost 5fps or crashes on said events?
I was playing my FM a ranged class and i could barely do anything on the exterminator since my game almost froze for the whole fight, and i was there asking myself wtf i would do if i was playing a melee class.
I see koreans playing the game vs field bosses with the same amount or more ppl all attacking no problems but we on the west somehow have to deal with abysmal or straight impossible performance, because?

Bots?Spammers?Cheaters? We should care about them, but when almost no one can even do the content of the game on playable FPS on an ACTION RPG that needs iframes constantly then the *cricket* are we suppose to do.
At least BW stayed on the 15-20 fps, square and SS plains is pretty much unplayable for most players and when ppl can't do the content they get frustrated and leave...i had a dude on my guild that played the game regularly, he took a brake for division, came back started the game had almost 20 fps for no reason and insta quit the game, not everyone has the patient or love for this game to play below 60fps much less 30-5fps ncsoft, stop giving us content after content and selling t-shirts and just try to fix the game performance before the few that actually like the game to the point of playing with constant random DC's and abysmal performance get fed up themselves and you end up with your 1,5M bots.

Edited by AkabaneKun

Share this post


Link to post
Share on other sites
Septy   

Check "optimized for potatos" (800x600)

Press alt+enter (At the same time)

Ctrl F

Enjoy your playable fps

It`s what I did and I`m melee and also have a potato.

 

If you still have bad fps even after this, your PC wants to retire

 

Share this post


Link to post
Share on other sites
Bumlife   

What are your specs?

Here is my poor rig:
i3 3.2 GHZ 4.5 years ago.
8GB RAM
AMD 6570 1gb

Graphics Settings:
Optimized for Combat
Texture 5
Everything that has "Visibility" option is 5 (Reason: So PC will load chunks in advanced not when you just hit the area avoiding stutters)
Everything else is at 1 or diasbled
Resoulution 1366x768 wide-windowed mode then I just drag corner to enlarge screen or sometimes alt+enter.

In clashes: 20 to 30 FPS (not so smooth but playable)
In normal activities: 50 to 60 FPS

Share this post


Link to post
Share on other sites
Pulmi   

I'm afraid it's the sad truth, the game has been out for years so if they were going to fix these issues, they would have done it ages ago. Also, I believe there's no point bitching about it to ncsoft west since, I believe, the changes have to be made by the korean developer first and then given to us in the west. It's a shame cause it's such a nice game.

 

What about the korean client, since they are way ahead of us, have these issues been addressed?

Share this post


Link to post
Share on other sites

if the KR version is not optimized, the chances that NA/EU's version will be optimized is close to 0 percent.

Share this post


Link to post
Share on other sites

Optimization mode started really screwing stuff up last couple days at times.  Now objects in dungeons don't show up until i'm like right beside them, and down a hallway or tunnel the terrain stops and i can see skybox, it doesn't load until i get closer.  It's is absolutely unacceptable.  Ayy things i messed with were days before this started happening, so it wasn't like my fiddling caused it.  Optimization mode is ignoring all the sliders and has even broken bloom.

All i want is lower model/animation detail, not all this other crap.

 

Edit: I tried deleting ClientConfiguration.xml to get a default one, but it didn't fix anything. Bloom still broken, things still not rendering until close.

Edited by GenesisAria

Share this post


Link to post
Share on other sites
Mucski   

Aside in-game settings if you are nvidia the most you can do is enable Threaded Optimizaiton and change Maximum Pre-Rendered Frames to 3 and above

Share this post


Link to post
Share on other sites

I know it's not as cool as micro-managing everything, but your Graphics Driver should include a tool for optimizing for games you play. NVidia does at least, and the optimizer works well with B&S, and I never had an issue. 

 

rGbgm4J.png

 

Now to be clear, as I posted in a previous thread, I do not use a new system, nor do I have great internet. 

eyr4Td9.png

 

Here I'll log in an post a current in game screen...

 

qm5ZMQa.png

 

37KoI6b.png

 

 

Edited by gothicshark
Added Crickets to the PNGs, my Computer name needs Crickets

Share this post


Link to post
Share on other sites

That internet is better than mine lol.
Anyways, i'll look into fiddling with pre-rendering frames, seeing as the lag has increased recently.

 

Still haven't a clue why all the view distances and such are borked.

Edited by GenesisAria

Share this post


Link to post
Share on other sites
On 3/31/2016 at 10:42 AM, GenesisAria said:

That internet is better than mine lol.
Anyways, i'll look into fiddling with pre-rendering frames, seeing as the lag has increased recently.

 

Still haven't a clue why all the view distances and such are borked.

I had the same problem until I changed both character-view-distance and character-view-count to 4

 

Then I had max view range

Share this post


Link to post
Share on other sites
Vyky   

You are takling about the graphics engine when you are talking about huge performance drop on open world areas with many people arund. Yes it may casue the grapchics engine too on the one side. But the other side it causes the server performance, the network interfaces, the bad newtork optimization to handle the open worl areas. I am talking about combat log during these events. Totally useless to run the combat log in the background on 30, 40, 50, 100 players. Nobody cares about it during on these events. A tons of other data besides the combat log is crossing through the server which casues more of these performance drops, than you set the graphics or do not. The grapchics engine optimization is just the one side of the coin it could solve a couple of things, but the huge lags, and drops do not. What I mentioned is the setting that I can switch other players particle effects completely off and even on my character! I want to see only the dangerous effects and areas on the ground. In a mass battle this is the only thing that you want to see. Unfortunately we cannot switch off all the effects in the advanced options.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this