Jump to content

Invisible game window and no launcher after reinstall

Dru Lockheart

Recommended Posts

I was playing blade and soul, clicked on my weapon with mouse and suddenly the game window vanished and I could not access it anymore, it was listing at Alt+Tab as blank. Restarting client did not help, so I reinstalled the game - first with simple uninstall which fixed nothing. Then made another uninstallation and deleted NCsoft and NCwest folders to make sure the new installation will be clean. However, after this installation the game was unable to find its launcher as, apparently, it is not included in the installator.

Link to comment
Share on other sites

Same issue. Tried to install to my laptop while waiting for cable installation at new place. BnS lite installer seems to finish and everything appears to download ok. Except no NC soft folder in the directory I had specified. And no desktop icon even though I checked the box for desktop icon. No Launcher.

When I click on BnS lite installer a second time it removes the installer and files.

I have tried uninstalling and reinstalling. No solution.

Link to comment
Share on other sites

11 minutes ago, Dru Lockheart said:

The only temp solution for missing launcher I found was downloading launcher separately... However, reinstallation and repatching helped nothing, after the dragon splash the client creates invisible window so I cannot enter the game anymore.

where do you download the launcher from? I can only find the BnS_lite_Installer program.

Link to comment
Share on other sites

Support helped me find a solution. The cause of your problem may be different but since our problems were so similar I hope the following does the trick for you.


Let's start by preventing programs from automatically starting with Windows, then repairing some Winsock entries. To do this:

  1. Press and hold the Windows key and then hit the R key. This should bring up the Run dialog box.
  2. Type ""MSCONFIG"" without the quotes, and click ""OK."" This should open the System Configuration Utility.
  3. Click on the ""Services"" tab and check the ""Hide All Microsoft Services"" check box near the bottom, then click the ""Disable All"" button. (You MUST click ""Hide all Microsoft Services"")
  4. Next go to the ""Startup"" tab and click the ""Disable All"" button.
  5. Once these items are all disabled, click the ""OK"" button and you will get a prompt to restart your computer. Please restart your computer.

Once you return to Windows, use the following instructions to clean up Winsock entries:

  1. Click the ""Start"" button to bring up the Start Menu.
  2. Type in CMD into the ""Search programs and files"" field but do not hit enter. Doing this will change your start menu to show the program ""cmd.exe.""
  3. Right-click on ""cmd.exe"" and select ""Run as Administrator.""
  4. Type ""netsh winsock show catalog >C:\LSP.txt"" without the quotes. This will save a file to the root of your C drive called LSP.txt. Please attach that file to this ticket. (We would like this report even if the issue is resolved)
  5. Once complete, type ""netsh winsock reset"" without the quotes. When the command is completed successfully, a confirmation appears, followed by a new command prompt line.

Once completed, please try running Blade and Soul again by ""right-clicking"" on ""Blade and Soul.exe"" and selecting ""Run as Administrator.""

(For me, completing the last step instead of the blade.exe it was the BnS_lite_installer which completed successfully.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...