Sign in to follow this  
Serati

Huge lag spikes on EU

Recommended Posts

Serati   

Since the last update my ping got considerably worse. I live in Germany and usually have a ping of 50-80.

Today it's reached a new high with spikes of over 200ms every few seconds and sometimes it seems like complete packet loss for several seconds (I can move but not attack and NPCs won't react).

 

This is completely unplayable. I will make a new char on the NA server and see if I get a better ping there and it will be a really bad joke if I do :(

Share this post


Link to post
Share on other sites
Saoyara   

If you are having lag issues submit a ticket to NCSoft with some speedtest and tracing towards their server to get some feedback. And aside of that if they cannot fix it, try to use WTFast or other ping boosters until it gets fixed, is the best choice atm.

Share this post


Link to post
Share on other sites
Serati   

I'm not convinced a ping booster is going to help me if their crappy servers are the problem :/

It probably would help me get a better ping on NA but that's really not the point.

 

PS: It also looks like the game server doesn't respond to ping requests so a trace route doesn't get me much besides showing me that my connection is fine until the pings stop.

Edited by Serati

Share this post


Link to post
Share on other sites
Saoyara   
Just now, Serati said:

I'm not convinced a ping booster is going to help me if their crappy servers are the problem :/

It probably would help me get a better ping on NA but that's really not the point.

Well dunno man that's your choice, I had some latency small issues with packet lost, but I used WTFast for solve them until this last patch  that fixed all the issues for me, and now im running the game perfectly fine. If you are willing to give it a shot, feel free trust me you wont regret, if not gl on NA servers.

Share this post


Link to post
Share on other sites
KaLnoX   
46 minutes ago, Serati said:

Since the last update my ping got considerably worse. I live in Germany and usually have a ping of 50-80.

Today it's reached a new high with spikes of over 200ms every few seconds and sometimes it seems like complete packet loss for several seconds (I can move but not attack and NPCs won't react).

 

This is completely unplayable. I will make a new char on the NA server and see if I get a better ping there and it will be a really bad joke if I do :(

I moved to NA, i still log on my EU to pvp and gather soulstones via beans but thats about it, not gonna waste time gearing and all that shit. EU servers? There are none lol.

Share this post


Link to post
Share on other sites
Serbine   

You'll not alone it pretty bad for some players, was doing my FQ in Misty Wood trying to defeat Waido and kept spiking around the whole place, I manage to beat him but man was annoying.

Share this post


Link to post
Share on other sites
VRock   

i have this problem also. from 80 ms ping, jumps to 160 ms and then backs to 80ms then 160~180ms....cycle repeats  

Edited by VRock

Share this post


Link to post
Share on other sites

yep EU servers are fked up

 

or maybe they are (camuflated) Austin US ?!?!? dafuq why are we conected to Texas if we'r from Europe....

 

lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this