Jump to content
Forums

Game not starting after Login


MatMat

Recommended Posts

Hi guys can someone help me up ? I've been having this problem for ages. I really would want to play the game.

Alright so here's what going on. Everytime I tried to launch the game using the blade and soul icon (the red one) there would be a Login page (we all know of that)

once I try to log in the page will be gone and then nothing will happen. A friend of mine told me to try downloading the NCLauncher thingy which I did I tried to download and install it on my computer. After there have been some changes after install the launcher there would be a NCSOFT launcher thingy that would appear and then the log in page, after I sign in, there would be an update and then I would be able to play. But once I close the game it would turn  back to the first state wherein after the log in nothing will happen. then if i try to install the NCLauncher sometimes it will work sometimes it won't. Please I really need some help I'm waiting for some moderators to answer this question but it seems my first post was deleted or thrown somewhere else. thanks for those that can help me, btw im using Win 7. I was able to play I'm Lv18Warlock and I can't play anymore cause of this problem. I tried to restart do everything but its not working. help me waah! :(

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...