Azryn

FPS Drop & Freezing Issues

Recommended Posts

Shmyules   
5 hours ago, Kawasaki said:

does the new patch have any improvements?

Feels worse to me. Getting 20-30FPS open world with optimize for combat on (about 50FPS if I'm not moving - drops to 10 or lower during combat occasionally). I used to play at nearly max settings.

Share this post


Link to post
Share on other sites
Azryn   

So far so good actually. I haven't noticed any major freezes so far and I ventured into the arena to test it.

I'll update again later, they may have actually implemented a fix.

Share this post


Link to post
Share on other sites
Azryn   

Bump.

If anyone else is experiencing this issue,

does it seem better after the most recent maintenance?

Share this post


Link to post
Share on other sites
Kawasaki   
6 hours ago, Azryn said:

Bump.

If anyone else is experiencing this issue,

does it seem better after the most recent maintenance?

i still get freezes when i attack more than 2 monsters but it doesn't seem to be as bad. It's still horrible and i wont play until they fix what ever they did to the game on rising water patch to make this start to happen but i guess they are trying to fix it.

Edited by Kawasaki

Share this post


Link to post
Share on other sites
Savasha   
8 hours ago, Azryn said:

Bump.

If anyone else is experiencing this issue,

does it seem better after the most recent maintenance?

 

For me it's actually worse after the patch today.  

Share this post


Link to post
Share on other sites
Lysinc   

My specs:

CPU: I7 4770k

Video Card: GTX 970 Gigabyte G1 gaming V1.1

RAM: G. Skill Trident-X 16GB 2133MHz

HD: WD Blue 1TB and Samsung Evo 250GB(SSD)

 

My FPS still drops when I'm in a dungeon. Depends on the fight, my FPS drops to 13!!! Doesn't matter the settings, LOW or "Ultra", the FPS drop is the same...

Sorry for my bad english :)

Share this post


Link to post
Share on other sites
Azryn   
4 hours ago, Kawasaki said:

i still get freezes when i attack more than 2 monsters but it doesn't seem to be as bad. It's still horrible and i wont play until they fix what ever they did to the game on rising water patch to make this start to happen but i guess they are trying to fix it.

 

It does seem slightly better. I still occasionally freeze but it doesn't seem nearly as frequent as before.

Hopefully they have been attempting a fix and it's not just a happy coincidence.

Share this post


Link to post
Share on other sites

Had seriously lag spikes start happening about 5-6 days ago myself, tried everything to fix it.  The only thing that did fix it was reinstalling the game.  I also disabled windows firewall while reinstalling and before that uninstalled nvidia drivers and software and only reinstalled the drivers.  No lag spike freezes ever since.  I'm going to blame the a bad patch.  Definitely was not my computer hardware or my gigabit internet since prior to patch I had zero issues.

Edited by 894535_1452550603

Share this post


Link to post
Share on other sites
Azryn   
2 hours ago, 894535_1452550603 said:

Had seriously lag spikes start happening about 5-6 days ago myself, tried everything to fix it.  The only thing that did fix it was reinstalling the game.  I also disabled windows firewall while reinstalling and before that uninstalled nvidia drivers and software and only reinstalled the drivers.  No lag spike freezes ever since.  I'm going to blame the a bad patch.  Definitely was not my computer hardware or my gigabit internet since prior to patch I had zero issues.

 

Oh, I never thought to try this. 

I'll give it a shot.

Thanks.

Share this post


Link to post
Share on other sites
WK   
6 hours ago, Azryn said:

 

Oh, I never thought to try this. 

I'll give it a shot.

Thanks.

Hi there, Any luck on this?

Share this post


Link to post
Share on other sites
Kuro-pi   

Ever since the rising waters update myself and my entire clan (about 40 people) have been having much worse performance in every aspect of the game.  There is not a single person in the clan that hasn't seen the difference.  Would be really nice if they could fix this crap so we can play properly.

Share this post


Link to post
Share on other sites
Windy   

I been playing nicely before Rising Waters patch.Since 10 feb game turned to be hard to play because continous lag spikes,freezes low latency.How comes i could play quite well before and now keeps freezing like that? It's not about everyone's computer-its about the server -also all my guild experiencing this,it's frustrating.The game should work fine if a pc meets the sistem requirements for this game ,the firewall its properly set and your internet its working ok and your ports are opened.Still the game works poor for many of us .You really need to do something for this ,NCsoft.Because soon,once some other game will be launched ,players will move away.This its bad -because you will loose customers ,moneys and we,players will loose a game that we awaited for a long time -don't get us dissapointed ....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now