Jump to content
Forums

GeDoSaTo final fix!!! True downscaling working


Legendami

Recommended Posts

I finally have higher resolutions working! I was ripping my eyes out with the extreme tesselation and bad graphics on 1080p no matter what resolution you would set in the graphics options.

But i finally got it tow work with Gedosato and a bit of help from everywhere.

Download the tool GeDoSaTo by the talented Durante:

 

http://gedosato.metaclassofnil.com/GeDoSaToUpdater.exe

 

Try to familiarize yourself with the tool with online tutorials because there are plenty...

The first post is the following by the user Rapture. Many thanks to him because this seems to be working initially:

 

You can kind of force GeDoSaTo downscaling to work if you do the ALT+ENTER thing to force the client into Fullscreen Exclusive mode. It doesn't have any rendering bugs like SGSSAA/OGSSAA/DSR do in BnS, and at least at the moment GameGuard doesn't seem to nuke it.

 

  • First load the game, enter the normal full-screen windowed mode, and exit
  • Install the latest GeDoSaTo build (tested 0.19.1947)
  • Add the following to User Whitelist: Client || Blade & Soul

 

  • Edit Settings and press + to create a new profile named: Client
  • Add the following to the config/Client/GeDoSato.ini profile which was just created and save:

renderResolution 3840x2160@120

presentWidth 0

presentHeight 0

presentHz -1  #you may need to fill in your actual refresh rate here, depending on setup

forceRenderRes true

scalingType bilinear

aaQuality 0

ssaoStrength 0

 

  • Remove or comment out with # other renderResolution from the global config/GeDoSaTo.ini to ensure the one you picked is used
  • Launch the game
    • The game will render in a small box in the upper left hand corner of screen with broken mouse input
    • Press ALT+ENTER simultaneously to forcibly enter Fullscreen Exclusive mode when BnS is in focus
    • Press + to confirm GeDoSaTo downsampling is active from the overlay info
    • (Optional) Enable FXAA level 2 from in-game graphic settings
    • ???
    • Profit

The only problem I noticed is that it will rarely hang the BnS client on exit. If that happens to you, CTRL+ALT+DEL, Task Manager, End Process -> Client.exe.

 

 

If hitting ALT+ENTER doesn't seem to work than it means you did it too late... you have click ALT+ENTER the second the NCSoft logo comes on!

Now that you have this working there is one issue remaining.... that's the fact that your mouse cursor is not working at your normal resolutions since

the game is actually rendering the cursor in a different resolution... so there is one more addition you have to add in your code to the config/Client/GeDoSato.ini profile (and the normal GeDoSaTo.ini just to be sure) to make your mouse cursor working properly:

 

modifyGetCursorPos true

 

So the full code of the config/Client/GeDoSato.ini profile should look like this:

 

renderResolution 3840x2160@120

presentWidth 0

presentHeight 0

presentHz -1  #you may need to fill in your actual refresh rate here, depending on setup

forceRenderRes true

scalingType bilinear

aaQuality 0

ssaoStrength 0

modifyGetCursorPos true

 

Than if you start up the game you'll see your mouse is working, remember hitting ALT+ENTER to get it right, currently i'm playing it in a 8K resolution and it just looks amazing!  

 

You're welcome, GG

Link to comment
Share on other sites

Durante added frame limit to gedosato but do not use it lol. you can use driver-based frame limiting (eg. nvidia inspector) or you can try to lock the frames in the ingame settings

 

for scaling you might want to try using bicubic instead of bilinear, bicubic tends to remove some of the temporal aliasing at the cost of slightly extra frame drop. instead of in-game fxaa, you can inject smaa from gedosato itself which will have less blurring than fxaa. also i have found that forceRenderRes is not necessary and gedosato will downsample at any res you put using renderResolution (you still have to choose it in game)

Link to comment
Share on other sites

Yes keeping the default resolution in the graphics options in game is the best option, then from there scale up the game from GeDoSaTo, but the real problem was that the mouse was not working when people tried this, found a solution for that. I already have a profile for beautifull AA from nvidia inspector, i do frame limiting and AA from there. The SMAA from gedosato itself is a good option now that i think about it but i already have 32x [32x CSAA (8 color + 24 cv samples)] from Nvidia Inspector wich makes the game extremely smooth already.

 

Yes you can use this to lock framerate but you could already do that with the ingame graphics options if i'm not mistaken

Link to comment
Share on other sites

  • 5 weeks later...

Does not work very well ... ghost images appear.
I use windows 10 pro 64bit and I have a GTX980ti.
my monitorTV is 1080p ...


I fixed this way:
-DSR Active.
-Put The desktop resolution in 4K (3840x2160p).
-Launch The game.
-if the mouse arrow becomes big, go into the screen and change the setting under "change the text size, apps, and other items." from 200% to 100%

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...