Jump to content
Forums

Disconnected From Server Now says Undergoing Maint.


Xeren

Recommended Posts

3 minutes ago, hotokun said:

oh snap, not one of those rollback I hope 

I hope they do roll it back after that patch yesterday I cant play at all, we need the beta back at least that worked without any problems.

Games a mess, no wardrobe, no friends showing, bots all over the place, and gold spammers everywhere, so you cant even chat.

Link to comment
Share on other sites

8 minutes ago, Smudger said:

I hope they do roll it back after that patch yesterday I cant play at all, we need the beta back at least that worked without any problems.

Games a mess, no wardrobe, no friends showing, bots all over the place, and gold spammers everywhere, so you cant even chat.

 

The wardrobe and friend list issues have already been fixed and while the bots and gold spammers are annoying you will always find them on any game they will eventually go away if you have so much problems with them spamming a certain chat remove that chat from your settings simple as that.

Link to comment
Share on other sites

(1000)(132,10054)

I haven't even run around in this game yet, I honestly don't see where the hype for this game came from. I've played so many MMOs and so far this is the worst launch I've ever seen. I've trawled the net trying to find a fix and there are so many other people in the same shoes as I am, yet no NCSoft help ANYWHERE... You'd assume a disconnect would be your own fault, something wrong with your internet, well, I'm not disconnecting from any other services, including Teamspeak3 which requires constant up time to stay connected.

 

I've tried some of the 'fixes' I've come across, like disabling Razer Game Scanner and disabling Nvidia GeForce Experience, lowing my Graphical settings, but nothing, the furtherest I've reached is where I was told my controls were 'WASD', then boom, disconnected like the numerous other times. Seriously unimpressed, I've recently been playing the Star Citizen Alpha (2.0), and the worst bug I encountered was clipping through a wall.... Blade & Soul is in full release, not alpha, or even Beta, I've read forum posts of players quitting the game because there isn't an official fix yet, or even any official technical support.

 

So maybe I'll have to rely on a player fix, because the technical support from NCSoft is non-existent. Pull you're fingers out, or you may as well scurry back to an Asia only audience.

 

Rant over (also, I had less issues with the Warlords of Draenor launch, yeah, I hope that hurt, cause the launch was pitiful.)

 

Oh and don't get me started on the lack of Server Transfers, atleast they did have something to say about that one... 'Sorry, we can't do that'

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...