Jump to content
Forums

Anyone else find the graphical pop-in very distracting?


Recommended Posts

Simply put - the object, and foliage pop-in is really bad. (grass, rocks, terrain, objects, etc.). They are being drawn a few feet in front my my character. Everything is set to maximum. Also note: I'm not bashing on the games' visuals or anything like that here. This is a seperate issue.

 

Unfortunately with the config file being xml. All it really does is save the UI option preset values, and then resolves them on game launch. You can't raise them further via the config file, or anything like that (for example).

 

I just wanted to post this, to see if anyone else finds this very distracting. My eyes keep jerking to the pop-in points in front of my screen as I'm moving around. It's pretty annoying after a while.

 

 

Edited by Asmodean
zombie typos
Link to post
Share on other sites

I'm more annoyed about the random FPS drops in some of the instances. For no reason i'll go from 60fps to 18fps when going through a small tunnel but when there are 8 mobbs on the screen + 6 party members and abilities flying everywhere I can stay between 48-60fps. You're telling me a single torch is doing more than 14 bodies doing flips and spins and fire/ice spewing everywhere XD. 

Link to post
Share on other sites

Could anyone else maybe bump this, if you agree with the topic presented here. I'm not requesting anything major. Simply unlock the draw distance (options) for the foliage, etc. So those of us with the systems to handle it, can raise the object draw distance, to eliminate the crude looking pop-in, please?.

 

Either I'm overly sensitive to the pop-in, in this game, Or others need specticles? lol.

Link to post
Share on other sites
13 hours ago, Onene said:

I only get objects popping a few steps before my character only if I put the object view distance at 50% or lower. At max the grass for example renders all the way to the horizon.

 

Are you for real?. I've got everything set to max. The grass draws in about 15 feet in front of me, and the lod pop-in is pretty bad too.

 

What GPU are you running?. I've a gtx 970.

 

Can anyone else provide some input on this. Do you have this problem?. Or like above feel it's fine for you?.

Link to post
Share on other sites

definitely an issue with your pc performance instead of the game.

like the guy couple posts above me, i run at everything maxed with 980ti, and 99,9999999999999999% of the time the enviroment renders as far as the draw distance goes.

there are occasional popping grass thingies or whatnots when im changing areas and performance dips for half- asecond. aside that it's just fine.

Link to post
Share on other sites

I have GTX 970 and I don't have problem like that.

Like a lot of folks here, the only problem I'm getting is unstable FPS: I was at constant 120+ FPS then all of sudden it's drop to 28-45 FPS and going in back up after few seconds (happen a lot in open world at world boss fight) and my PC is not low performance gaming PC :)

Link to post
Share on other sites

Thanks for the feedback. I guess I'll try fresh reinstalling the game (?). I've no idea what's up. I've seen no other graphical artifacting. I've anything that auto adjusts the optons unticked aswel. I even checked the config xml, to be sure..

 

My frame rate is also fine, excluding the typical d3d9/x86 threading-related performance bs nosedives for certain stuff. Which is simply because the game doesn't utilize the system's hardware, running dated APIs.

 

My system is also healthy, and stable.

Windows 7 pro x64

3770k @ 4.4Ghz

GTX 970 @ 1440 / 1950

8GB 2133 CL9

Crucial M4 SSD

 

I'm not exactly confident about a reinstall solving the problem, but I guess I'll report back afterwards, regardless o/

Edited by Asmodean
Link to post
Share on other sites

Your GPU will not be a main issue. This game has been proven to be massively more CPU dependent that GPU dependent. Hyperthreading single processor set-ups are showing a better performance benchmark by far. Not to mention the U3 engine is starting to show its age.

Link to post
Share on other sites
30 minutes ago, enem said:

and you're up-to-date with nVidia drivers and all that?   I really don't think reinstalling is going to do anything for you at all. 

 

I'm running 359.06. I don't update drivers for the sake of it, though. The only other two released since then was a VR-related one, and a gameready driver for tomb raider, and the division. Edit: Have you guys also noticed that there are 3 profiles for BnS, one is a dated one, with a different client (bnsclient) it's called. And the other 2 are for Korea, and China. I wonder if that has something to do with it, because I was trying out those profiles to see - because there seems to be no NA/EU profiles released from NV.

 

I also don't think a game reinstall will sort it, but I've run out of options, that I can think of. I'm usually pretty good at resolving my own technical issues. Hmmm, the game's already too op for me ;p

 

26 minutes ago, OmniBlade said:

Your GPU will not be a main issue. This game has been proven to be massively more CPU dependent that GPU dependent. Hyperthreading single processor set-ups are showing a better performance benchmark by far. Not to mention the U3 engine is starting to show its age.

 

Yeah, I'm not going to disagree with you. But, it's fairly typical for MMOs. They use fairly cheap rendering techniques, usually. It's the threading, and cpu processing for the various system frameworks that are the usual performance problems for most. This is also why all mmos released at this stage should be running x64 arch binaries, for memory and threading management.

 

But, back to the point. I'm not actually asking about performance stuff here ^-^. It's an unusual draw distance issue. My game's grass, and lod, are stuck really low for some reason. Heavy pop-in. It's extremely distracting.

 

The only thing I've left to try so far, is a driver-reinstallation, or a game reinstallion. I guess I'll try a driver one first. Even though I don't see what that'll do. A draw distance issue is really not a typical driver-related issue. It would typically be texture clamping, or shader / artifact related, but I'm outa options, I guess lol.

 

 

Ta for the replies.

Edited by Asmodean
Link to post
Share on other sites

Def your pc thing. For example, I currently have a rather crappy PC, but I have set everything on 1, except Character View Distance at 5. It should mean characters loading away, but sometimes it's loading so slow that I'm already gripping the character but still don't see him.

So it's something about your settings/performance. For me, it's because of lack of RAM (4gb, nearing top with BNS on) and game being installed on HDD.

Edited by Enhance
Link to post
Share on other sites
On ‎31‎.‎01‎.‎2016 at 4:49 PM, Asmodean said:

 

Are you for real?. I've got everything set to max. The grass draws in about 15 feet in front of me, and the lod pop-in is pretty bad too.

 

What GPU are you running?. I've a gtx 970.

 

Can anyone else provide some input on this. Do you have this problem?. Or like above feel it's fine for you?.

 

 

Having the same problem with stuff popping in pretty close no matter what settings or view distance I choose.

 

Intel i5 4670K

GeForce GTX 770

Gigabyte GA-Z87X-D3H

Kingston HyperX DDR3 1600MHz

Game installed to Samsung 840 SSD

Win 7 Ultimate SP1 x64

 

Edit: Just finished a fresh install of my PC. While overall performance improved (fresh install was overdue), the pop-ins persist.

So I can rule out conflicts with previous B&S clients I had installed. Also I'm not having problems with other games.

I tried almost every possible combination of nVidia- and ingame-settings. I noticed the pop-ins are worse in some zones than in others.

It's most noticeable on small foliage like grass. Looks like half of it gets rendered farther away (~20m) and the other half pops in as I get closer (~10m). Bigger textures like rocks, trees and bushes pop in a little sooner, but I can't see stuff nearly as far as some people say they do. Rocks sometimes slightly change shape shortly after becoming visible.

I'm starting to think it's just bad optimization on some systems.

Link to post
Share on other sites
  • 4 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...