Jump to content



Recommended Posts

SO This has been going on for over 24 hours and I'm pretty pissed.

Everytime I try to start up this game if gets to the logo and then crashes.


Ive sent in multiple tickets trying to get this issue fixed and they sent 3 copy paste fixes (which ive done all of them) and then stop replying.

I have a membership that i'm WASTING trying to figure this stuff out. 

Ive reinstalled twice, ive deleted files and replaces, i got rid of my firewall and antivirus software. IM OUT OF OPTIONS. 



Link to comment
Share on other sites

Provide more information for people to be able to help you....


Computer Specs,

Have you tried running it as admin

Have you COMPLETELY disabled anti-virus? A lot of the time people THINK they have, but actually haven't.

Link to comment
Share on other sites

Windows 7 64bit

AMD Phenom(tm) II X4 965 3.40 GHz

12 GB Ram

AMD Radeon R9 200 Series 

750GB HDD + 320 HDD


I have tried running it as admin, I have completely disabled anti-virus, and have countless other steps but to no avail.

Link to comment
Share on other sites

I have the same problem it isnt your pc. I have this logo crash problem too havent been able to play for a week now. 

It isnt pc spec or even razer if it was razer it would of said 4049.

I havent found a solution and do not reinstall its a waste of time LOL reinstalled the whole game and same thing happened Crash

Link to comment
Share on other sites

  • 2 months later...


This topic is now archived and is closed to further replies.

  • Create New...