Sign in to follow this  
DrRob

Blade and Soul with Steam Overlay

Recommended Posts

DrRob   

Hey guys I just wanted to share how to get your Steam Overlay to work with Blade and Soul. I'm sure many people can use this and this will probably help for talking to friends on Steam or even showing them the game:

 

#1 Go to your Steam Overlay and select "ADD A GAME..." then click "Add a Non-Steam Game..."

 

8SDz0bP.png

 

#2 Browse for the Blade and Soul program to check mark it and press "ADD SELECTED PROGRAMS".

 

#3 Once you got that done you have to edit the target information since Steam didn't do it right, so right click Blade and Soul in Steam and click properties:

 

QYdTySO.png

 

#4 Delete the "Target:" information by holding delete or pressing Ctrl + A and pressing backspace. Copy this in "Target:":

 

"C:\Program Files (x86)\NCWest\NCLauncher\NCLauncher.exe" /LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com"

 

#5 Delete the "Start In:" information by holding delete or pressing Ctrl + A and pressing backspace. Fill this in "Start In:":

 

"C:\Program Files (x86)\NCWest\NCLauncher"

 

#6 After this you can Close properties and launch Blade and Soul through Steam to get the Steam Overlay in-game!

 

 

Edit: 

 

If this does not work for you: 

 

1. Your Blade and Soul isn't the default directory such as C:\Program Files (x86), etc. 

 

2. You're using a different launcherid instead of NCWest

 

If your Blade and Soul is in a different place than the default or it's just different what you can do is go to your desktop and right click the properties of your Blade and Soul to find the "Target:" and "Start In" information you need.

Edited by DrRob

Share this post


Link to post
Share on other sites
Serati   

This also doesn't work if the client is installed on a different partition than the launcher. Afaik the launcher is always installed in C: and it can't be changed so if you installed the client elsewhere it's not going to work.

Share this post


Link to post
Share on other sites
DrRob   
6 minutes ago, Serati said:

This also doesn't work if the client is installed on a different partition than the launcher. Afaik the launcher is always installed in C: and it can't be changed so if you installed the client elsewhere it's not going to work.

 

Well you could probably copy it to a different drive if you wanted to. I'm sure there's a way.

Share this post


Link to post
Share on other sites
Bahaliel   
8 minutes ago, Mikhail said:

Mine pops up and acts like I'm not playing it anymore.

 

Try running Steam as admin

Share this post


Link to post
Share on other sites
DrRob   
17 hours ago, Bahaliel said:

Try running Steam as admin

 

Yeah, that might be the problem. I always have my Steam to auto run as admin.

Share this post


Link to post
Share on other sites

Changed the target and start in, still get immediate launcher error whenever I try to run the game through steam. Steam is running as admin automatically.

 

Edit: apparently the target change didn't stick the first time. It seems to be working now.

Edited by KeybladeBandit

Share this post


Link to post
Share on other sites
CptBrian   

Doesn't work and everything is set up exactly like this with default installation directories too. Running Steam as admin as well, I wasn't previously, so it didn't change anything. Edit: Got it working, copied info from official shortcut and pasted into Steam. Edit2: Running as admin may be required.

 

WjW7b8j.png

0RZaIk4.png

Target: "C:\Program Files (x86)\NCWest\NCLauncher\NCLauncher.exe" /LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com"

 

Official shortcut info:

M940H1K.png

Target: "C:\Program Files (x86)\NCWest\NCLauncher\NCLauncher.exe" /LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com"

StartIn: "C:\Program Files (x86)\NCWest\NCLauncher"

 

Edit: It's working now that I copied the stuff from my official shortcut... I don't see any differences though.

Edited by CptBrian
Got it working.

Share this post


Link to post
Share on other sites

Im going to bump this knowing that it is old and please dont tell me i should not use a controller with this game, i get that but for me it works best. Anyway im struggling to get the controller and steam overlay to work through the new launcher. I changed location ran steam in normal mode and controller was acting weird but when i ran it in admin mode it wouldnt even work at all. So if anyone is nice enough to have some sort of information on how i do it with the new launcher, i would greatly appreciate it

Share this post


Link to post
Share on other sites

This is an update to the Add on Steam Launch:

Go to 'Add a Game' Than select 'Add non Steam Game'. Look for 'NCLauncher2' tick mark it and 'Add Selected Programs'.

It should show like this:

Target:

"C:\Program Files (x86)\NCSOFT\NC Launcher 2\Matryoshka.exe"

Start In:

"C:\Program Files (x86)\NCSOFT\NC Launcher 2\"

 

 

Run Steam as Admin. You sould be able to play BnS now, though im still trying to figure out how to get the overlay to work now. It only show on my friend list that im playing Blade and Soul.

Share this post


Link to post
Share on other sites
Azyrion   
Am 9.4.2019 um 17:59 schrieb GREYDRONE70:

This is an update to the Add on Steam Launch:

Go to 'Add a Game' Than select 'Add non Steam Game'. Look for 'NCLauncher2' tick mark it and 'Add Selected Programs'.

It should show like this:

Target:

"C:\Program Files (x86)\NCSOFT\NC Launcher 2\Matryoshka.exe"

Start In:

"C:\Program Files (x86)\NCSOFT\NC Launcher 2\"

 

 

Run Steam as Admin. You sould be able to play BnS now, though im still trying to figure out how to get the overlay to work now. It only show on my friend list that im playing Blade and Soul.

This doesn't let me play the game with controller. Also: The overlay only comes shortly in the login window afterwards it doesn't show up anymore.

 

Anyone a solution for this?

Share this post


Link to post
Share on other sites
Hanuku   

The current BnS launcher won't allow Steam to interact directly with BnS. They did something that disabled it nearly completely. You can still have the game as a shortcut there, but it's simply not necessary anymore since it won't work. Meaning, say goodbye to the Steam overlay and dedicated gamepad mode. It's gone for this game until something is done dev-side to change it. Now, it does not mean you can't use a Steam controller with it. You just have to make a desktop setup and emulate the KB+Mouse binds to it. So step by step:

 

Open Steam in admin mode. (can be done from classic client or BPM but the location of the next step varies a bit between front ends)

Go to Settings>Controller>Desktop configuration (classic client) or gear icon>Base configurations>Desktop configuration (BPM).

Create or edit a KB+Mouse emulation preset. Set everything in whatever way you want.

Save this desktop configuration and open BnS. Use Export Configuration>Personal to really save it into Steam's servers.

Now you can open and play with your controller even if it's not added as a non steam shortcut. You can even open Steam after opening the game. The only requirement is that Steam must be run in admin mode. The in-game UI and all prompts will be set for KB+M, so some key learning is needed. But a benefit is that now people can speak to you in game terms and you will know which keys they are talking about without having to translate them into gamepad controls.

 

My current config goes more or less like this:

L trigger: right mouse click

R trigger: left mouse click

L bumper: G (damage type ultimate attack)

R bumper: 5 (item)

R grip: Mode shift for d-pad and for r-trackpad

L grip: talisman

R track pad: Q,E,tab and F set to no click needed for ease of access

L track pad: mouse move. Go to additional settings and set edge spin speed to max and edge spin radius to mid way.

L track pad click: Jump

Joystick: WASD move

Select: Alt

Start: Esc

 

These are my personal settings I feel good with. You can do better settings than these, but I feel these cover most of what's needed to do combat and move around.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this