marzy

LOW FPS - HIGH PC SPECS

Recommended Posts

marzy   

Hi guys

 

I am getting really really low FPS however I have a really good PC, im getting 20-40fps on low settings and i have no idea why??

 

PC Specs:

 

i7

16GB RAM

GTX 970

500w PSU

 

...

 

Any idea why my game is running really slow?

 

I handle every other game on high settings with no problem, but with this game i can't handle it at all.

 

Would appreciate it if someone could help

 

Thanks :) 

 

Share this post


Link to post
Share on other sites
marzy   

I have turned shadows off completely, and im still getting shocking FPS, with my specs it should handle the highest graphics, including shadows...

Share this post


Link to post
Share on other sites
Jourdan   

I feel ya. I got the same specs so but I noticed when both shadow settings were at 5 I got 45 fps constant then when I turned them down to 3 I got 60 fps straight.

Share this post


Link to post
Share on other sites
3 minutes ago, marzy said:

Hi guys

 

I am getting really really low FPS however I have a really good PC, im getting 20-40fps on low settings and i have no idea why??

 

PC Specs:

 

i7

16GB RAM

GTX 970

500w PSU

 

...

 

Any idea why my game is running really slow?

 

I handle every other game on high settings with no problem, but with this game i can't handle it at all.

 

Would appreciate it if someone could help

 

Thanks :) 

 

i5-4690K

16 GB RAM

GTX 970

Game graphics set on max across the board

 

FPS steady at 121.  Only drops when transitioning areas and when I get in areas with high population, but Ive only seen them drop to the mid 80's.  Your rig should be fine, not sure what the problem could be.  What kind of speeds and latency do you normally get from your ISP?

Share this post


Link to post
Share on other sites
marzy   
1 minute ago, dispatcher505 said:

i5-4690K

16 GB RAM

GTX 970

Game graphics set on max across the board

 

FPS steady at 121.  Only drops when transitioning areas and when I get in areas with high population, but Ive only seen them drop to the mid 80's.  Your rig should be fine, not sure what the problem could be.  What kind of speeds and latency do you normally get from your ISP?

2

See... I don't understand that :( i know my PC is really power, I handle every new game without a problem and on the highest settings, however this game is a totally different experience and i have no idea why.

 

And my speed is 20mb and ping is usually around 40

Share this post


Link to post
Share on other sites
Phoenix4   
8 minutes ago, marzy said:

Hi guys

 

I am getting really really low FPS however I have a really good PC, im getting 20-40fps on low settings and i have no idea why??

 

PC Specs:

 

i7

16GB RAM

GTX 970

500w PSU

 

...

 

Any idea why my game is running really slow?

 

I handle every other game on high settings with no problem, but with this game i can't handle it at all.

 

Would appreciate it if someone could help

 

Thanks :) 

 

I pretty much have a similar issue , using a i7 4790K and GTX 770 with 32GB 2666MHz and im getting sub 40s now and then , generally lots of frame drops.

 

I guess server lag has an impact too , yesterday especially in a few maps personally i had like 500ping and along with it my fps died. Also for some reason the game is not Full Screen but instead its Windowed Full Screen even if it is says its Full and this is tanking some FPS for sure.

Share this post


Link to post
Share on other sites
Just now, marzy said:

See... I don't understand that :( i know my PC is really power, I handle every new game without a problem and on the highest settings, however this game is a totally different experience and i have no idea why.

 

And my speed is 20mb and ping is usually around 40

Not bad numbers.  My speed runs around 30 megs and ping is in the low 20's.  

Share this post


Link to post
Share on other sites
marzy   
3 minutes ago, dispatcher505 said:

Not bad numbers.  My speed runs around 30 megs and ping is in the low 20's.  

I dont understand why im running the game at 20-40fps on low settingssss -.- :( 

Share this post


Link to post
Share on other sites
Just now, marzy said:

I dont understand why im running the game at 20-40fps on low settingssss -.- :( 

Wait, there is an option to limit frames per second in the settings.  Have you checked to see if the sliders are set to those FPS?  I remember now having to turn mine up to max of 121.

Share this post


Link to post
Share on other sites
marzy   
Just now, dispatcher505 said:

Wait, there is an option to limit frames per second in the settings.  Have you checked to see if the sliders are set to those FPS?  I remember now having to turn mine up to max of 121.

Yes, i have turned mine up to 120 as well but im still getting 20-40 fps 

Share this post


Link to post
Share on other sites
Kend   

I suggest reinstall the game since it could be file corrupt. This game is already 5 time better than what it was a few year ago in kr sever openning,  

MSI GS 70

i7

Gtx 765m ( pretty old graphic) 

16 Gb Ram

80 fps and more .... if i want.

 

Share this post


Link to post
Share on other sites
marzy   
2 minutes ago, Kend said:

I suggest reinstall the game since it could be file corrupt. This game is already 5 time better than what it was a few year ago in kr sever openning,  

MSI GS 70

i7

Gtx 765m ( pretty old graphic) 

16 Gb Ram

80 fps and more .... if i want.

 

This makes me so jealous :/

 

3 minutes ago, Zjade said:

I have the same exactly problemmmm

 

What specs do you have?

Share this post


Link to post
Share on other sites
1 minute ago, marzy said:

Yes, i have turned mine up to 120 as well but im still getting 20-40 fps 

Man, I just dont know.  Without being there to physically look at your machine its hard to tell, could be a number of things.  Could be anything from something hogging your bandwidth to an imperfect connection to their servers.  Have you done a ping or tracrt using your cmd?

Share this post


Link to post
Share on other sites
marzy   
2 minutes ago, dispatcher505 said:

Man, I just dont know.  Without being there to physically look at your machine its hard to tell, could be a number of things.  Could be anything from something hogging your bandwidth to an imperfect connection to their servers.  Have you done a ping or tracrt using your cmd?

Yes, it all seemed fine :/

1 minute ago, Phoenix4 said:

What Windows are you using right now ?

Windows 8.1, should i upgrade? 

Share this post


Link to post
Share on other sites
Just now, Kend said:

try WTFast to see if its internet problem 

DO NOT DO THIS!!!!  It is speculated that WTFast is the reason peoples accounts are being banned/locked for some reason.  I repeat, DO NOT DO THIS right now!!!

Share this post


Link to post
Share on other sites
Phoenix4   
Just now, marzy said:

Yes, it all seemed fine :/

Windows 8.1, should i upgrade? 

I don't know to be honest , i'm having issues too like i said before and i'm running 8.1 too. I wonder how it would run on Windows 7 , since it's a Korean game i'm pretty sure there has to be a difference in performance but i don't have time to test stuff like that.

Share this post


Link to post
Share on other sites
Just now, Phoenix4 said:

I don't know to be honest , i'm having issues too like i said before and i'm running 8.1 too. I wonder how it would run on Windows 7 , since it's a Korean game i'm pretty sure there has to be a difference in performance but i don't have time to test stuff like that.

Im running on Win 10 with no issues at all.

Share this post


Link to post
Share on other sites

Hello, i have the same problem here ...

I have max. 25 fps in this game, this is OMG, this game is broken.

 

My specs:

GPU : MSI GTX 980Ti 
CPU : Intel Core i7-4790K 4.4 GHz 
RAM : Patriot Viper3 Black Mamba 8GB

Share this post


Link to post
Share on other sites

There is nothing wrong with your setups, its not the processor, neither the graphics card or the PSU, also razer synapse isn't the fault here.

 

Game is 4 years old already and it was started to be developed really long before those 4 years, therefore its graphic engine its deprecated nowadays.

 

FYI it uses UT3 (same as Tera and other games) and obviously that engine was not really thought for MMO games, more likely FPS and sandboxed 3rd person shooting/action games (like a singleplayer game, lets say for you have an idea kind of Devil May Cry as an example).

 

So basically the problem is game running on UT3 engine + DX9.0c + massive amount of people in an area = fps drops.

 

Go try do blackwyrm at faction area with 50 people and you'll see. Even people with 980s SLI are dropping to 15-20fps because the game engine does the bottleneck.

 

Have a nice day

Share this post


Link to post
Share on other sites
Phoenix4   
4 minutes ago, pingal1ty said:

There is nothing wrong with your setups, its not the processor, neither the graphics card or the PSU, also razer synapse isn't the fault here.

 

Game is 4 years old already and it was started to be developed really long before those 4 years, therefore its graphic engine its deprecated nowadays.

 

FYI it uses UT3 (same as Tera and other games) and obviously that engine was not really thought for MMO games, more likely FPS and sandboxed 3rd person shooting/action games (like a singleplayer game, lets say for you have an idea kind of Devil May Cry as an example).

 

So basically the problem is game running on UT3 engine + DX9.0c + massive amount of people in an area = fps drops.

 

Go try do blackwyrm at faction area with 50 people and you'll see. Even people with 980s SLI are dropping to 15-20fps because the game engine does the bottleneck.

 

Have a nice day

The point is that some people have i7s and 980Tis and are lagging even on Low while they are pretty much with a few mobs/people meanwhile others with inferior hardware are having +80FPS

 

Something is not right , i mean yeah the game isn't that optimized and on 50 people it should lag but still.

 

 

 

@

dispatcher505

 

I guess i have to give it a try on my brother's PC which has W10.

Edited by Phoenix4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now