Kolto

Nvidia Kernel Driver Crash only when playing Bns

Recommended Posts

Makonia   
  • 3 hours ago, NightmareCandle said:

Not who you're replying to but: That's not the issue. It's not the driver (I have upgraded or rolled back to four different drivers now, from the newest to one from Nov), the graphics card, temperatures, any of the hardware, or anything else. I have tested every single piece of hardware (and disabled all non-windows software) on my system and literally Blade and Soul itself is the only problem. I have no issues on any other MMO or single player game, even a different region's release of BnS. Which is what is bothering me the most. It's obviously not the graphics or your hardware when almost the same exact game works perfectly whereas it crashes from the start on this release.

 

 

Well just saying if one person is having issues with the game with the exact same GPU I have it's kinda hard to rule it as a client issue when the programs ran with the client could be conflicting it's processing. How can you explain I have no issues when everyone else seems to be with the same GPU? I've seen people with builds almost identical to my own and having the same issues experienced in this thread. I used to have the exact same issues when I first started playing the game (Head start). I was getting black screens, random CTD's, and the client would freeze up every so often and I'd have to force close the client. After some digging around and disabling all my startup programs I was able to play for certain periods of time before I'd start crashing. Then NCsoft said the issue was the razer chroma keyboard in the clientconfiguration.xml file that needed to be set to 'n' instead of 'y' so when I fixed that I could play all day long and not crash once.

Then with this recent maintenance on 1/30 they screwed up the client again and I had to enable the Razer Chroma SDK service so I could even launch the game (without it can't even get past BnS LOGO with a crash report). Once I launched the game I had to go into task manager and END TASK on the Razer Chroma SDK service or else it'd crash my game after 5min. At least at this point I'm now able to play without issue but I have to restart my computer if I decide to quit and come back in the same day. Anyhow good luck I'm gonna restart my computer so I can finish my dailies.

Share this post


Link to post
Share on other sites
Krosa   

Yeah, I'll add to the thread. I'm having the same issues as well. Though what grinds my gears is that it always. ALWAYS locks up right at Poh 6 man. 24 man works fine, but for some reason the actual dungeon will always freeze me and disconnect at the final boss. Hopefully the issue gets fixed since I'd like to run endgame dungeons with friends without leaving them hanging on the final boss.

Share this post


Link to post
Share on other sites
Andyyyy   

I have the Same Problem.

Nvidia Kernel Driver Crashes Max. 2 minutes After loading Game. No Solution so far...

Share this post


Link to post
Share on other sites

Same problem, although my crash timings vary. 

I have a computer science background with a few years in industry, so please no canned answers like 'packet loss' in favor of not investigating a bug.

 

I do run rainmeter, so I have some fun graphs and what not.

 

Raw gfx graph

http://prnt.sc/a67xjw

 

Labeled:

http://prntscr.com/a687ap

 

My rig is

  • i7-5820k
  • 32 GB RAM
  • GTX980
  • 100 MB solid connection.

While I obviously can't look at your code,

In the drawing phase of the BnS program, you have to have some sort of race condition where you cause the gfx card to freak out.

When the driver crashes, you guys don't check if the nvidia hooks are still valid. and causing the game to forever freeze.

Share this post


Link to post
Share on other sites
scerate   

I know it sounds wrong and or weird but did you guys tried to underclock your GPUs Core Offset? Cause i have a somewhat similar case since CBT and it annoyed the cr*p out of me. I have a 980TI Lightning and somehow the game freaked my card out like you guys describe and weirdly only via underclocking it to -50Mhz worked at first but it wasn't a satisfying solution to me, so right now i'm undervolting my cards main Voltage from 1.2v to 1.15v wich works instead of underclocking. Normally the card runs out of the box @ 1430 1.2v and only BnS gave me these sort of crashes sometimes 1-2min into the game/login screen or it even could take up to 2-3 hours but it crashed eventually. I guess it have something to do with how the card throttles itself due to boost 2.0, cause due to using a Lightning card my Voltage gets applied directly instead of just setting a reference Voltage offset, but i hope my solution directs you somewhat in the right direction.

Edited by scerate

Share this post


Link to post
Share on other sites

I was a Computer Programmer for 13 years.

Laughed my ass off at "packet loss".

 

I've gone through my rig with Titan X, etc and same issues.

I've fiddled with the graphics and quite honestly if I can max out Witcher 3 with ease this game should be nothing.

This issue has to be on their end or in the coding. 

 

Share this post


Link to post
Share on other sites

Yeah I made this post on /r/pcmasterrace and on /r/bladeandsoul. I thought my card was dying since it was happening every day. I havnt tried the fix yet but glad to see that other people recommend underclocking. Although I dont understand why having a high clock speed should ever be a problem...

 

 

edit: if you dont go to the link and want to know my setup, I run an i7 4790k and a Nvidia gtx 980 classified.

Edited by CogitoProxy

Share this post


Link to post
Share on other sites
scerate   

what i thought about, you guys can use EVGA PrecisionX and use KBoost there, it should force your card in permanent P0 State, which means it stays at 3D Clocks and steady Voltage, it potentially could help. To undo it just disable KBoost there.

Share this post


Link to post
Share on other sites

Guys.. I got this fixed (at least for myself).

If you don't want the poorly opzimized game to crash use the 340 wqhl drivers from nvidia.

How it went for me:

Everything worked "ok now lets try this new 365 driver and see if we get more fps" whoosh card driver gone, mouse, keyboard, headset aswell. Hard reboot a few times.. same shit.

"Maybe I use 340 or some older drivers, could work" now I do dis but still hardware gives up..

Problem: after installung/rewriting the new drivers with the old one physx newest version still there so now.. "I need to get rid of all these drivers to make it work again" and so I did, rebooted a few times.. got rid of everything. All! All drivers for your card or you won't move forward. Now express install 340 drivers on clean computer and this works fine now. Just did my few arena dailys before server maintenance.

 

P.S.

Intel i5 (2,5-2,7) can't check since on my phone.

Nvidia gtx 760 pny

6gb ram ddr3

Win7 64bit

 

 

Edited by YuriYuran

Share this post


Link to post
Share on other sites

This is a normal question about display drivers stopped responding and has recovered, it occured above windows vista. First, people need to check if the driver is outdated and it can full compatible with the game.  And there are several things can follow to solve this problem:

1. Update the latest verion of graphic drivers (NVIDIA, AMD and Intel)

2. Reset the TDR time (adjust above 2 seconds)

3. End programs by using Task Manager

4. Update the system Package

5. Reset base clock offset (such as 25 MHz)

6. Update motherboard/bios drivers

7. Cooling computer

8. Change graphic card (this is hardware problem)

 

And you can learn more about steps and why you need do all these things: https://www.driverdr.com/news/easy-way-to-fix-display-driver-stopped-responding-and-has-recovered/

Share this post


Link to post
Share on other sites

Same problem. The game freezes during intense fight usually (especially at bosses), then the message about the graphics driver not responding and recovering comes up but the game remains frozen and cannot be closed even from the process manager, effectively forcing the windows shutdown.

Windows 10 x64

Nvidia GeForce 950M

Newest driver 364.72 (it was crashing the same with earlier drivers too).

Share this post


Link to post
Share on other sites

A month has passed and nothing fixed, in spite of Nvidia releasing two driver updates, the game still randomly freezes and crashes, also crashing the computer in the process.

Share this post


Link to post
Share on other sites
Windy   

Same problem here ,Nvidia user -constant freezes-like 15 sec -when the entire pc becomes unresponsive.I rarely crash tho,yet the game freezing at a fps of 80 and with a very good internet connection with a decent pc /hardware configuration wich can room smoothly Aion,GW2.Tera,Rift ,Forsaken World,Echo of soul,makes me really think the problem is not on my pc and connection ,but something directly  from this game .Is getting worse and worse with every patch we are getting,yet we don't get any kind of support.All i seen here in this post ,were exactly same stuff wich the team from support offered for me when i tried to check whats going on--exactly same copy paste answers in same steps ,without to solve nothing.The game stays freezing,the sub is paid,yet i cannot play and enjoy the game this way.

I cancelled my sub,and probably ,if nothing changes ,ppl will get eventually bored to watch the endless loading screens and feeling helpless in some dungeon because they have screen freezes during boss fight like 5-10 sec.This game needs optimisation,badly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now