Jump to content

Crashes Caused by Razer and ASUS Services

Recommended Posts

Now, as I've read through this thread, I've come to understand a lot more than me are having these crashes, and even if it's unrelated to Razer or ASUS (I am still using a Razer mouse and ASUS motherboard, so somewhat related), I'll try posting all of the information I've gathered, and what kind of fixes I've tried.


Alright, so I started playing BnS two weeks back I think, and experienced my first crash very early on..I just brushed it off as a "happens", but it kept going, and I've had ranging from 3 to whooping 10 crashes every single day, and I'm really getting tired of it, as I am often making people or friends wait in dungeons for me when I crash.
First there's my system specs and then a list of things I've tried, if any of you know any other fix you'll be more than welcome, as the Technical Support gave up after 24 tickets back and forth.
Motherboard: ASUS Z97-E LGA1150 Intel ATX (90MB0KX0-M0ECY5)
CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
RAM: 16384MB RAM
GPU: NVIDIA GeForce GTX 660 Ti
Now, this is gonna be a ton of stuff, so I'll just try to make it short.
The crash that I'm having, is the nvidia driver crash, saying "Display driver stopped responding and has recovered" "Display driver NVIDIA Windows Kernel Mode Driver, Version 361.75 stopped responding and has successfully recovered."
-I disabled any kind of razer service, didn't help, uninstalled razer synapse, didn't help either.
-I don't have any kind of ASUS service running (I'm thinking of the ASUS something something game service)
-My CPU temperature ranges between 40 and 50 degrees celcius, and my GPU from 40 to 60.
-I switched on the optimize for combat option, disable chroma keyboard option, tried the optimize for low-end pc's, still crashing.
-I tried running my computer on a single monitor, crash.
-I tried reinstalling and repairing more times than I can count.
-I went into the NVIDIA control panel, set the image preview to performance, went into Manage 3D settings, changed Power management mode to Prefer maximum performance, changed Texture filtering - Quality to High Performance, tried Multi-display/mixed-GPU acceleration to Single Display performance mode...everything individually, everything together, nothing helped.
-Went into the NVIDIA inspector and tried the FFXIV profile optimization method, also tried the Blade and Soul profile which someone mentioned (I don't have the link any longer...)
-I tried formatting my computer, only installing Blade and Soul, still crashed.
-Of course I've updated my drivers.
-Fixed a corrupt opencl.dll file when I ran sfc /scannow.
-Ran verifier /standard /all, played the game until it crashed, no errors from it.
-Changed my PageFile memory usage, and changed my "Link State Power Management" in PCI Express in my Power Options to off.
-I have not experienced this with any other game, so I am fairly certain it's not my hardware.
After all of this, I decided to write to their "Technical Support"
I gave them my DxDiag, then they asked for my hijackthis.
They asked me to disable all of my services except the windows ones, then save my netsh winsock catalog to LSP.txt, which I gave them, and then I ran "netsh winsock reset", and played Blade and Soul with administrator rights, I crashed yet again after 2 hours of play.
I got asked to send my new hijackthis report, which I did.
I then made an exception from Windows Defender to the BnS folder, and any other kind of folder the game made.
THEN THEY TOLD ME TO UPDATE MY DRIVERS - keep in mind, I've told them everything I've tried to do, and told them I've been updating my drivers and checking if they're up to date all the time - I found no new drivers.
I then gave them my Speccy snapshot, and they asked me to run sfc /scannow...again, something I've written to them in detail.
At this point I was losing hope, and as a gift from heaven it came, the possible 'fix' to my problem...they ASKED ME TO USE THE "FILE REPAIR" BUTTON ON THE CLIEN, as if I hadn't reinstalled / repaired multiple times enough already. Honestly, if they don't know why, why not just tell me so instead of this.
I did as I was told, but crashed again, now they told me it might be because my windows account might be corrupt, so I made a new one, but again, I crashed after an hour or two of play.
At long last, they told me to stop any kind of razer drivers and restart my pc. I don't have any razer drivers left...
And this is the end of my conversation with over 10 different Technical Supports, if there's any of you with any kind of idea as to why this is happening, please speak up, I am in love with the game (not really how they handle it, but the game), and I really want to continue playing it, it's just sad to know I'm wasting so much of my party-members time when I crash and disconnect in the middle of a dungeon.
Keep in mind, my crashes are completely random, I've crashed in the beginning and end of cutscenes, also while I was in them, I've crashed while staring at the marketplace and having a drink, not touching anything, I've crashed in the dungeon and arena lobby, while stairing out on the sea on a rock, while fightning mosnters, when a E.Supply Chain boss spawned, when a boss died, when I logged in.....any time
Please send help!
Running a memtest gave me no errors.
I tried both overclocking to 4.4Ghz and underclocking to 3.5Ghz, I still crashed before I had played half an hour.


The reddit thread I've made

Link to post
Share on other sites
  • Replies 471
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

i dont own any razer products but i switched off asus game first and it still hasent solved anthing  

its ridiculous that they can release the game in less the 10 hours and have such a major problem i payed for the headstart and not been able to enjoy the bonus

it has to be client side aswell cus i played all the beta periods and i never encountered a single error until the headstart

420+ replies and no response from NCSOFT? This is pathetic... Once again NCSOFT ruins amazing games with their shit customer service. 


 My game runs fine until I get to any loading screen which involves a MASSIVE portion of this game...so the game has become basically unplayable.

  1. I don't have Razer or Asus.
  2. I have reinstalled my client 3 times
  3. I have repaired all broken files etc.
  4. I have even worked my DNS IP

Now answer me this  when did I have to start doing IT work on my computer to get a damn game to play. Your move NCSOFT. We are all waiting.




Link to post
Share on other sites
On 2/8/2016 at 4:40 PM, Rikanao said:

420+ replies and no response from NCSOFT? This is pathetic... Once again NCSOFT ruins amazing games with their shit customer service. 


 My game runs fine until I get to any loading screen which involves a MASSIVE portion of this game...so the game has become basically unplayable.

  1. I don't have Razer or Asus.
  2. I have reinstalled my client 3 times
  3. I have repaired all broken files etc.
  4. I have even worked my DNS IP

Now answer me this  when did I have to start doing IT work on my computer to get a damn game to play. Your move NCSOFT. We are all waiting.





Link to post
Share on other sites

My game now crashes at the splash screen logo thing now since last update, prem is wasting away too


I don't use razer or any of that stupid stuff, repair files fails as it fails to "read" something.




bns crash report does nothing.


no luck with re-installation.




Edited by CharlieGunz
Link to post
Share on other sites
On 2/9/2016 at 10:01 PM, Lauryn said:


Because this is more than Razer and Asus! Tons of people are crashing and NcSoft is doing nothing. Don't stand up for them when they don't deserve it.

Link to post
Share on other sites
On 2/12/2016 at 3:15 PM, Rikanao said:

Because this is more than Razer and Asus! Tons of people are crashing and NcSoft is doing nothing. Don't stand up for them when they don't deserve it.

Oh good god! You think I am saying this because I am defending them? How about this... I came here because I had an issue with my game crashing. Guess what? They told me it was because of Razer Synapse. Guess what I did then? Came to the forums looking for "Crashing Razer Synapse". Guess what I found? A thread called, "Crashes Caused by Razer and ASUS Services". Now my question is... How the hell did you get here when you dont have the same issue? Its like going to Auto Repair store saying your car wont start but you dont have a battery. Then you yell at them because you dont have a battery. Instead, all that you have done is reply to a thread that had nothing to do with your problem... Oh and BTW I am playing the game and loving it!

Link to post
Share on other sites

Temporary Workaround / Fix To Get Your Game Up And Running



Ive been following this thread periodically for a permanent solution from NCsoft since i own both a Razer Naga MMO mouse and an Orbweaver and well to be honest the last few updates have started many problems with the anti hacking software running in the background while BnS is launched. I still see a lot of players unable to either launch the game, crash after login or simply unable to get it to work.


Well GOOD NEWS EVERYONE if your running Windows 10 and you keep crashing or cant get the game to run ... here's a WORKAROUND that should allow you to run the game smoothly without hassles ... its not a FIX but it will get your game running and ive been using this and my razer gear for days with no hassles or crashes ( a lot of credit goes to my wife Nitepaws for coming up with the original brilliant suggestion lol ... what would we do without our wifey's XD ).


STEP 1 - Go to your windows startup manager and disable Razer Synapse from loading at startup (please look this up on google if you need further help on doing this step, but im trying to keep this post from becoming a wall of text) - Its not needed for the workaround, but it generally works better if synapse is not running when you launch BnS (restart your PC if you dont know how to stop all the razer processes).


Step 2 - Once booted into Windows 10 press Ctrl+Alt+Del and start the Task Manager, and please shut down any non essential services or processes you dont need to play the game ... especially things like CC cleaner / IO bit Malware Bytes / Advanced system care processes /Software update processes etc .. youd be surprised as to the things the Anti hacking software in BnS doesnt like ... besides your game will run a lot smoother without all this junk running in the background anyways.


Step 3 - While in Task Manager switch to the tab called "services", scroll down till you reach the processes starting with the letter "r" and look for :

               a) Razer Chroma SDK service

               b) Razer Game Scanner Service


Step 4 - This step is ESSENTIAL if both services are already running STOP them first and then restart them, if they are not running (stopped) then start them normally ... confirm on the right side that they are running or your launcher will crash.


Step 5 - With the Task Manager open and running start your BnS game launcher and login to the game.


Step 6 - IMPORTANT the moment you have logged into the game in the opening animation screen STOP BOTH THE RAZER PROCESSES in task manager (YOU MUST do this either before you enter your pin or before you login to your server) ... if you log into your character with the processes running and do anything like walk or run (basically press anything on a razer device you will probably trigger a crash).


Step 7 - Close Task Manager and THEN START Razer Synapse AFTER your login has completed and your on you character, you should be able to play your game smoothly for hours with no crashes or hassles.


It seems whatever fixes they have made to the launcher or game now require these two processes to be running when you start the launcher, however the solution from their side has has not been fully completed with the anti hacking software still treating the razer processes as malicious/botting processes, so basically what your trying to do is run the two processes to allow the launcher to load the game without crashing but stop the two processes from triggering the anti hacking software from crashing you while you are in-game and as far as i can tell certain patterns of key presses seem to trigger the crashes for e.g you can walk normally for an hour but suddenly hitting s+s might bring about your downfall lol.


Hope this helps your all out, took me ages of scratching my head before this started working with a 100% success rate for me, please feel free to try this on Windows 7 or 8.1 it should work ;)


Edited by Nitefire
Link to post
Share on other sites

The easiest way to completely fix this issue is to completely delete the Razor Application. Let the uninstall wizard remove it. This does have it's drawbacks and you can't use the left or right wheel mouse buttons but better than crashing every 5 minutes. 

Link to post
Share on other sites

The workaround given above lets you run your razer synapse normally and get all the benefits without any crashes .. spent most of the day in game yesterday till very late at night .. no crashes and no razer problems ;)


Not to mention that ive been doing this since the famous patch that ruined it all lol ... works 100% of the time for me.

Edited by Nitefire
Link to post
Share on other sites

Don't have any of this shit and still crash, and now it's worse I can't even load game without it crashing. Not to mention 80 dollars went out the window and I can't even play and enjoy my Premium services, nor will they refund it because I used NCoins. I even offered for them to delete my characters and refund me but nope didn't do it.

Edited by Aeriya
Link to post
Share on other sites

Soooo after I tried all kinds of weird fixes to the problem I found a little hint on facebook which helped for me.


I run the client on Windows 7 and everytime I tried to confirm my login information basically nothing happened and the client just disappeared until I tried again.


What helped me was to change the properties of the launcher file and run it in compatibiliy mode for Win7.

After I changed that I ran the launcher as Admin and it started working.


I hope that can help some of you guys and y'all can have some fun.



Link to post
Share on other sites

After the last update again, I am getting

A debugger has been found running in your system. Please, unload it from memory and restart your program.


The game has been working for a while now and again after the update this is happening. I look in task manager and nothing is running.



Link to post
Share on other sites

I don't have either product myself but I am getting the E02017 error pretty much every minute. It is completely mind boggling since this is a brand new system with virtually nothing installed on it other than the required latest drivers for everything related to the build, Firefox and two other MMORPG's. World of Warcraft & FFXIV both installed without a single issue. Blade & Soul has been NOTHING BUT ISSUES as soon as I hit the update button. As a systems administrator myself, I've done everything remotely possible on my end to resolve the issue & nothing has worked at this point. Searching the error through multiple sources proved to be unhelpful with a majority of forum & reddit post made on the error going unanswered. The official site gave a straight up BS way to trying to resolve the issue so I'm sure that was nothing more than a scripted response. So my advice for NCSoft to fix this issue & other issues related to it are as follows. 

1) Whoever was involved in designing the NCSoft launcher/client. Give that person or group of people nice severance packages & terminate them immediately. They clearly have no clue as to what they are doing. Try to replace then with individuals that actually have more to show than 2 year degrees from a tech school or a handful of " payed one check for this " certifications. 

2) Set up direct downloads (multiple mirrors) to the latest client version with the most recent major patch being implemented. This will allow the launcher to do an initial download of minor updates & will take over the duties of keeping the game updated from that point on. Since you are already doing it through the client, you can also set up direct links to the game via torrent. Other MMO's do this directly & it works well. Since the issues could be very well related to a poorly set up torrent system. 

Edited by LatinLegacy
Link to post
Share on other sites
On 1/18/2016 at 1:35 PM, Rukkirii said:

We are currently investigating an issue where certain services are causing issues with the Blade & Soul Client.  We are working hard on a fix to address these issues, in the meantime we recommend disabling these services via the below steps:


If you are having issues with the Blade & Soul client crashing to desktop, try disabling the Razer Chroma SDK Service and Razer Game Scanner Service.

Steps to turn off Razer Chroma SDK Service and Razer Game Scanner Service:

  1. Press CTRL, ALT, DEL and open the Task Manager

  2. Select "Services"

  3. Locate "Razer Chroma SDK Service" and select it

  4. Select the "Services" button on lower right

  5. Locate "Razer Chroma SDK Service" again, select "Actions" then "Stop"

  6. Select "Actions" again and choose "Properties"

  7. Open the "Startup type" drop box, and select "Disabled", then “Apply” and “OK”



If you are experiencing issues with skill delay, turn off ASUSGameFirstService:

  1. Hit the START button, and in the search box type: services.msc

  2. Locate "ASUSGameFirstService"

  3. Right-click "ASUSGameFirstService" and got to "Properties"

  4. Change the "Startup type:" option to "Disabled"

  5. Press "Apply", then "Okay"


This service may also be displayed as "cFosSpeed" "XFast LAN" or "Gigabyte Speed"



done everything nothing worked still crashed ive dont tickets and tried what they said nothing worked zzzzz this is annoying ncsoft needs to fix this as main priority not put it on the backburner and fix it when they want too and bns shouldnt come out with new content till this is fixed unfair for the player base having the problem we cant play any new content or classes pisses me off ...sigh

Link to post
Share on other sites

its the second time im posting here but this seems like the best solution since it disables to option for the game to even try and use razer products just give it a try it worked for me and apparently for a few others 

If the game seems to "NEED" razer software to actually run, try to make this change , so the client wont try to use razer software.

Go to :

C:\Users[Your username here]\Documents\BnS\NCWEST

( press WIN+R and type "%USERPROFILE%\Documents\BnS\NCWEST" )

edit the xml there ( Clientconfiguration.xml )

find the line that states

    <option name='use-chroma-keyboard' value='y'/>

change it to

    <option name='use-chroma-keyboard' value='n'/>

Now try to run the game , with all razer services disabled ( You can run with services on , thx /u/DeusInsania for the info :) ) . Hope it works :)


source : https://www.reddit.com/r/bladeandsoul/comments/4312nm/summary_razer_users_crashing_beforeafter_update/czenn0x

Link to post
Share on other sites
  • Liinxy unpinned this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...