Liinxy

Crashes Caused by Razer and ASUS Services

Recommended Posts

Liinxy   

We are currently investigating an issue where certain services are causing issues with the Blade & Soul Client.  We are working hard on a fix to address these issues, in the meantime we recommend disabling these services via the below steps:

 

If you are having issues with the Blade & Soul client crashing to desktop, try disabling the Razer Chroma SDK Service and Razer Game Scanner Service.

Steps to turn off Razer Chroma SDK Service and Razer Game Scanner Service:

  1. Press CTRL, ALT, DEL and open the Task Manager

  2. Select "Services"

  3. Locate "Razer Chroma SDK Service" and select it

  4. Select the "Services" button on lower right

  5. Locate "Razer Chroma SDK Service" again, select "Actions" then "Stop"

  6. Select "Actions" again and choose "Properties"

  7. Open the "Startup type" drop box, and select "Disabled", then “Apply” and “OK”

     

 

If you are experiencing issues with skill delay, turn off ASUSGameFirstService:

  1. Hit the START button, and in the search box type: services.msc

  2. Locate "ASUSGameFirstService"

  3. Right-click "ASUSGameFirstService" and got to "Properties"

  4. Change the "Startup type:" option to "Disabled"

  5. Press "Apply", then "Okay"

     

This service may also be displayed as "cFosSpeed" "XFast LAN" or "Gigabyte Speed"

 

 

Share this post


Link to post
Share on other sites
Nynaeve   

as stated in another thread i went so far as to reintall my entire bios i only run windows 10 atm with blade and soul and what it needs to run and i stil crash as soon as i log in

Share this post


Link to post
Share on other sites

its ridiculous that they can release the game in less the 10 hours and have such a major problem i payed for the headstart and not been able to enjoy the bonus

Share this post


Link to post
Share on other sites
Nynaeve   

it has to be client side aswell cus i played all the beta periods and i never encountered a single error until the headstart

Share this post


Link to post
Share on other sites
Zireael3   

I'm happy to hear you are working on this. I don't have any Razer or Asus services and still experience lag/delay problems despite not having any through all CBT. Connecting through WTFast solved it for me partially, (I managed to get from 180 to 30 ping) but for some reason, Cross Server Dungeon doesn't work for me when I connect like this. I just hope everything will be resolved soon and I'll be able to experience smooth gameplay like when I was playing in Closed Beta.

Share this post


Link to post
Share on other sites
MvJesus   

THANK YOU :D i dont have issues with crashing, but another issue. I have a beast pc and such with ping lower than 1500, so i shouldnt be lagging. however, when i press to use a skill, i have lag where it takes up to 3 seconds to cast. its random, sometimes it casts immediately, sometimes it doesnt. have disabled this, and hope it helps. thank you :)

Share this post


Link to post
Share on other sites
Zetian   

I am also in the camp of 'I don't have Razer or Asus but my game is still crashing- crashing to the point where it locks up my computer and I get a blank colored screen. 

Share this post


Link to post
Share on other sites
For those still experiencing issues with Razer Synapse, in my case I completed the following steps on Windows 10 to stop the game from crashing:
  1. Press CTRL + ALT + DELETE and select Task Manager.
  2. Select the Startup tab.
  3. Right Click Razer Synapse and select 'Disable'.
  4. Select the Services tab and click 'Open Services' at the bottom of the window.
  5. Right Click Razer Game Scanner and select 'Stop'.
  6. Right Click Razer Game Scanner and select 'Properties'.
  7. Change the Startup Type to 'Disabled'.
  8. Click 'OK'.
  9. Right Click Razer Chroma SDK Service and select 'Stop'.
  10. Right Click Razer Chroma SDK Service and select 'Properties'.
  11. Change the Startup Type to 'Disabled'.
  12. Click 'OK'.
Completing these steps will prevent all of your Razer applications from activating again once you restart your computer.  If you wish to use Razer Synapse, all you need to do is open it and it will restart the services required.  Otherwise, you should be free to play Blade and Soul without crashing.

Share this post


Link to post
Share on other sites
ppk   

this is crazy u run 10 years beta server and u have problem with asus and razer lol with razer? 1st in my life i see this gg wp seeking 3H for my issues and i see this omg when u gonna fix next few years ???

Share this post


Link to post
Share on other sites
zanetrx   
5 hours ago, Zetian said:

I am also in the camp of 'I don't have Razer or Asus but my game is still crashing- crashing to the point where it locks up my computer and I get a blank colored screen. 

 same problem here 

Share this post


Link to post
Share on other sites

don t work ...  we lose time ncsoft lose player's ...   problem is not  computer player problem is client ncsoft ... we have game;s in computer and we don t need to disable / enable / uninstall / etc to play a game

Share this post


Link to post
Share on other sites
peet   

im just going to wait for you guys to fix it. Everytime the game crashes it also crashes my pc so i cant even access my task manager, i have to turn it off and on again. i dont own any razor stuff but my pc is asus and so is my keyboard. Please fix this asap.

Share this post


Link to post
Share on other sites

I'm actually going to come out and say that it ISN'T an issue with Razer Products or the local softwares that are involved.

 

It has to do with corrupted bin files from the original LIVE BNS Client that we received for Headstart that got updated but failed to clean up old files.

 

For everyone having consistent crashes (Within 10-25 minutes of logging in), follow these steps.

 

Step 1: Access your local disc

 

Step 2: Program Files (X86) > NCSoft > BnS

 

Step 3: Delete the entire "bin" folder.

 

Step 4: Run the patcher and click repair files. Your bin files will be reinstated with clean ones and lacking any bugged or left over files.

 

Step 5 (Optional): Turn off Chroma Settings in game.

 

Step 6: Enjoy.

 

While the bug IS centered around Razer (As signified by some error reports), it's not specifically a Razer product or any softwares. The issue that seemed to be present was the Chroma Feature (On by default) triggering some type of communication failure to peripherals (Razer & Non-Razer) in which case, Game Guard was snapping at it and causing an error.

 

Even for people without Razer Products, the setting is still on and is attempting to communicate. Game Guard still flags it but fails to solve it.

 

Good luck, everyone.

Edited by BeardedBourbon

Share this post


Link to post
Share on other sites
Nynaeve   
1 hour ago, BeardedBourbon said:

I'm actually going to come out and say that it ISN'T an issue with Razer Products or the local softwares that are involved.

 

It has to do with corrupted bin files from the original LIVE BNS Client that we received for Headstart that got updated but failed to clean up old files.

 

For everyone having consistent crashes (Within 10-25 minutes of logging in), follow these steps.

 

Step 1: Access your local disc

 

Step 2: Program Files (X86) > NCSoft > BnS

 

Step 3: Delete the entire "bin" folder.

 

Step 4: Run the patcher and click repair files. Your bin files will be reinstated with clean ones and lacking any bugged or left over files.

 

Step 5 (Optional): Turn off Chroma Settings in game.

 

Step 6: Enjoy.

 

While the bug IS centered around Razer (As signified by some error reports), it's not specifically a Razer product or any softwares. The issue that seemed to be present was the Chroma Feature (On by default) triggering some type of communication failure to peripherals (Razer & Non-Razer) in which case, Game Guard was snapping at it and causing an error.

 

Even for people without Razer Products, the setting is still on and is attempting to communicate. Game Guard still flags it but fails to solve it.

 

Good luck, everyone.

see ive done that to and it stil will not work trust me i have tried evrything on this forum and as said im running only windows atm with b&s on it and im stil crashing as i load in the game

Edited by Nynaeve

Share this post


Link to post
Share on other sites
Marz   

I can confirm that doing the above has not fixed the issue for me either.

I have gotten to the point where I do not feel it is worth playing until this bug is fixed sadly

 

Ill keep checking this thread in hopes it has been resolved

Share this post


Link to post
Share on other sites
peet   
3 hours ago, BeardedBourbon said:

I'm actually going to come out and say that it ISN'T an issue with Razer Products or the local softwares that are involved.

 

It has to do with corrupted bin files from the original LIVE BNS Client that we received for Headstart that got updated but failed to clean up old files.

 

For everyone having consistent crashes (Within 10-25 minutes of logging in), follow these steps.

 

Step 1: Access your local disc

 

Step 2: Program Files (X86) > NCSoft > BnS

 

Step 3: Delete the entire "bin" folder.

 

Step 4: Run the patcher and click repair files. Your bin files will be reinstated with clean ones and lacking any bugged or left over files.

 

Step 5 (Optional): Turn off Chroma Settings in game.

 

Step 6: Enjoy.

 

While the bug IS centered around Razer (As signified by some error reports), it's not specifically a Razer product or any softwares. The issue that seemed to be present was the Chroma Feature (On by default) triggering some type of communication failure to peripherals (Razer & Non-Razer) in which case, Game Guard was snapping at it and causing an error.

 

Even for people without Razer Products, the setting is still on and is attempting to communicate. Game Guard still flags it but fails to solve it.

 

Good luck, everyone.

I did everything and it didnt work. im like 5 min into the game and the game crashes my computer i either get a white screen or a black screen after that i cant do anything and i have to turn the power off and on. this is really sad because i really wanted to play :/

Share this post


Link to post
Share on other sites
Myri   

Hell no I wont block Razer since its the only way I can actually play the game or any action mmo.

Share this post


Link to post
Share on other sites
1 hour ago, Myri said:

Hell no I wont block Razer since its the only way I can actually play the game or any action mmo.

Blocking Razer software doesn't block you from using the peripherals. The software only gives you additional benefit of hotkeys and stuff.

Share this post


Link to post
Share on other sites
Zetian   

I've sent in a bug report and i'm waiting for them to get back to me. I really want to play this game! But this is getting most frustrating.  

Share this post


Link to post
Share on other sites
1 hour ago, Myri said:

Hell no I wont block Razer since its the only way I can actually play the game or any action mmo.

 

Agreed. That's the whole reason I'm sticking with Synapse. 

 

Taking out razer is just like taking out 90% of my gaming style because I'm just a casual that depends too much on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now