Sign in to follow this  
MvJesus

Very laggy game.

Recommended Posts

MvJesus   

HI, so i'd like to say that I have a beast of a of a pc link here:  http://bit.ly/1mjVBHi and for whatever reason even with 70ish ping to the NA Dallas servers have very bad lag. please help, thank you :) running windows 10.

Share this post


Link to post
Share on other sites
Killian   

Not clicking a suspicious link, but make sure you turn off V-sync and there should be no lag. I don't get any anyway.

Share this post


Link to post
Share on other sites
syphex97   

He linked his pc build for some reason, could you please tell us what is lagging, is it your pc or is the server latency bad?

Share this post


Link to post
Share on other sites
MvJesus   

yes, linked my pc just to show its not bad. nothing is bottlenecking, nor is my connection to the servers bad either. heres the speedtest link: http://www.speedtest.net/my-result/5006563092

im confused because there shouldnt be any lagging at all by what my system is spitting back as feedback from the game, and network is fine...

Edited by MvJesus

Share this post


Link to post
Share on other sites
MvJesus   

when people dont get the point of a post. -_- maybe i should just make a new one. im saying that iahev 100-120 fps ingame, with normal 70ping. yet, im lagging. so all it was, was proof of me having a good pc. btw, thank you for doing nothing to help the cause.

Share this post


Link to post
Share on other sites

70 ping is ok to play with. Ping mostly depends how far you live away from where the servers are located to. I can't see how you could be lagging with that kind of computer specs. Maybe  its your internet causing trouble.

Share this post


Link to post
Share on other sites
Ord   

What is your overall frames per second ingame?

 

As others have said, turn off V-Sync. It does nothing but lag when turned on.

 

Also, turn down shadows to see if that helps.

 

At 70ms you should have no lag, so this isn't a case of net lag, but rather a case of hardware lag.

 

So it would be better if you wrote down your PC specs rather than posting a link to them. Shouldn't be that hard.

Share this post


Link to post
Share on other sites
MvJesus   

yes, thats what i do not understand. specs, are there. internet stability and speed, there. there technically shouldnt be anything wrong, yet there is. hence why im here. :/

Share this post


Link to post
Share on other sites

The game might not be completely optimized yet, since it is about to be released and they have a lot of things to patch in the upcoming updates.

If it's latency issue, I would advice you to check http://speedtest.net or maybe use a Ethernet cable to see if the connection issue have been fixed.

Edited by Christina

Share this post


Link to post
Share on other sites
MvJesus   

literally just posted the speedtest to the servers where the game is hosted from in the US *facepalm* but thank you, for actually giving some tips :)

Share this post


Link to post
Share on other sites
syphex97   

i don't get it what you have a problem with, is your pc lagging or is the latency lagging?

Edited by syphex97

Share this post


Link to post
Share on other sites

i had the same problem with my PC.  My friend with nearly identical system ran smooth, but somehow my pc had problems with lagging in game. The internet connection was fine as he had no problem (we was on the same network).

After restarting the game and logging into another server and back on - the problem seemed to go away. Dunno if its some on there internal servers there are a bit overloader. 

Share this post


Link to post
Share on other sites

How do you login to another server though?

I remember I had to re log several times before it was alright. I have similar problems with the both of you. 

Share this post


Link to post
Share on other sites
Ord   

As i've already said once, check your ingame FPS to see if it spikes a lot.

 

If your internet connection is fine, then it is a hardware issue.

 

If you have V-Sync turned on, that will also cause ingame lag.

 

You might also want to make sure that all your drivers etc are updated along with your operating system.

Share this post


Link to post
Share on other sites
Hypatios   

If you're on Mushin the reason would be because the server is trying to cope with a full server with a gigantic queue trailing out to the distance so it would be impacting on server performance. 

Share this post


Link to post
Share on other sites
Sign in to follow this