tylery123

LET ME PLAY. ITS BEEN AN ENTIRE DAY

Recommended Posts

I put my email and PW in then press login, and then the launcher closes and nothing happens after that.

How am I supposed to fix this? It was working perfectly fine last night.

Share this post


Link to post
Share on other sites
6 minutes ago, tylery123 said:

I put my email and PW in then press login, and then the launcher closes and nothing happens after that.

How am I supposed to fix this? It was working perfectly fine last night.

You should try, restarting your computer if you havent already. And if you have already then try and repairing files, since they had a hotfix.

Share this post


Link to post
Share on other sites
Liinxy   

Hey tylery123,

 

Have you tried restarting or closing all NCLaunchers and Blade & Soul clients within the Task Manager (CTRL + ALT + DEL)?

 

I will also move this thread to Player to Player Support forum for more player assistance visibility.

 

Share this post


Link to post
Share on other sites
1 minute ago, ColdFeels said:

You should try, restarting your computer if you havent already. And if you have already then try and repairing files, since they had a hotfix.

 

I've tried restarting my computer, and I can't repair because the launcher doesn't get past the part where I put in my username and password. After I put in my account info everything shuts down

Share this post


Link to post
Share on other sites
Just now, Rukkirii said:

Hey tylery123,

 

Have you tried restarting or closing all NCLaunchers and Blade & Soul clients within the Task Manager (CTRL + ALT + DEL)?

 

There aren't any open, just the NCLauncher module, and after I put in my account details it closes in task manager.

Share this post


Link to post
Share on other sites
Liinxy   
50 minutes ago, tylery123 said:

There aren't any open, just the NCLauncher module, and after I put in my account details it closes in task manager.

 

I'm sorry you're having this problem tylery123. Since you are still having issues after the above troubleshooting methods, please submit a ticket to customer support and they will be able to assist you further. You may also try uninstalling and reinstalling the NC launcher: https://support.bladeandsoul.com/hc/en-us/articles/207195856-How-to-re-install-only-the-NCSOFT-Game-Launcher

 

Click here to submit a ticket

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now